summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-02-18 19:42:42 +0000
committerSam James <sam@gentoo.org>2022-02-18 22:47:51 +0000
commit4436dfcd4b7449fb3880f72cc0f94db509ff7457 (patch)
tree24ae274c0e553041cc73ac729f4886e868d8b7df /sci-geosciences/qgis
parentnet-print/cups-filters: add 1.28.12 (diff)
downloadgentoo-4436dfcd4b7449fb3880f72cc0f94db509ff7457.tar.gz
gentoo-4436dfcd4b7449fb3880f72cc0f94db509ff7457.tar.bz2
gentoo-4436dfcd4b7449fb3880f72cc0f94db509ff7457.zip
sci-geosciences/qgis: add 3.22.4
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-geosciences/qgis')
-rw-r--r--sci-geosciences/qgis/Manifest1
-rw-r--r--sci-geosciences/qgis/qgis-3.22.4.ebuild205
2 files changed, 206 insertions, 0 deletions
diff --git a/sci-geosciences/qgis/Manifest b/sci-geosciences/qgis/Manifest
index 940303f8523d..9e380ed22b73 100644
--- a/sci-geosciences/qgis/Manifest
+++ b/sci-geosciences/qgis/Manifest
@@ -3,4 +3,5 @@ DIST qgis-3.22.0.tar.bz2 135469417 BLAKE2B 54fdd8517e37931dcdc81ef1006859d58d9e6
DIST qgis-3.22.1.tar.bz2 136772144 BLAKE2B ba3a5d9db2a487ff10800da0ab12de4b6d3c1dab72e286d0cafef1804429f59e6c80fd05d662e8abadb7216811f3cbe36bb50d54b077a5c4db7cabcb1002a826 SHA512 b49fdab97c707a3bd29c2ad288733373d406fe024e07873e6ba28653a9a8882f58115ae346523b2f07011be312e18bf2643c8f0b7979d4ba8ed07dce4579cba9
DIST qgis-3.22.2.tar.bz2 136903329 BLAKE2B b1991944c05a9035dc91ea3fcc252a43da435199cb37c8a03647666f15dfd2367f2990bdddb2a124559993405ff61b4a110e6fa31da10d33411e24b756b9eb30 SHA512 6d893217d54483018ab5de06cc11da5da3faf24fb863da57a608429a75f3e1c4647dd809ae1bc0a7034e28296a116c8ebcb528b4886b2714e75654415b2f4c74
DIST qgis-3.22.3.tar.bz2 136876983 BLAKE2B 3b57af74829ca35802a09a8d83f4638ccd4d56674151d45e81f0d2af5544a6d59f20c3a68e5508f5bb5e32f5e98bf7f64f2c9f2d72e09a5137be63e4cbcaa1c0 SHA512 8918ee725f4f8d12c4cab009c446e137513b931583bf843356238122e22267211fffee9fd20382fbcb9b613be6d7af22bc0250d9e166ba53dd621e827aafda28
+DIST qgis-3.22.4.tar.bz2 137701974 BLAKE2B f1e7c35ace59b427a29c96eb6304c2e03ef6ad5304832d679f4a51fcca2c4868bd68058aa224be82e0cdef7b4f44fa310daa51e8c207c16de90b4e6536935f54 SHA512 423ba679618876fd4e3d308ad47903b47bfe758e78c01160e9d490121a863b83f5a60f6210fbfea090fb6dac9e42749d2b92777fa2756938bb6ab41fe75377e5
DIST qgis_sample_data-2.8.14.tar.gz 22119181 BLAKE2B 2d0565e91ec8119382bc9ab8e262dc04227fe8289146794891759ff5a32012245270614ba1119a6329fc45cf56852830c2079589309aa3467873f71f5c608eac SHA512 6b2653d5b57ffc2c2317639dac212429840984ac917ca3e452b39aabb99ea106d1a77c1c1dd967244ef16ede9deae751b170affdf08b72239eafed5b8977da3d
diff --git a/sci-geosciences/qgis/qgis-3.22.4.ebuild b/sci-geosciences/qgis/qgis-3.22.4.ebuild
new file mode 100644
index 000000000000..424d7ec8847e
--- /dev/null
+++ b/sci-geosciences/qgis/qgis-3.22.4.ebuild
@@ -0,0 +1,205 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8,9,10} )
+PYTHON_REQ_USE="sqlite"
+
+if [[ ${PV} = *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/${PN}/${PN^^}.git"
+ inherit git-r3
+else
+ SRC_URI="https://qgis.org/downloads/${P}.tar.bz2
+ examples? ( https://qgis.org/downloads/data/qgis_sample_data.tar.gz -> qgis_sample_data-2.8.14.tar.gz )"
+ KEYWORDS="~amd64 ~x86"
+fi
+inherit cmake python-single-r1 xdg
+
+DESCRIPTION="User friendly Geographic Information System"
+HOMEPAGE="https://www.qgis.org/"
+
+LICENSE="GPL-2+ GPL-3+"
+SLOT="0"
+IUSE="3d examples georeferencer grass hdf5 mapserver netcdf opencl oracle polar postgres python qml serial"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE} mapserver? ( python )"
+
+# Disabling test suite because upstream disallow running from install path
+RESTRICT="test"
+
+COMMON_DEPEND="
+ app-crypt/qca:2[qt5(+),ssl]
+ >=dev-db/spatialite-4.2.0
+ dev-db/sqlite:3
+ dev-libs/expat
+ dev-libs/libzip:=
+ dev-libs/protobuf:=
+ dev-libs/qtkeychain[qt5(+)]
+ dev-qt/designer:5
+ dev-qt/qtconcurrent:5
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5[ssl]
+ dev-qt/qtpositioning:5
+ dev-qt/qtprintsupport:5
+ dev-qt/qtsvg:5
+ dev-qt/qtsql:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtxml:5
+ media-gfx/exiv2:=
+ >=sci-libs/gdal-3.0.4:=[geos]
+ sci-libs/geos
+ sci-libs/libspatialindex:=
+ sys-libs/zlib
+ >=sci-libs/proj-4.9.3:=
+ >=x11-libs/qscintilla-2.10.1:=[qt5(+)]
+ >=x11-libs/qwt-6.1.2:6=[qt5(+),svg]
+ 3d? ( dev-qt/qt3d:5 )
+ georeferencer? ( sci-libs/gsl:= )
+ grass? ( =sci-geosciences/grass-7*:= )
+ hdf5? ( sci-libs/hdf5:= )
+ mapserver? ( dev-libs/fcgi )
+ netcdf? ( sci-libs/netcdf:= )
+ opencl? ( virtual/opencl )
+ oracle? (
+ dev-db/oracle-instantclient:=
+ sci-libs/gdal:=[oracle]
+ )
+ polar? ( >=x11-libs/qwtpolar-1.1.1-r1[qt5(+)] )
+ postgres? ( dev-db/postgresql:= )
+ python? (
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ dev-python/future[${PYTHON_USEDEP}]
+ dev-python/httplib2[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/markupsafe[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/owslib[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/PyQt5[designer,gui,network,positioning,printsupport,sql,svg,widgets,${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ >=dev-python/qscintilla-python-2.10.1[qt5(+),${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ <dev-python/sip-5:=[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ >=sci-libs/gdal-2.2.3[python,${PYTHON_USEDEP}]
+ postgres? ( dev-python/psycopg:2[${PYTHON_USEDEP}] )
+ ')
+ )
+ qml? ( dev-qt/qtdeclarative:5 )
+ serial? ( dev-qt/qtserialport:5 )
+"
+DEPEND="${COMMON_DEPEND}
+ dev-qt/qttest:5
+ python? ( ${PYTHON_DEPS} )
+"
+RDEPEND="${COMMON_DEPEND}
+ sci-geosciences/gpsbabel
+"
+BDEPEND="
+ ${PYTHON_DEPS}
+ dev-qt/linguist-tools:5
+ sys-devel/bison
+ sys-devel/flex
+"
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DQGIS_MANUAL_SUBDIR=share/man/
+ -DQGIS_LIB_SUBDIR=$(get_libdir)
+ -DQGIS_PLUGIN_SUBDIR=$(get_libdir)/qgis
+ -DQWT_INCLUDE_DIR=/usr/include/qwt6
+ -DQWT_LIBRARY=/usr/$(get_libdir)/libqwt6-qt5.so
+ -DQGIS_QML_SUBDIR=/usr/$(get_libdir)/qt5/qml
+ -DPEDANTIC=OFF
+ -DUSE_CCACHE=OFF
+ -DWITH_ANALYSIS=ON
+ -DWITH_APIDOC=OFF
+ -DWITH_GUI=ON
+ -DWITH_INTERNAL_MDAL=ON # not packaged, bug 684538
+ -DWITH_QSPATIALITE=ON
+ -DENABLE_TESTS=OFF
+ -DWITH_3D=$(usex 3d)
+ -DWITH_GSL=$(usex georeferencer)
+ -DWITH_GRASS7=$(usex grass)
+ $(cmake_use_find_package hdf5 HDF5)
+ -DWITH_SERVER=$(usex mapserver)
+ $(cmake_use_find_package netcdf NetCDF)
+ -DUSE_OPENCL=$(usex opencl)
+ -DWITH_ORACLE=$(usex oracle)
+ -DWITH_QWTPOLAR=$(usex polar)
+ -DWITH_POSTGRESQL=$(usex postgres)
+ -DWITH_BINDINGS=$(usex python)
+ -DWITH_CUSTOM_WIDGETS=$(usex python)
+ -DWITH_QUICK=$(usex qml)
+ -DWITH_QT5SERIALPORT=$(usex serial)
+ -DWITH_QTWEBKIT=OFF
+ )
+
+ if use grass; then
+ readarray -d'-' -t f <<<"$(best_version sci-geosciences/grass)"
+ readarray -d'.' -t v <<<"${f[2]}"
+ grassdir="grass${v[0]}${v[1]}"
+
+ GRASSDIR=/usr/$(get_libdir)/${grassdir}
+ mycmakeargs+=( -DGRASS_PREFIX7=${GRASSDIR} )
+ fi
+
+ use python && mycmakeargs+=( -DBINDINGS_GLOBAL_INSTALL=ON ) ||
+ mycmakeargs+=( -DWITH_QGIS_PROCESS=OFF ) # FIXME upstream issue #39973
+
+ # bugs 612956, 648726
+ addpredict /dev/dri/renderD128
+ addpredict /dev/dri/renderD129
+
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+
+ insinto /usr/share/mime/packages
+ doins debian/qgis.xml
+
+ if use examples; then
+ docinto examples
+ dodoc -r "${WORKDIR}"/qgis_sample_data/.
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+
+ if use python; then
+ python_optimize
+ python_optimize "${ED}"/usr/share/qgis/python
+ fi
+
+ if use grass; then
+ python_fix_shebang "${ED}"/usr/share/qgis/grass/scripts
+ fi
+}
+
+pkg_postinst() {
+ if use postgres; then
+ elog "If you don't intend to use an external PostGIS server"
+ elog "you should install:"
+ elog " dev-db/postgis"
+ elif use python; then
+ elog "Support of PostgreSQL is disabled."
+ elog "But some installed python-plugins import the psycopg2 module."
+ elog "If you do not need these plugins just disable them"
+ elog "in the Plugins menu, else you need to set USE=\"postgres\""
+ fi
+
+ xdg_pkg_postinst
+}