summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMario Haustein <mario.haustein@hrz.tu-chemnitz.de>2022-08-27 10:04:49 +0200
committerSam James <sam@gentoo.org>2022-08-27 11:52:46 +0100
commit99201b14faf305a88326bbb59343cc4e3b272d1c (patch)
tree03d0d22e5ea30ffa996293207db7f61355b3813d /sci-geosciences/grass
parentsys-cluster/glusterfs: Stabilize 10.2-r2 x86, #866953 (diff)
downloadgentoo-99201b14faf305a88326bbb59343cc4e3b272d1c.tar.gz
gentoo-99201b14faf305a88326bbb59343cc4e3b272d1c.tar.bz2
gentoo-99201b14faf305a88326bbb59343cc4e3b272d1c.zip
sci-geosciences/grass: don't call eautoreconf
Upstream have their own header which autoheader conflicts with. Just use the dist tarball's build system files instead. Closes: https://bugs.gentoo.org/866554 Signed-off-by: Mario Haustein <mario.haustein@hrz.tu-chemnitz.de> Closes: https://github.com/gentoo/gentoo/pull/27030 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-geosciences/grass')
-rw-r--r--sci-geosciences/grass/grass-7.8.7-r2.ebuild (renamed from sci-geosciences/grass/grass-7.8.7-r1.ebuild)8
-rw-r--r--sci-geosciences/grass/grass-8.0.2-r2.ebuild (renamed from sci-geosciences/grass/grass-8.0.2-r1.ebuild)8
-rw-r--r--sci-geosciences/grass/grass-8.2.0-r2.ebuild (renamed from sci-geosciences/grass/grass-8.2.0-r1.ebuild)8
-rw-r--r--sci-geosciences/grass/grass-9999.ebuild8
4 files changed, 24 insertions, 8 deletions
diff --git a/sci-geosciences/grass/grass-7.8.7-r1.ebuild b/sci-geosciences/grass/grass-7.8.7-r2.ebuild
index d254c88caf17..2055352416fa 100644
--- a/sci-geosciences/grass/grass-7.8.7-r1.ebuild
+++ b/sci-geosciences/grass/grass-7.8.7-r2.ebuild
@@ -7,7 +7,7 @@ PYTHON_COMPAT=( python3_{8..10} )
PYTHON_REQ_USE="sqlite" # bug 572440
WX_GTK_VER="3.0-gtk3"
-inherit autotools desktop python-single-r1 toolchain-funcs wxwidgets xdg
+inherit desktop python-single-r1 toolchain-funcs wxwidgets xdg
MY_PM=${PN}$(ver_cut 1-2 ${PV})
MY_PM=${MY_PM/.}
@@ -116,7 +116,11 @@ src_prepare() {
sed -e "s:= python3:= ${EPYTHON}:" -i "${S}/include/Make/Platform.make.in" || die
default
- eautoreconf
+
+ # When patching the build system, avoid running autoheader here. The file
+ # config.in.h is maintained manually upstream. Changes to it may lead to
+ # undefined behavior. See bug #866554.
+ # AT_NOEAUTOHEADER=1 eautoreconf
ebegin "Fixing python shebangs"
python_fix_shebang -q "${S}"
diff --git a/sci-geosciences/grass/grass-8.0.2-r1.ebuild b/sci-geosciences/grass/grass-8.0.2-r2.ebuild
index 4bb9a92f3ba1..64fdec42f03c 100644
--- a/sci-geosciences/grass/grass-8.0.2-r1.ebuild
+++ b/sci-geosciences/grass/grass-8.0.2-r2.ebuild
@@ -7,7 +7,7 @@ PYTHON_COMPAT=( python3_{8..10} )
PYTHON_REQ_USE="sqlite" # bug 572440
WX_GTK_VER="3.0-gtk3"
-inherit autotools desktop python-single-r1 toolchain-funcs wxwidgets xdg
+inherit desktop python-single-r1 toolchain-funcs wxwidgets xdg
DESCRIPTION="A free GIS with raster and vector functionality, as well as 3D vizualization"
HOMEPAGE="https://grass.osgeo.org/"
@@ -129,7 +129,11 @@ src_prepare() {
sed -e "s:= python3:= ${EPYTHON}:" -i "${S}/include/Make/Platform.make.in" || die
default
- eautoreconf
+
+ # When patching the build system, avoid running autoheader here. The file
+ # config.in.h is maintained manually upstream. Changes to it may lead to
+ # undefined behavior. See bug #866554.
+ # AT_NOEAUTOHEADER=1 eautoreconf
ebegin "Fixing python shebangs"
python_fix_shebang -q "${S}"
diff --git a/sci-geosciences/grass/grass-8.2.0-r1.ebuild b/sci-geosciences/grass/grass-8.2.0-r2.ebuild
index 581cd7fa78cb..71dfdbf59d7f 100644
--- a/sci-geosciences/grass/grass-8.2.0-r1.ebuild
+++ b/sci-geosciences/grass/grass-8.2.0-r2.ebuild
@@ -7,7 +7,7 @@ PYTHON_COMPAT=( python3_{8..10} )
PYTHON_REQ_USE="sqlite" # bug 572440
WX_GTK_VER="3.0-gtk3"
-inherit autotools desktop python-single-r1 toolchain-funcs wxwidgets xdg
+inherit desktop python-single-r1 toolchain-funcs wxwidgets xdg
DESCRIPTION="A free GIS with raster and vector functionality, as well as 3D vizualization"
HOMEPAGE="https://grass.osgeo.org/"
@@ -129,7 +129,11 @@ src_prepare() {
sed -e "s:= python3:= ${EPYTHON}:" -i "${S}/include/Make/Platform.make.in" || die
default
- eautoreconf
+
+ # When patching the build system, avoid running autoheader here. The file
+ # config.in.h is maintained manually upstream. Changes to it may lead to
+ # undefined behavior. See bug #866554.
+ # AT_NOEAUTOHEADER=1 eautoreconf
ebegin "Fixing python shebangs"
python_fix_shebang -q "${S}"
diff --git a/sci-geosciences/grass/grass-9999.ebuild b/sci-geosciences/grass/grass-9999.ebuild
index 8b286969e78a..7b5ec1408e74 100644
--- a/sci-geosciences/grass/grass-9999.ebuild
+++ b/sci-geosciences/grass/grass-9999.ebuild
@@ -7,7 +7,7 @@ PYTHON_COMPAT=( python3_{8..10} )
PYTHON_REQ_USE="sqlite" # bug 572440
WX_GTK_VER="3.0-gtk3"
-inherit autotools desktop python-single-r1 toolchain-funcs wxwidgets xdg
+inherit desktop python-single-r1 toolchain-funcs wxwidgets xdg
DESCRIPTION="A free GIS with raster and vector functionality, as well as 3D vizualization"
HOMEPAGE="https://grass.osgeo.org/"
@@ -124,7 +124,11 @@ src_prepare() {
sed -e "s:= python3:= ${EPYTHON}:" -i "${S}/include/Make/Platform.make.in" || die
default
- eautoreconf
+
+ # When patching the build system, avoid running autoheader here. The file
+ # config.in.h is maintained manually upstream. Changes to it may lead to
+ # undefined behavior. See bug #866554.
+ # AT_NOEAUTOHEADER=1 eautoreconf
ebegin "Fixing python shebangs"
python_fix_shebang -q "${S}"