summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2024-10-19 21:43:03 +0300
committerAlexey Shvetsov <alexxy@gentoo.org>2024-10-19 21:43:45 +0300
commit31a956f026856b8b22a993b4abe07fbd89176477 (patch)
tree27b0571f00bbc9e46b8c122fc39f687c81196ac2 /sci-chemistry
parentsci-chemistry/gromacs: Update live version (diff)
downloadgentoo-31a956f026856b8b22a993b4abe07fbd89176477.tar.gz
gentoo-31a956f026856b8b22a993b4abe07fbd89176477.tar.bz2
gentoo-31a956f026856b8b22a993b4abe07fbd89176477.zip
sci-chemistry/gromacs: Correct depend when openmp is enabled
Closes: https://bugs.gentoo.org/927990 Signed-off-by: Alexey Shvetsov <alexxy@gentoo.org>
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/gromacs/gromacs-2020.7-r1.ebuild4
-rw-r--r--sci-chemistry/gromacs/gromacs-2021.7-r1.ebuild4
-rw-r--r--sci-chemistry/gromacs/gromacs-2022.6.ebuild4
-rw-r--r--sci-chemistry/gromacs/gromacs-2023.5.ebuild4
-rw-r--r--sci-chemistry/gromacs/gromacs-2023.9999.ebuild4
-rw-r--r--sci-chemistry/gromacs/gromacs-2024.3.ebuild4
-rw-r--r--sci-chemistry/gromacs/gromacs-2024.9999.ebuild4
-rw-r--r--sci-chemistry/gromacs/gromacs-9999.ebuild4
8 files changed, 32 insertions, 0 deletions
diff --git a/sci-chemistry/gromacs/gromacs-2020.7-r1.ebuild b/sci-chemistry/gromacs/gromacs-2020.7-r1.ebuild
index fa123d04defb..c93e5baf72ef 100644
--- a/sci-chemistry/gromacs/gromacs-2020.7-r1.ebuild
+++ b/sci-chemistry/gromacs/gromacs-2020.7-r1.ebuild
@@ -49,6 +49,10 @@ CDEPEND="
blas? ( virtual/blas )
cuda? ( >=dev-util/nvidia-cuda-toolkit-6.5.14:= )
opencl? ( virtual/opencl )
+ openmp? (
+ sys-devel/gcc[openmp]
+ sys-devel/clang-runtime[openmp]
+ )
fftw? ( sci-libs/fftw:3.0= )
hwloc? ( sys-apps/hwloc:= )
lapack? ( virtual/lapack )
diff --git a/sci-chemistry/gromacs/gromacs-2021.7-r1.ebuild b/sci-chemistry/gromacs/gromacs-2021.7-r1.ebuild
index 1b82d86998ee..8b99117678ed 100644
--- a/sci-chemistry/gromacs/gromacs-2021.7-r1.ebuild
+++ b/sci-chemistry/gromacs/gromacs-2021.7-r1.ebuild
@@ -49,6 +49,10 @@ CDEPEND="
blas? ( virtual/blas )
cuda? ( >=dev-util/nvidia-cuda-toolkit-6.5.14:=[profiler] )
opencl? ( virtual/opencl )
+ openmp? (
+ sys-devel/gcc[openmp]
+ sys-devel/clang-runtime[openmp]
+ )
fftw? ( sci-libs/fftw:3.0= )
hwloc? ( sys-apps/hwloc:= )
lapack? ( virtual/lapack )
diff --git a/sci-chemistry/gromacs/gromacs-2022.6.ebuild b/sci-chemistry/gromacs/gromacs-2022.6.ebuild
index 8ebb3ae9a8dd..92b1f497c860 100644
--- a/sci-chemistry/gromacs/gromacs-2022.6.ebuild
+++ b/sci-chemistry/gromacs/gromacs-2022.6.ebuild
@@ -45,6 +45,10 @@ CDEPEND="
blas? ( virtual/blas )
cuda? ( >=dev-util/nvidia-cuda-toolkit-11:=[profiler] )
opencl? ( virtual/opencl )
+ openmp? (
+ sys-devel/gcc[openmp]
+ sys-devel/clang-runtime[openmp]
+ )
fftw? ( sci-libs/fftw:3.0= )
hwloc? ( sys-apps/hwloc:= )
lapack? ( virtual/lapack )
diff --git a/sci-chemistry/gromacs/gromacs-2023.5.ebuild b/sci-chemistry/gromacs/gromacs-2023.5.ebuild
index a3319899d419..4ee08b22a7f0 100644
--- a/sci-chemistry/gromacs/gromacs-2023.5.ebuild
+++ b/sci-chemistry/gromacs/gromacs-2023.5.ebuild
@@ -45,6 +45,10 @@ CDEPEND="
blas? ( virtual/blas )
cuda? ( >=dev-util/nvidia-cuda-toolkit-11:=[profiler] )
opencl? ( virtual/opencl )
+ openmp? (
+ sys-devel/gcc[openmp]
+ sys-devel/clang-runtime[openmp]
+ )
fftw? ( sci-libs/fftw:3.0= )
hwloc? ( sys-apps/hwloc:= )
lapack? ( virtual/lapack )
diff --git a/sci-chemistry/gromacs/gromacs-2023.9999.ebuild b/sci-chemistry/gromacs/gromacs-2023.9999.ebuild
index a3319899d419..4ee08b22a7f0 100644
--- a/sci-chemistry/gromacs/gromacs-2023.9999.ebuild
+++ b/sci-chemistry/gromacs/gromacs-2023.9999.ebuild
@@ -45,6 +45,10 @@ CDEPEND="
blas? ( virtual/blas )
cuda? ( >=dev-util/nvidia-cuda-toolkit-11:=[profiler] )
opencl? ( virtual/opencl )
+ openmp? (
+ sys-devel/gcc[openmp]
+ sys-devel/clang-runtime[openmp]
+ )
fftw? ( sci-libs/fftw:3.0= )
hwloc? ( sys-apps/hwloc:= )
lapack? ( virtual/lapack )
diff --git a/sci-chemistry/gromacs/gromacs-2024.3.ebuild b/sci-chemistry/gromacs/gromacs-2024.3.ebuild
index 33e343e23e7c..2101629ebc36 100644
--- a/sci-chemistry/gromacs/gromacs-2024.3.ebuild
+++ b/sci-chemistry/gromacs/gromacs-2024.3.ebuild
@@ -45,6 +45,10 @@ CDEPEND="
blas? ( virtual/blas )
cuda? ( >=dev-util/nvidia-cuda-toolkit-11:=[profiler] )
opencl? ( virtual/opencl )
+ openmp? (
+ sys-devel/gcc[openmp]
+ sys-devel/clang-runtime[openmp]
+ )
fftw? ( sci-libs/fftw:3.0= )
hwloc? ( sys-apps/hwloc:= )
lapack? ( virtual/lapack )
diff --git a/sci-chemistry/gromacs/gromacs-2024.9999.ebuild b/sci-chemistry/gromacs/gromacs-2024.9999.ebuild
index 33e343e23e7c..2101629ebc36 100644
--- a/sci-chemistry/gromacs/gromacs-2024.9999.ebuild
+++ b/sci-chemistry/gromacs/gromacs-2024.9999.ebuild
@@ -45,6 +45,10 @@ CDEPEND="
blas? ( virtual/blas )
cuda? ( >=dev-util/nvidia-cuda-toolkit-11:=[profiler] )
opencl? ( virtual/opencl )
+ openmp? (
+ sys-devel/gcc[openmp]
+ sys-devel/clang-runtime[openmp]
+ )
fftw? ( sci-libs/fftw:3.0= )
hwloc? ( sys-apps/hwloc:= )
lapack? ( virtual/lapack )
diff --git a/sci-chemistry/gromacs/gromacs-9999.ebuild b/sci-chemistry/gromacs/gromacs-9999.ebuild
index 64de8d68d1c5..9f4ae599f86b 100644
--- a/sci-chemistry/gromacs/gromacs-9999.ebuild
+++ b/sci-chemistry/gromacs/gromacs-9999.ebuild
@@ -45,6 +45,10 @@ CDEPEND="
blas? ( virtual/blas )
cuda? ( >=dev-util/nvidia-cuda-toolkit-11:=[profiler] )
opencl? ( virtual/opencl )
+ openmp? (
+ sys-devel/gcc[openmp]
+ sys-devel/clang-runtime[openmp]
+ )
fftw? ( sci-libs/fftw:3.0= )
hdf5? ( sci-libs/hdf5 )
hwloc? ( sys-apps/hwloc:= )