summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2022-05-16 10:12:14 +0200
committerDavid Seifert <soap@gentoo.org>2022-05-16 10:12:14 +0200
commit245c3a3bb2b6bcd1e8a047f5a13d0d9fd3c7ce19 (patch)
tree85377d2b66f6e6303f9c58995e23052615a88f16 /sci-chemistry
parentsci-biology/seqan: [QA] use tc-check-openmp correctly (diff)
downloadgentoo-245c3a3bb2b6bcd1e8a047f5a13d0d9fd3c7ce19.tar.gz
gentoo-245c3a3bb2b6bcd1e8a047f5a13d0d9fd3c7ce19.tar.bz2
gentoo-245c3a3bb2b6bcd1e8a047f5a13d0d9fd3c7ce19.zip
sci-chemistry/openbabel: [QA] use tc-check-openmp correctly
Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/openbabel/openbabel-3.1.1_p20210225.ebuild6
-rw-r--r--sci-chemistry/openbabel/openbabel-9999.ebuild6
2 files changed, 10 insertions, 2 deletions
diff --git a/sci-chemistry/openbabel/openbabel-3.1.1_p20210225.ebuild b/sci-chemistry/openbabel/openbabel-3.1.1_p20210225.ebuild
index 97dfa6e9a236..61a6ad498b66 100644
--- a/sci-chemistry/openbabel/openbabel-3.1.1_p20210225.ebuild
+++ b/sci-chemistry/openbabel/openbabel-3.1.1_p20210225.ebuild
@@ -80,8 +80,12 @@ RDEPEND="
)
"
+pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
pkg_setup() {
- use openmp && tc-check-openmp
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
}
prepare_python_bindings() {
diff --git a/sci-chemistry/openbabel/openbabel-9999.ebuild b/sci-chemistry/openbabel/openbabel-9999.ebuild
index 2c73801d2362..956b061aed0f 100644
--- a/sci-chemistry/openbabel/openbabel-9999.ebuild
+++ b/sci-chemistry/openbabel/openbabel-9999.ebuild
@@ -80,8 +80,12 @@ RDEPEND="
)
"
+pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
pkg_setup() {
- use openmp && tc-check-openmp
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
}
prepare_python_bindings() {