summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-chemistry/reduce/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-chemistry/reduce/files')
-rw-r--r--sci-chemistry/reduce/files/3.13.080428-CFLAGS.patch22
-rw-r--r--sci-chemistry/reduce/files/3.13.080428-LDFLAGS.patch11
-rw-r--r--sci-chemistry/reduce/files/3.14.080821-CFLAGS.patch22
3 files changed, 55 insertions, 0 deletions
diff --git a/sci-chemistry/reduce/files/3.13.080428-CFLAGS.patch b/sci-chemistry/reduce/files/3.13.080428-CFLAGS.patch
new file mode 100644
index 000000000000..7daa5336f689
--- /dev/null
+++ b/sci-chemistry/reduce/files/3.13.080428-CFLAGS.patch
@@ -0,0 +1,22 @@
+diff --git a/reduce_src/Makefile b/reduce_src/Makefile
+index 598e367..067ace4 100644
+--- a/reduce_src/Makefile
++++ b/reduce_src/Makefile
+@@ -12,7 +12,7 @@ PROG_FLGS = -DAROMATICS_ACCEPT_HBONDS \
+ # -DDEBUGMOVABLENODE -DDEBUGDOTCOUNTS
+ # -DMINPREDEFINED -DMAXPREDEFINED\
+
+-CFLAGS = $(OPT) $(DEBUG) $(PROG_FLGS) $(DICT_LOC)\
++CXXFLAGS = $(OPT) $(DEBUG) $(PROG_FLGS) $(DICT_LOC)\
+ -I$(PDBHOME) -I$(TOOLHOME)
+ # -Wall
+
+@@ -26,7 +26,7 @@ OBJLIST = GraphToHoldScores.o reduce.o CTab.o ElementInfo.o StdResH.o ResBlk.o A
+ CXX = g++
+
+ .cpp.o:
+- $(CXX) -c $*.cpp $(CFLAGS)
++ $(CXX) -c $*.cpp $(CXXFLAGS)
+
+ OPT = -O3
+ DEBUG = $(CXXDEBUGFLAGS)
diff --git a/sci-chemistry/reduce/files/3.13.080428-LDFLAGS.patch b/sci-chemistry/reduce/files/3.13.080428-LDFLAGS.patch
new file mode 100644
index 000000000000..bcee1a9fe8f3
--- /dev/null
+++ b/sci-chemistry/reduce/files/3.13.080428-LDFLAGS.patch
@@ -0,0 +1,11 @@
+--- reduce_src/Makefile 2009-08-09 10:11:29.000000000 +0200
++++ reduce_src/Makefile.new 2009-08-09 10:13:31.000000000 +0200
+@@ -34,7 +34,7 @@
+ all: reduce
+
+ reduce: $(OBJLIST)
+- $(CXX) -o $@ $(OBJLIST) $(LFLAGS)
++ $(CXX) $(LDFLAGS) -o $@ $(OBJLIST) $(LFLAGS)
+
+ clean:
+ @rm -rf *.o *.ckp ii_files
diff --git a/sci-chemistry/reduce/files/3.14.080821-CFLAGS.patch b/sci-chemistry/reduce/files/3.14.080821-CFLAGS.patch
new file mode 100644
index 000000000000..8294c8ca385d
--- /dev/null
+++ b/sci-chemistry/reduce/files/3.14.080821-CFLAGS.patch
@@ -0,0 +1,22 @@
+diff --git a/reduce_src/Makefile b/reduce_src/Makefile
+index 598e367..067ace4 100644
+--- a/reduce_src/Makefile
++++ b/reduce_src/Makefile
+@@ -12,7 +12,7 @@ PROG_FLGS = -DAROMATICS_ACCEPT_HBONDS \
+ # -DDEBUGMOVABLENODE -DDEBUGDOTCOUNTS
+ # -DMINPREDEFINED -DMAXPREDEFINED\
+
+-CFLAGS = $(OPT) $(DEBUG) $(PROG_FLGS) $(DICT_LOC) $(DICT_LOCOLD)\
++CXXFLAGS = $(OPT) $(DEBUG) $(PROG_FLGS) $(DICT_LOC) $(DICT_LOCOLD)\
+ -I$(PDBHOME) -I$(TOOLHOME)
+ # -Wall
+
+@@ -26,7 +26,7 @@ OBJLIST = GraphToHoldScores.o reduce.o CTab.o ElementInfo.o StdResH.o ResBlk.o A
+ CXX = g++
+
+ .cpp.o:
+- $(CXX) -c $*.cpp $(CFLAGS)
++ $(CXX) -c $*.cpp $(CXXFLAGS)
+
+ OPT = -O3
+ DEBUG = $(CXXDEBUGFLAGS)