summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-chemistry/pymol-plugins-promol
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-chemistry/pymol-plugins-promol')
-rw-r--r--sci-chemistry/pymol-plugins-promol/Manifest1
-rw-r--r--sci-chemistry/pymol-plugins-promol/metadata.xml7
-rw-r--r--sci-chemistry/pymol-plugins-promol/pymol-plugins-promol-3.0.2-r1.ebuild61
3 files changed, 69 insertions, 0 deletions
diff --git a/sci-chemistry/pymol-plugins-promol/Manifest b/sci-chemistry/pymol-plugins-promol/Manifest
new file mode 100644
index 000000000000..30b2014c9f2f
--- /dev/null
+++ b/sci-chemistry/pymol-plugins-promol/Manifest
@@ -0,0 +1 @@
+DIST pymol-plugins-promol-3.0.2.zip 2219295 SHA256 4281131ab5fc5568c1e3984aec4a7022b515334c66adfbc2682df5f0e6a4c2d6 SHA512 e40e9c08e2cb1b223390d751bb1f32069924f1c23aa2b4bdafb6689254e6aa673d4412aca587792f660869f97a389db8a9183033d8b2394c998d0f911104d8d7 WHIRLPOOL 83a3122aaa60b3d81ca8f19dcc4c8bce32190861893c712e517d48053d65009ff001b7bb1bb89b7bbd2504f1cea38999655ddd164defcba0231e805a5c590728
diff --git a/sci-chemistry/pymol-plugins-promol/metadata.xml b/sci-chemistry/pymol-plugins-promol/metadata.xml
new file mode 100644
index 000000000000..4a00a64b40ae
--- /dev/null
+++ b/sci-chemistry/pymol-plugins-promol/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
diff --git a/sci-chemistry/pymol-plugins-promol/pymol-plugins-promol-3.0.2-r1.ebuild b/sci-chemistry/pymol-plugins-promol/pymol-plugins-promol-3.0.2-r1.ebuild
new file mode 100644
index 000000000000..e2d6430c01e1
--- /dev/null
+++ b/sci-chemistry/pymol-plugins-promol/pymol-plugins-promol-3.0.2-r1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-r1
+
+DESCRIPTION="Fast and accurate regognition of active sites"
+HOMEPAGE="http://www.rit.edu/cos/ezviz/ProMOL_dl.html"
+SRC_URI="http://www.rit.edu/cos/ezviz/ProMOL.zip -> ${P}.zip"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux"
+LICENSE="all-rights-reserved"
+IUSE=""
+
+RESTRICT="mirror bindist"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ virtual/pmw[${PYTHON_USEDEP}]
+ sci-chemistry/pymol[${PYTHON_USEDEP}]"
+DEPEND=""
+
+S="${WORKDIR}/ProMOL Folder"
+
+src_prepare() {
+ python_copy_sources
+ preparation() {
+ cd "${BUILD_DIR}" || die
+ sed \
+ -e "s:./modules/pmg_tk/startup:${EPREFIX}/$(python_get_sitedir)/pmg_tk/startup/ProMol:g" \
+ -i ProMOL_302.py || die
+ }
+ python_foreach_impl preparation
+}
+
+src_install(){
+ dodoc *doc
+ dohtml -r Thanks.html EDMHelp.htm Help
+
+ installation() {
+ cd "${BUILD_DIR}" || die
+ python_moduleinto pmg_tk/startup/ProMol
+ python_domodule PDB_List AminoPics Motifs *GIF pdb_entry_type.txt Master.txt Scripts
+ python_moduleinto pmg_tk/startup
+ python_domodule *.py
+ dosym ../../../../../../share/doc/${PF}/html/Help \
+ $(python_get_sitedir)/pmg_tk/startup/ProMol/Help
+ dosym ../../../../../../share/doc/${PF}/html/Thanks.html \
+ $(python_get_sitedir)/pmg_tk/startup/ProMol/Thanks.html
+ dosym ../../../../../../share/doc/${PF}/html/EDMHelp.htm \
+ $(python_get_sitedir)/pmg_tk/startup/ProMol/EDMHelp.htm
+ }
+ python_foreach_impl installation
+}