summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2024-06-13 18:54:18 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2024-06-13 18:54:39 +0300
commit24a606297721d23b50d65b82954b4f8971447b0f (patch)
treea21b0dd460235251f78cf65e691f31e7feeffd13 /sci-chemistry/elem/elem-1.0.3-r3.ebuild
parentx11-themes/kvantum: add 1.1.2 (diff)
downloadgentoo-24a606297721d23b50d65b82954b4f8971447b0f.tar.gz
gentoo-24a606297721d23b50d65b82954b4f8971447b0f.tar.bz2
gentoo-24a606297721d23b50d65b82954b4f8971447b0f.zip
sci-chemistry/elem: EAPI 6 -> 8
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'sci-chemistry/elem/elem-1.0.3-r3.ebuild')
-rw-r--r--sci-chemistry/elem/elem-1.0.3-r3.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/sci-chemistry/elem/elem-1.0.3-r3.ebuild b/sci-chemistry/elem/elem-1.0.3-r3.ebuild
new file mode 100644
index 000000000000..f49bffea4826
--- /dev/null
+++ b/sci-chemistry/elem/elem-1.0.3-r3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="periodic table of the elements"
+HOMEPAGE="http://elem.sourceforge.net/"
+SRC_URI="https://downloads.sourceforge.net/elem/${PN}-src-${PV}-Linux.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 sparc ~x86"
+
+DEPEND="x11-libs/xforms"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-fix-build-system.patch
+ "${FILESDIR}"/${P}-missing-stdlib.patch
+ "${FILESDIR}"/${P}-fno-common.patch
+)
+
+src_configure() {
+ tc-export CC
+}
+
+src_compile() {
+ emake all
+}
+
+src_install() {
+ dobin elem elem-de elem-en
+
+ rm -rf doc/CVS || die
+ HTML_DOCS=( doc/. )
+ einstalldocs
+}