summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2017-10-24 15:15:18 +0200
committerJeroen Roovers <jer@gentoo.org>2017-10-24 15:15:57 +0200
commitcba707ea3f9ccb11c68eb14f1e43b1bc3a3798ea (patch)
treecfe68fee28233de1efce53bdf38f526e0395d771 /sci-calculators/units/units-2.15.ebuild
parentdev-python/future: Mark ~hppa too. (diff)
downloadgentoo-cba707ea3f9ccb11c68eb14f1e43b1bc3a3798ea.tar.gz
gentoo-cba707ea3f9ccb11c68eb14f1e43b1bc3a3798ea.tar.bz2
gentoo-cba707ea3f9ccb11c68eb14f1e43b1bc3a3798ea.zip
sci-calculators/units: Version bump.
Package-Manager: Portage-2.3.12, Repoman-2.3.3
Diffstat (limited to 'sci-calculators/units/units-2.15.ebuild')
-rw-r--r--sci-calculators/units/units-2.15.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/sci-calculators/units/units-2.15.ebuild b/sci-calculators/units/units-2.15.ebuild
new file mode 100644
index 000000000000..4d87f5164edd
--- /dev/null
+++ b/sci-calculators/units/units-2.15.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+inherit eutils python-single-r1
+
+DESCRIPTION="Unit conversion program"
+HOMEPAGE="https://www.gnu.org/software/units/units.html"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="FDL-1.3 GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="+units_cur"
+REQUIRED_USE="units_cur? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="
+ sys-libs/readline:=
+ units_cur? (
+ ${PYTHON_DEPS}
+ dev-python/future[${PYTHON_USEDEP}]
+ )
+"
+DEPEND="
+ ${RDEPEND}
+"
+
+pkg_setup() {
+ use units_cur && python-single-r1_pkg_setup
+}
+
+src_configure() {
+ econf ac_cv_path_PYTHON=no
+}
+
+src_compile() {
+ emake ${PN}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ dodoc ChangeLog NEWS README
+
+ # we're intentionally delaying this since 'make install' would
+ # get confused if we shove 'units_cur' there, and there is no real
+ # need to add more complexity for it
+ if use units_cur; then
+ sed \
+ -e "/^outfile/s|'.*'|'/usr/share/units/currency.units'|g" \
+ -e 's|^#!|&/usr/bin/python|g' \
+ units_cur_inst > units_cur || die
+ python_doscript units_cur
+ fi
+}