summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-07-11 03:40:22 +0100
committerSam James <sam@gentoo.org>2022-07-11 03:40:22 +0100
commit4c42fcee335109e1e656426a5cfd6d4acff5217c (patch)
treeb47351168d8a30a54dac9a056e943099676ca230 /sci-astronomy
parentdev-cpp/commoncpp2: treeclean (diff)
downloadgentoo-4c42fcee335109e1e656426a5cfd6d4acff5217c.tar.gz
gentoo-4c42fcee335109e1e656426a5cfd6d4acff5217c.tar.bz2
gentoo-4c42fcee335109e1e656426a5cfd6d4acff5217c.zip
sci-astronomy/pyephem: add 4.1.3
Bug: https://bugs.gentoo.org/855461 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-astronomy')
-rw-r--r--sci-astronomy/pyephem/Manifest1
-rw-r--r--sci-astronomy/pyephem/pyephem-4.1.3.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/sci-astronomy/pyephem/Manifest b/sci-astronomy/pyephem/Manifest
index c975c283041f..3c0359bd7977 100644
--- a/sci-astronomy/pyephem/Manifest
+++ b/sci-astronomy/pyephem/Manifest
@@ -1,2 +1,3 @@
DIST pyephem-3.7.7.1.tar.gz 1622306 BLAKE2B aefdd7b7e4471140f1c2b5c065f663dfb1095d8d8325e23d4b5b9c683ff7a91020151429a992ad78be897ab738d9bc207afa337b7806fb244d6d6c8a1c680b7f SHA512 ae0d9562f33ee25065b33ea3d4b24a74e32259bebb07edf37deacaa77e6d24b3a7a49e4602393b45a3c7cfc7d8088f038e68e96ec3576a796b5486fc2946ac5a
DIST pyephem-4.1.1.gh.tar.gz 2659977 BLAKE2B e373857d3fb66e742f9db992165dbd1d50afbb6b91588f2cfcd299409d491ef1174c54a182dd59b5a8e298a07312899c8f8b5a8aaa63e6b31deb5f8b1cd3131e SHA512 2539f36b7110cacd6cf95e9ba0be26ca837a66ba81f092d4be01405029adf22478184861f46ecf09d6cd35927140874e0f0d228b06537d05f3e2eddbcb35da85
+DIST pyephem-4.1.3.gh.tar.gz 2660800 BLAKE2B 272a96dfe5debe083274f911737246ea90dc15b12b141e41c018d0b4eff13e548fe1d99cfb75ea7d06d7784cd9cbce7f43149a08de051cd9e12a4b5d6a306607 SHA512 1d113e1adbe5c8175364a29ae405d80005e54a4f60d475534d6721dc51b4f58d314ad161ddaf791614fcd4b0550e4b2142f4e52ec4771ca0d1be6b10f3f8cc4d
diff --git a/sci-astronomy/pyephem/pyephem-4.1.3.ebuild b/sci-astronomy/pyephem/pyephem-4.1.3.ebuild
new file mode 100644
index 000000000000..423ccb34c62e
--- /dev/null
+++ b/sci-astronomy/pyephem/pyephem-4.1.3.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Astronomical routines for the Python programming language"
+HOMEPAGE="https://rhodesmill.org/pyephem/"
+SRC_URI="https://github.com/brandon-rhodes/pyephem/archive/refs/tags/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc"
+
+BDEPEND="doc? ( dev-python/sphinx )"
+
+EPYTEST_DESELECT=(
+ # Can't find its test files (class not loaded properly in test env?)
+ # bug #855461
+ tests/test_jpl.py::JPLTest::runTest
+)
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # Don't install rst files by default
+ sed -i -e "s:'doc/\*\.rst',::" setup.py || die
+ distutils-r1_src_prepare
+}
+
+src_compile() {
+ distutils-r1_src_compile
+ if use doc; then
+ PYTHONPATH=. emake -C ephem/doc html
+ fi
+}
+
+python_test() {
+ cd "${T}" || die
+ epytest --pyargs ephem
+}
+
+src_install() {
+ use doc && HTML_DOCS=( ephem/doc/_build/html/. )
+ distutils-r1_src_install
+}
+
+python_install() {
+ distutils-r1_python_install
+
+ rm -r "${D}$(python_get_sitedir)/ephem/tests" || die
+}