summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-07-23 13:34:01 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-07-23 17:18:47 +0200
commit56f85c343614d9774738f8df9da61d4c9e98fdfd (patch)
treee85e33c4550da26938222218a4ded1790d4f6b1e /ros-meta/ament_cmake/ament_cmake-9999.ebuild
parentdev-ros/ament_cmake_export_targets: initial import (diff)
downloadgentoo-56f85c343614d9774738f8df9da61d4c9e98fdfd.tar.gz
gentoo-56f85c343614d9774738f8df9da61d4c9e98fdfd.tar.bz2
gentoo-56f85c343614d9774738f8df9da61d4c9e98fdfd.zip
ros-meta/ament_cmake: bump to 0.9.6
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'ros-meta/ament_cmake/ament_cmake-9999.ebuild')
-rw-r--r--ros-meta/ament_cmake/ament_cmake-9999.ebuild15
1 files changed, 6 insertions, 9 deletions
diff --git a/ros-meta/ament_cmake/ament_cmake-9999.ebuild b/ros-meta/ament_cmake/ament_cmake-9999.ebuild
index f6fdfb5d439e..960565dee0ad 100644
--- a/ros-meta/ament_cmake/ament_cmake-9999.ebuild
+++ b/ros-meta/ament_cmake/ament_cmake-9999.ebuild
@@ -1,11 +1,11 @@
-# Copyright 2019 Gentoo Authors
+# Copyright 2019-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python{3_6,3_7} )
+PYTHON_COMPAT=( python{3_6,3_7,3_8} )
-inherit cmake-utils python-r1
+inherit cmake python-r1
ROS_PN="ament_cmake"
if [ "${PV#9999}" != "${PV}" ] ; then
@@ -38,6 +38,7 @@ DEPEND="
dev-ros/ament_cmake_export_interfaces
dev-ros/ament_cmake_export_libraries
dev-ros/ament_cmake_export_link_flags
+ dev-ros/ament_cmake_export_targets
dev-ros/ament_cmake_libraries
dev-ros/ament_cmake_python
dev-ros/ament_cmake_target_dependencies
@@ -54,10 +55,6 @@ BDEPEND="${DEPEND}"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
src_configure() {
- # This is a build tool that does not install python-related files
- # ... but we need to propagate the deps and use python3 to build it.
- local pyimpl="${PYTHON_COMPAT[0]}"
- python_export "${pyimpl}" EPYTHON PYTHON
- python_wrapper_setup
- cmake-utils_src_configure
+ python_setup
+ cmake_src_configure
}