summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2020-06-12 10:20:41 -0400
committerRick Farina <zerochaos@gentoo.org>2020-06-12 10:20:51 -0400
commite51169a5b007c8b6726c82bfd6768e576cc50823 (patch)
tree7c8f02c224bdb124ca1aa121ab78fcc259327616 /net-wireless
parentnet-wireless/ubertooth: fix bug #706598 (diff)
downloadgentoo-e51169a5b007c8b6726c82bfd6768e576cc50823.tar.gz
gentoo-e51169a5b007c8b6726c82bfd6768e576cc50823.tar.bz2
gentoo-e51169a5b007c8b6726c82bfd6768e576cc50823.zip
net-wireless/ubertooth: remove old
Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Rick Farina <zerochaos@gentoo.org>
Diffstat (limited to 'net-wireless')
-rw-r--r--net-wireless/ubertooth/Manifest1
-rw-r--r--net-wireless/ubertooth/ubertooth-2018.08.1.ebuild69
2 files changed, 0 insertions, 70 deletions
diff --git a/net-wireless/ubertooth/Manifest b/net-wireless/ubertooth/Manifest
index 7b66637368b0..c515f6316081 100644
--- a/net-wireless/ubertooth/Manifest
+++ b/net-wireless/ubertooth/Manifest
@@ -1,2 +1 @@
-DIST ubertooth-2018-08-R1.tar.xz 701928 BLAKE2B 031d4178693a4c1734f72d5c7292ba58f0c74b9a57cc1841ecdec286d547994847dc7badabc3efce6eff9a34abe505d942b561bc3291b3cda0f29a42fa7dd340 SHA512 630707583b4fa0683d3f2a40e06697546897e603bd27842886897949ffeaff252d3b34040dee6b8b3319f9bed65eb706f57b885d7a6719fc9cb993e7c1d9c203
DIST ubertooth-2018-12-R1.tar.xz 704208 BLAKE2B 7a17830a0ed417a737d78aa22c5a6a270a67b350a3a5e9a0aebabd4b38547d8d35551e061ea3d5260996f8fe1a366c75c8773d5e3a6abf37a0930f93200da3fc SHA512 409fdb403d6a3fa84b92757e0fd8672b1403ba3d24888fbde4d6d6923d8e0796914c20d38e2fc58909f81fcb8a0b6290bcf91282bb02354c310e6e91ad85e23b
diff --git a/net-wireless/ubertooth/ubertooth-2018.08.1.ebuild b/net-wireless/ubertooth/ubertooth-2018.08.1.ebuild
deleted file mode 100644
index 845ee09d3793..000000000000
--- a/net-wireless/ubertooth/ubertooth-2018.08.1.ebuild
+++ /dev/null
@@ -1,69 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-
-inherit cmake-utils udev
-
-HOMEPAGE="http://ubertooth.sourceforge.net/"
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="+bluez static-libs +ubertooth1-firmware +udev"
-
-DEPEND="bluez? ( net-wireless/bluez:= )
- >=net-libs/libbtbb-${PV}:=[static-libs?]
- static-libs? ( dev-libs/libusb[static-libs] )
- virtual/libusb:1="
-RDEPEND="${DEPEND}
- udev? ( virtual/udev )"
-
-MY_PV=${PV/\./-}
-MY_PV=${MY_PV/./-R}
-if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="https://github.com/greatscottgadgets/ubertooth.git"
- inherit git-r3
- S="${WORKDIR}/${P}/host"
-else
- S="${WORKDIR}/${PN}-${MY_PV}/host"
- SRC_URI="https://github.com/greatscottgadgets/${PN}/releases/download/${MY_PV}/${PN}-${MY_PV}.tar.xz"
- KEYWORDS="~amd64 ~arm ~x86"
-fi
-DESCRIPTION="open source wireless development platform suitable for Bluetooth experimentation"
-
-#readd firmware building, but do it right
-#USE="-fortran -mudflap -nls -openmp -multilib" crossdev --without-headers --genv 'EXTRA_ECONF="--with-mode=thumb --with-cpu=cortex-m3 --with-float=soft"' -s4 -t arm-cortexm3-eabi
-
-src_configure() {
- local mycmakeargs=(
- -DUSE_BLUEZ=$(usex bluez)
- -DBUILD_STATIC_LIB=$(usex static-libs)
- -DINSTALL_UDEV_RULES=$(usex udev)
- -DENABLE_PYTHON=false
- )
- if use udev; then
- mycmakeargs+=(
- -DUDEV_RULES_GROUP=usb
- -DUDEV_RULES_PATH="$(get_udevdir)/rules.d"
- )
- fi
- cmake-utils_src_configure
-}
-
-src_install() {
- cmake-utils_src_install
-
- insinto /usr/share/${PN}
- pushd "${WORKDIR}/${PN}-${MY_PV}" || die
- if [[ ${PV} == "9999" ]] ; then
- ewarn "Firmware isn't available for git releases, we assume you are already"
- ewarn "on the latest and/or can build your own."
- else
- use ubertooth1-firmware && newins ubertooth-one-firmware-bin/bluetooth_rxtx.dfu ${PN}-one-${PV}-bluetooth_rxtx.dfu
- use ubertooth1-firmware && newins ubertooth-one-firmware-bin/bluetooth_rx_only.dfu ${PN}-one-${PV}-bluetooth_rx_only.dfu
- fi
- popd
-
- elog "Everyone can read from the ubertooth, but to talk to it"
- elog "your user needs to be in the usb group."
-}