summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2021-02-26 10:51:34 -0500
committerRick Farina <zerochaos@gentoo.org>2021-02-26 10:56:25 -0500
commit78f902b250d0b3307851c8c6b671900602476082 (patch)
treee5ba03c79a4090143773598072da51e3316d7795 /net-wireless/soapyrtlsdr/soapyrtlsdr-0.3.2.ebuild
parentnet-wireless/soapyplutosdr: ebuild modernization (diff)
downloadgentoo-78f902b250d0b3307851c8c6b671900602476082.tar.gz
gentoo-78f902b250d0b3307851c8c6b671900602476082.tar.bz2
gentoo-78f902b250d0b3307851c8c6b671900602476082.zip
net-wireless/soapyrtlsdr: bump
ebuild modernization Package-Manager: Portage-3.0.15, Repoman-3.0.2 Signed-off-by: Rick Farina <zerochaos@gentoo.org>
Diffstat (limited to 'net-wireless/soapyrtlsdr/soapyrtlsdr-0.3.2.ebuild')
-rw-r--r--net-wireless/soapyrtlsdr/soapyrtlsdr-0.3.2.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/net-wireless/soapyrtlsdr/soapyrtlsdr-0.3.2.ebuild b/net-wireless/soapyrtlsdr/soapyrtlsdr-0.3.2.ebuild
new file mode 100644
index 000000000000..c69214fbee0c
--- /dev/null
+++ b/net-wireless/soapyrtlsdr/soapyrtlsdr-0.3.2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="SoapySDR RTL-SDR Support Module"
+HOMEPAGE="https://github.com/pothosware/SoapyRTLSDR"
+
+if [ "${PV}" = "9999" ]; then
+ EGIT_REPO_URI="https://github.com/pothosware/SoapyRTLSDR.git"
+ inherit git-r3
+else
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="https://github.com/pothosware/SoapyRTLSDR/archive/soapy-rtl-sdr-${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}"/SoapyRTLSDR-soapy-rtl-sdr-"${PV}"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="net-wireless/soapysdr:=
+ net-wireless/rtl-sdr"
+DEPEND="${RDEPEND}"