summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-12-27 21:15:48 +0000
committerSam James <sam@gentoo.org>2023-12-27 21:16:27 +0000
commit3b1d01dc53eaff37a58faf406d66494343551b3e (patch)
treed0749d7f6f19b5804b0fbe9ef887440d9c0d817f /net-voip
parentRevert "net-misc/asterisk: remove masked IUSE="dahdi"" (diff)
downloadgentoo-3b1d01dc53eaff37a58faf406d66494343551b3e.tar.gz
gentoo-3b1d01dc53eaff37a58faf406d66494343551b3e.tar.bz2
gentoo-3b1d01dc53eaff37a58faf406d66494343551b3e.zip
Revert "net-voip/yate: remove masked IUSE="dahdi""
This reverts commit 546086695a47bbf4d0f3899c5b5476a4cfb3e07c. Removal date was not yet met & there are plans to possibly resurrect dahdi, per the bug. Bug: https://bugs.gentoo.org/914477 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-voip')
-rw-r--r--net-voip/yate/metadata.xml1
-rw-r--r--net-voip/yate/yate-6.2.0.ebuild7
-rw-r--r--net-voip/yate/yate-9999.ebuild7
3 files changed, 9 insertions, 6 deletions
diff --git a/net-voip/yate/metadata.xml b/net-voip/yate/metadata.xml
index c19d9da8fdd7..44d8957443cb 100644
--- a/net-voip/yate/metadata.xml
+++ b/net-voip/yate/metadata.xml
@@ -6,6 +6,7 @@
<name>Radio</name>
</maintainer>
<use>
+ <flag name="dahdi">Enable Dahdi driver</flag>
<flag name="zaptel">Enable Zaptel driver</flag>
<flag name="wpcard">Enable Wanpipe card driver</flag>
<flag name="tdmcard">Enable TDMV API card driver</flag>
diff --git a/net-voip/yate/yate-6.2.0.ebuild b/net-voip/yate/yate-6.2.0.ebuild
index 6856c69337a4..57f0c59da403 100644
--- a/net-voip/yate/yate-6.2.0.ebuild
+++ b/net-voip/yate/yate-6.2.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -19,7 +19,7 @@ fi
LICENSE="GPL-2"
SLOT="0/${PV}"
-IUSE="doc cpu_flags_x86_sse2 sctp zaptel wpcard tdmcard wanpipe +ilbc +ilbc-webrtc +isac-float isac-fixed postgres mysql +gsm +speex spandsp +ssl +zlib amrnb"
+IUSE="doc cpu_flags_x86_sse2 sctp dahdi zaptel wpcard tdmcard wanpipe +ilbc +ilbc-webrtc +isac-float isac-fixed postgres mysql +gsm +speex spandsp +ssl +zlib amrnb"
RDEPEND="
postgres? ( dev-db/postgresql:* )
@@ -30,6 +30,7 @@ RDEPEND="
zlib? ( sys-libs/zlib )
ilbc? ( media-libs/libilbc:= )
spandsp? ( >=media-libs/spandsp-0.0.3 )
+ dahdi? ( net-misc/dahdi )
"
DEPEND="${RDEPEND}"
BDEPEND="
@@ -60,7 +61,7 @@ src_configure() {
--without-libqt4 \
$(use_enable cpu_flags_x86_sse2 sse2) \
$(use_enable sctp) \
- --disable-dahdi \
+ $(use_enable dahdi) \
$(use_enable zaptel) \
$(use_enable wpcard) \
$(use_enable tdmcard) \
diff --git a/net-voip/yate/yate-9999.ebuild b/net-voip/yate/yate-9999.ebuild
index 6856c69337a4..57f0c59da403 100644
--- a/net-voip/yate/yate-9999.ebuild
+++ b/net-voip/yate/yate-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -19,7 +19,7 @@ fi
LICENSE="GPL-2"
SLOT="0/${PV}"
-IUSE="doc cpu_flags_x86_sse2 sctp zaptel wpcard tdmcard wanpipe +ilbc +ilbc-webrtc +isac-float isac-fixed postgres mysql +gsm +speex spandsp +ssl +zlib amrnb"
+IUSE="doc cpu_flags_x86_sse2 sctp dahdi zaptel wpcard tdmcard wanpipe +ilbc +ilbc-webrtc +isac-float isac-fixed postgres mysql +gsm +speex spandsp +ssl +zlib amrnb"
RDEPEND="
postgres? ( dev-db/postgresql:* )
@@ -30,6 +30,7 @@ RDEPEND="
zlib? ( sys-libs/zlib )
ilbc? ( media-libs/libilbc:= )
spandsp? ( >=media-libs/spandsp-0.0.3 )
+ dahdi? ( net-misc/dahdi )
"
DEPEND="${RDEPEND}"
BDEPEND="
@@ -60,7 +61,7 @@ src_configure() {
--without-libqt4 \
$(use_enable cpu_flags_x86_sse2 sse2) \
$(use_enable sctp) \
- --disable-dahdi \
+ $(use_enable dahdi) \
$(use_enable zaptel) \
$(use_enable wpcard) \
$(use_enable tdmcard) \