summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2016-07-01 06:00:56 +0800
committerYixun Lan <dlan@gentoo.org>2016-07-01 06:00:56 +0800
commit4a468d37d7246cb5ee68be3430bf25ab19192feb (patch)
treec62382206c107c460bde4be0ed0b3e830a696208 /net-proxy
parentnet-proxy/shadowsocks-libev: version bump 2.4.7 (diff)
downloadgentoo-4a468d37d7246cb5ee68be3430bf25ab19192feb.tar.gz
gentoo-4a468d37d7246cb5ee68be3430bf25ab19192feb.tar.bz2
gentoo-4a468d37d7246cb5ee68be3430bf25ab19192feb.zip
net-proxy/shadowsocks-libev: introduce USE=system-libs, unbundle libs
Package-Manager: portage-2.3.0_rc1
Diffstat (limited to 'net-proxy')
-rw-r--r--net-proxy/shadowsocks-libev/metadata.xml1
-rw-r--r--net-proxy/shadowsocks-libev/shadowsocks-libev-2.4.7-r1.ebuild (renamed from net-proxy/shadowsocks-libev/shadowsocks-libev-2.4.7.ebuild)8
2 files changed, 8 insertions, 1 deletions
diff --git a/net-proxy/shadowsocks-libev/metadata.xml b/net-proxy/shadowsocks-libev/metadata.xml
index 7baa3e59735b..bb9595db01a6 100644
--- a/net-proxy/shadowsocks-libev/metadata.xml
+++ b/net-proxy/shadowsocks-libev/metadata.xml
@@ -10,6 +10,7 @@
<use>
<flag name="openssl">Use <pkg>dev-libs/openssl</pkg> as crypto backend</flag>
<flag name="polarssl">Use <pkg>net-libs/polarssl</pkg> as crypto backend</flag>
+ <flag name="system-libs">Use system libraries instead of the ones included in the upstream distribution</flag>
</use>
<upstream>
<remote-id type="github">shadowsocks/shadowsocks-libev</remote-id>
diff --git a/net-proxy/shadowsocks-libev/shadowsocks-libev-2.4.7.ebuild b/net-proxy/shadowsocks-libev/shadowsocks-libev-2.4.7-r1.ebuild
index c761cba2a4d6..398664df171e 100644
--- a/net-proxy/shadowsocks-libev/shadowsocks-libev-2.4.7.ebuild
+++ b/net-proxy/shadowsocks-libev/shadowsocks-libev-2.4.7-r1.ebuild
@@ -15,11 +15,16 @@ SRC_URI="https://github.com/shadowsocks/${PN}/archive/${MY_PV}.tar.gz -> ${P}.ta
LICENSE="GPL-3+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="debug +openssl polarssl"
+IUSE="debug +openssl polarssl +system-libs"
DEPEND="openssl? ( dev-libs/openssl:= )
polarssl? ( net-libs/polarssl )
<sys-kernel/linux-headers-4.5
+ system-libs? (
+ dev-libs/libev
+ dev-libs/libsodium
+ net-libs/udns
+ )
"
RDEPEND="${DEPEND}"
@@ -28,6 +33,7 @@ REQUIRED_USE=" ^^ ( openssl polarssl )"
src_configure() {
econf \
$(use_enable debug assert) \
+ $(use_enable system-libs system-shared-lib) \
--with-crypto-library=$(usex openssl openssl polarssl)
}