summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Savchenko <bircoph@gentoo.org>2019-03-22 12:14:40 +0300
committerAndrew Savchenko <bircoph@gentoo.org>2019-03-22 12:14:40 +0300
commit1dd75d1fd7792bc465d4c3b13fd631742361b970 (patch)
tree57d54b4a3244357b8bb1d8955147fa3ef8ae3300 /net-proxy/tsocks/files
parentpackage.mask: Last rite net-vpn/aiccu (diff)
downloadgentoo-1dd75d1fd7792bc465d4c3b13fd631742361b970.tar.gz
gentoo-1dd75d1fd7792bc465d4c3b13fd631742361b970.tar.bz2
gentoo-1dd75d1fd7792bc465d4c3b13fd631742361b970.zip
net-proxy/tsocks: fix configure options handling
As reported in bug 672644, --enable(disable)-envconf option is not properly handled due to autoconf script mishandling. Review shown other options are not handled properly as well. This revision bump contains fix for all configure options. Closes: https://bugs.gentoo.org/672644 Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Andrew Savchenko <bircoph@gentoo.org>
Diffstat (limited to 'net-proxy/tsocks/files')
-rw-r--r--net-proxy/tsocks/files/tsocks-1.8_beta5-options.patch47
1 files changed, 47 insertions, 0 deletions
diff --git a/net-proxy/tsocks/files/tsocks-1.8_beta5-options.patch b/net-proxy/tsocks/files/tsocks-1.8_beta5-options.patch
new file mode 100644
index 000000000000..d1f524b3147c
--- /dev/null
+++ b/net-proxy/tsocks/files/tsocks-1.8_beta5-options.patch
@@ -0,0 +1,47 @@
+--- tsocks-1.8/configure.in.orig 2002-07-16 02:51:03.000000000 +0400
++++ tsocks-1.8/configure.in 2019-03-22 01:38:19.065438275 +0300
+@@ -154,36 +154,36 @@
+ ])
+ ])
+
+-if test "${enable_socksdns}" = "yes"; then
++if test "x${enable_socksdns}" = "xyes"; then
+ AC_DEFINE(USE_SOCKS_DNS)
+ fi
+
+-if test "x${enable_envconf}" = "x"; then
++if test "x${enable_envconf}" = "xyes"; then
+ AC_DEFINE(ALLOW_ENV_CONFIG)
+ fi
+
+-if test "${enable_oldmethod}" = "yes"; then
++if test "x${enable_oldmethod}" = "xyes"; then
+ AC_DEFINE(USE_OLD_DLSYM)
+ oldmethod="yes"
+ fi
+
+-if test "x${enable_debug}" = "x"; then
++if test "x${enable_debug}" = "xyes"; then
+ AC_DEFINE(ALLOW_MSG_OUTPUT)
+ fi
+
+-if test "x${enable_hostnames}" = "x"; then
++if test "x${enable_hostnames}" = "xyes"; then
+ AC_DEFINE(HOSTNAMES)
+ fi
+
+-if test "${enable_socksdns}" = "yes" -a \
+- "x${enable_hostnames}" = "x" ; then
++if test "x${enable_socksdns}" = "xyes" -a \
++ "x${enable_hostnames}" != "xno" ; then
+ AC_MSG_ERROR("--enable-socksdns is not valid without --disable-hostnames")
+ fi
+
+ dnl If we have to use the old method of overriding connect (i.e no
+ dnl RTLD_NEXT) we need to know the location of the library that
+ dnl contains connect(), select(), poll() and close()
+-if test "${oldmethod}" = "yes"; then
++if test "x${oldmethod}" = "xyes"; then
+ dnl We need to find the path to the library, to do
+ dnl this we use find on the usual suspects, i.e /lib and
+ dnl /usr/lib