summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2024-06-15 19:24:52 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2024-06-15 19:28:25 +0300
commita4f6c15343a9908e32c6b6aa447b52a5d1e91993 (patch)
treebfac6cf162c03cf99871f3d047c2d229a896ac3a /net-print
parentdev-python/css-parser: enable py3.13 (diff)
downloadgentoo-a4f6c15343a9908e32c6b6aa447b52a5d1e91993.tar.gz
gentoo-a4f6c15343a9908e32c6b6aa447b52a5d1e91993.tar.bz2
gentoo-a4f6c15343a9908e32c6b6aa447b52a5d1e91993.zip
net-print/foomatic-db: EAPI 6 -> 8
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'net-print')
-rw-r--r--net-print/foomatic-db/foomatic-db-4.0.20190226-r1.ebuild47
-rw-r--r--net-print/foomatic-db/foomatic-db-4.0.20190226.ebuild41
2 files changed, 47 insertions, 41 deletions
diff --git a/net-print/foomatic-db/foomatic-db-4.0.20190226-r1.ebuild b/net-print/foomatic-db/foomatic-db-4.0.20190226-r1.ebuild
new file mode 100644
index 000000000000..89e2462b4179
--- /dev/null
+++ b/net-print/foomatic-db/foomatic-db-4.0.20190226-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Printer information files for foomatic-db-engine to generate ppds"
+HOMEPAGE="http://www.linuxprinting.org/foomatic.html"
+SRC_URI="http://www.openprinting.org/download/foomatic/${PN}-$(ver_rs 2 -).tar.xz"
+S=${WORKDIR}/${PN}-$(ver_cut 3)
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm ~hppa ~ia64 ~mips ppc ppc64 ~s390 sparc x86"
+
+RDEPEND="
+ net-print/foomatic-db-engine
+ !net-print/foo2zjs[hp2600n]
+"
+
+src_prepare() {
+ # ppd files do not belong to this package
+ rm -r db/source/PPD || die
+ default
+}
+
+src_configure() {
+ econf \
+ --disable-gzip-ppds \
+ --disable-ppds-to-cups
+}
+
+src_install() {
+ default
+
+ cd "${ED}"/usr/share/foomatic/db/source/ || die
+ rm -r PPD || die
+ # Avoid collision with foo2zjs, bug 185486
+ local FILES=(
+ driver/foo2{hp,lava,xqx,zjs}.xml
+ printer/Generic-ZjStream_Printer.xml
+ printer/HP-Color_LaserJet_{1500,1600,2600n}.xml
+ printer/HP-LaserJet_10{00,05,18,20,22}.xml printer/HP-LaserJet_M1005_MFP.xml
+ printer/Minolta-Color_PageWorks_Pro_L.xml printer/Minolta-magicolor_2{20,30,43}0_DL.xml
+ printer/Samsung-CLP-{3,6}00.xml
+ )
+ rm -v "${FILES[@]}" || die
+}
diff --git a/net-print/foomatic-db/foomatic-db-4.0.20190226.ebuild b/net-print/foomatic-db/foomatic-db-4.0.20190226.ebuild
deleted file mode 100644
index b559732c3d5b..000000000000
--- a/net-print/foomatic-db/foomatic-db-4.0.20190226.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit versionator
-
-DESCRIPTION="Printer information files for foomatic-db-engine to generate ppds"
-HOMEPAGE="http://www.linuxprinting.org/foomatic.html"
-SRC_URI="http://www.openprinting.org/download/foomatic/${PN}-$(replace_version_separator 2 -).tar.xz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm ~hppa ~ia64 ~mips ppc ppc64 ~s390 sparc x86"
-IUSE=""
-
-DEPEND=""
-RDEPEND="
- net-print/foomatic-db-engine
- !net-print/foo2zjs[hp2600n]"
-
-S="${WORKDIR}/${PN}-$(get_version_component_range 3 ${PV})"
-
-src_prepare() {
- # ppd files do not belong to this package
- rm -r db/source/PPD || die
- default
-}
-
-src_configure() {
- econf \
- --disable-gzip-ppds \
- --disable-ppds-to-cups
-}
-
-src_install() {
- default
- rmdir "${ED}"/usr/share/foomatic/db/source/PPD || die
- # Avoid collision with foo2zjs, bug 185486
- rm "${ED}"/usr/share/foomatic/db/source/{driver/foo2{hp,lava,xqx,zjs}.xml,printer/{Generic-ZjStream_Printer,HP-{Color_LaserJet_{1500,1600,2600n},LaserJet_{10{00,05,18,20,22},M1005_MFP}},Minolta-{Color_PageWorks_Pro_L,magicolor_2{20,30,43}0_DL},Samsung-CLP-{3,6}00}.xml} || die
-}