summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolić <jsmolic@gentoo.org>2022-01-12 21:53:04 +0100
committerJakov Smolić <jsmolic@gentoo.org>2022-01-12 22:31:17 +0100
commit4d73f12f08f5ba7edeed58f5b5fd02e38346ad97 (patch)
tree2afa3ab7a8fa97b4b7741b69e51f93bcbfa78c8f /net-print
parentwww-client/chromium: promote M98 to beta channel (diff)
downloadgentoo-4d73f12f08f5ba7edeed58f5b5fd02e38346ad97.tar.gz
gentoo-4d73f12f08f5ba7edeed58f5b5fd02e38346ad97.tar.bz2
gentoo-4d73f12f08f5ba7edeed58f5b5fd02e38346ad97.zip
net-print/foomatic-db-engine: Port to EAPI 8
Closes: https://bugs.gentoo.org/819276 Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
Diffstat (limited to 'net-print')
-rw-r--r--net-print/foomatic-db-engine/files/4.0.7-perl-module.patch2
-rw-r--r--net-print/foomatic-db-engine/files/4.0.7-respect-ldflag.patch4
-rw-r--r--net-print/foomatic-db-engine/foomatic-db-engine-4.0.12-r1.ebuild (renamed from net-print/foomatic-db-engine/foomatic-db-engine-4.0.12.ebuild)34
3 files changed, 20 insertions, 20 deletions
diff --git a/net-print/foomatic-db-engine/files/4.0.7-perl-module.patch b/net-print/foomatic-db-engine/files/4.0.7-perl-module.patch
index dbb53feb2a87..172f37fc42d3 100644
--- a/net-print/foomatic-db-engine/files/4.0.7-perl-module.patch
+++ b/net-print/foomatic-db-engine/files/4.0.7-perl-module.patch
@@ -1,5 +1,3 @@
-diff --git a/Makefile.in b/Makefile.in
-index 3014185..81e090d 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -42,7 +42,7 @@ LOCAL_LIBDIR=@LOCAL_LIBDIR@
diff --git a/net-print/foomatic-db-engine/files/4.0.7-respect-ldflag.patch b/net-print/foomatic-db-engine/files/4.0.7-respect-ldflag.patch
index 9e6071276a4e..7a62faabc684 100644
--- a/net-print/foomatic-db-engine/files/4.0.7-respect-ldflag.patch
+++ b/net-print/foomatic-db-engine/files/4.0.7-respect-ldflag.patch
@@ -1,5 +1,5 @@
---- foomatic-db-engine-4.0.2/Makefile.in.orig 2009-07-23 11:45:28.487999828 +0200
-+++ foomatic-db-engine-4.0.2/Makefile.in 2009-07-23 11:45:53.939525006 +0200
+--- a/Makefile.in
++++ b/Makefile.in
@@ -231,10 +231,10 @@
( cd lib && $(PERL) Makefile.PL verbose INSTALLDIRS=$(PERL_INSTALLDIRS) )
diff --git a/net-print/foomatic-db-engine/foomatic-db-engine-4.0.12.ebuild b/net-print/foomatic-db-engine/foomatic-db-engine-4.0.12-r1.ebuild
index 02025f3d87b6..ff3713e2c096 100644
--- a/net-print/foomatic-db-engine/foomatic-db-engine-4.0.12.ebuild
+++ b/net-print/foomatic-db-engine/foomatic-db-engine-4.0.12-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=8
-inherit epatch perl-module versionator autotools
+inherit autotools perl-module
DESCRIPTION="Generates ppds out of xml foomatic printer description files"
HOMEPAGE="http://www.linuxprinting.org/foomatic.html"
@@ -12,52 +12,54 @@ SRC_URI="http://www.openprinting.org/download/foomatic/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha amd64 arm ~hppa ~ia64 ~mips ppc ppc64 ~s390 sparc x86"
-IUSE=""
-DEPEND="net-print/cups
+BDEPEND="
+ net-print/cups
virtual/pkgconfig"
RDEPEND="
dev-libs/libxml2
>=net-print/cups-filters-1.0.43-r1[foomatic]
"
+DEPEND="${RDEPEND}"
PDEPEND="net-print/foomatic-db"
src_prepare() {
- epatch \
+ default
+ eapply \
"${FILESDIR}"/4.0.7-perl-module.patch \
"${FILESDIR}"/4.0.7-respect-ldflag.patch \
"${FILESDIR}"/4.0.12-use-pkgconfig.patch
sed -i -e "s:@LIB_CUPS@:$(cups-config --serverbin):" Makefile.in || die
eautoreconf
- cd lib
+ cd lib || die
perl-module_src_prepare
}
src_configure() {
default
- emake defaults
- cd lib
+ cd lib || die
perl-module_src_configure
}
src_compile() {
+ emake defaults
default
- cd lib
+ cd lib || die
perl-module_src_compile
}
+src_test() {
+ cd lib || die
+ perl-module_src_test
+}
+
src_install() {
default
dodoc USAGE
- cd lib
+ cd lib || die
perl-module_src_install
}
-
-src_test() {
- cd lib
- perl-module_src_test
-}