summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Norris <briannorris@chromium.org>2016-01-19 15:09:31 -0500
committerMike Frysinger <vapier@gentoo.org>2016-01-19 15:10:29 -0500
commit0df2c1ffc08a1cc7089b9ca7abfffd7d2b6d45e9 (patch)
treeb24d7ab6688b7bf40f0c2087a314245dd1b26512 /net-print/foomatic-db-engine/files
parentnet-print/foomatic-db-engine: switch to `default` (diff)
downloadgentoo-0df2c1ffc08a1cc7089b9ca7abfffd7d2b6d45e9.tar.gz
gentoo-0df2c1ffc08a1cc7089b9ca7abfffd7d2b6d45e9.tar.bz2
gentoo-0df2c1ffc08a1cc7089b9ca7abfffd7d2b6d45e9.zip
net-print/foomatic-db-engine: use pkg-config to locate libxml2 libs
This fixes up cross-compiling issues by utilizing standard pkg-config files to locate libxml2 settings rather than `libxml2-config`.
Diffstat (limited to 'net-print/foomatic-db-engine/files')
-rw-r--r--net-print/foomatic-db-engine/files/4.0.12-use-pkgconfig.patch35
1 files changed, 35 insertions, 0 deletions
diff --git a/net-print/foomatic-db-engine/files/4.0.12-use-pkgconfig.patch b/net-print/foomatic-db-engine/files/4.0.12-use-pkgconfig.patch
new file mode 100644
index 000000000000..146932200197
--- /dev/null
+++ b/net-print/foomatic-db-engine/files/4.0.12-use-pkgconfig.patch
@@ -0,0 +1,35 @@
+https://bugs.linuxfoundation.org/show_bug.cgi?id=1339
+
+From: Brian Norris <computersforpeace@gmail.com>
+Date: Fri, 15 Jan 2016 11:12:03 -0800
+Subject: [PATCH] configure.ac: use pkg-config instead of xml2-config
+
+The former is much more standard, and libxml2 ships a .pc file.
+
+Leave libxml alone, since I haven't tested it, and it may not ship a .pc
+file.
+---
+ configure.ac | 8 +-------
+ 1 file changed, 1 insertion(+), 7 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 1562ee61b9d5..0ed5323ff2e7 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -22,12 +22,7 @@ dnl LIBS="$LIBS"
+ # Test for libxml
+ #
+ xml_version=
+-AC_PATH_PROG(XML2_CONFIG, xml2-config)
+-if test ! -z "$XML2_CONFIG"; then
+- xml_version=libxml2
+- XML_CFLAGS=`$XML2_CONFIG --cflags`
+- XML_LIBS=`$XML2_CONFIG --libs`
+-fi
++PKG_CHECK_MODULES(XML, libxml-2.0, [xml_version=libxml2])
+ if test -z "$xml_version"; then
+ AC_PATH_PROG(XML_CONFIG, xml-config)
+ if test ! -z "$XML_CONFIG"; then
+--
+2.1.2
+