summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Roman <davidroman96@gmail.com>2019-04-18 20:24:45 +0200
committerMichał Górny <mgorny@gentoo.org>2019-04-19 13:32:23 +0200
commit3e23aa3c804387233551d7d754ade8c49a13733d (patch)
treebf63be8bf101843be1dcd670ea645acc95e19ad1 /net-p2p/go-ipfs-bin/go-ipfs-bin-0.4.20.ebuild
parentnet-libs/nghttp2: Fixed build against ~dev-libst/boost-1.70.0 (diff)
downloadgentoo-3e23aa3c804387233551d7d754ade8c49a13733d.tar.gz
gentoo-3e23aa3c804387233551d7d754ade8c49a13733d.tar.bz2
gentoo-3e23aa3c804387233551d7d754ade8c49a13733d.zip
net-p2p/go-ipfs-bin: verbump to 0.4.20
Package-Manager: Portage-2.3.63, Repoman-2.3.12 Signed-off-by: David Roman <davidroman96@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/11733 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'net-p2p/go-ipfs-bin/go-ipfs-bin-0.4.20.ebuild')
-rw-r--r--net-p2p/go-ipfs-bin/go-ipfs-bin-0.4.20.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/net-p2p/go-ipfs-bin/go-ipfs-bin-0.4.20.ebuild b/net-p2p/go-ipfs-bin/go-ipfs-bin-0.4.20.ebuild
new file mode 100644
index 000000000000..d19ef9ab7104
--- /dev/null
+++ b/net-p2p/go-ipfs-bin/go-ipfs-bin-0.4.20.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit bash-completion-r1 systemd user
+
+DESCRIPTION="Main implementation of IPFS"
+HOMEPAGE="https://ipfs.io/"
+SRC_URI="amd64? ( https://dist.ipfs.io/go-ipfs/v${PV}/go-ipfs_v${PV}_linux-amd64.tar.gz )
+ x86? ( https://dist.ipfs.io/go-ipfs/v${PV}/go-ipfs_v${PV}_linux-386.tar.gz )
+ arm? ( https://dist.ipfs.io/go-ipfs/v${PV}/go-ipfs_v${PV}_linux-arm.tar.gz )
+
+ https://raw.githubusercontent.com/ipfs/go-ipfs/v${PV}/misc/completion/ipfs-completion.bash -> ${P}.bash"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~arm ~x86"
+
+RDEPEND="sys-fs/fuse"
+S="${WORKDIR}/go-ipfs"
+
+QA_PREBUILT="/usr/bin/ipfs"
+
+src_install() {
+ dobin ipfs
+
+ systemd_dounit "${FILESDIR}/ipfs.service"
+ newinitd "${FILESDIR}/ipfs.init" ipfs
+ newconfd "${FILESDIR}/ipfs.confd" ipfs
+
+ newbashcomp "${DISTDIR}/${P}.bash" "ipfs"
+ keepdir /var/log/ipfs
+}
+
+pkg_preinst() {
+ enewgroup ipfs
+ enewuser ipfs "" "" /var/lib/ipfs ipfs
+
+ fowners -R ipfs:ipfs /var/log/ipfs
+}
+
+pkg_postinst() {
+ elog 'To be able to use the ipfs service you will need to create the ipfs repository'
+ elog '(eg: su -s /bin/sh -c "ipfs init -e" ipfs)'
+ elog 'or change IPFS_PATH of /etc/conf.d/ipfs with another with proper permissions.'
+}