summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2019-10-09 16:52:51 -0400
committerCraig Andrews <candrews@gentoo.org>2019-10-11 11:07:09 -0400
commit0636a6c1baa2467b6642ea60227ba5af62388bb0 (patch)
tree483f6dd4711100850c9af7d57f153cc6e7a62e59 /net-p2p/deluge
parentdev-libs/gecode: Remove last-rited pkg (diff)
downloadgentoo-0636a6c1baa2467b6642ea60227ba5af62388bb0.tar.gz
gentoo-0636a6c1baa2467b6642ea60227ba5af62388bb0.tar.bz2
gentoo-0636a6c1baa2467b6642ea60227ba5af62388bb0.zip
net-p2p/deluge: 2.0.3 version bump
Closes: https://bugs.gentoo.org/688024 Closes: https://github.com/gentoo/gentoo/pull/12548 Closes: https://github.com/gentoo/gentoo/pull/9327 Closes: https://github.com/gentoo/gentoo/pull/13243 Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'net-p2p/deluge')
-rw-r--r--net-p2p/deluge/Manifest1
-rw-r--r--net-p2p/deluge/deluge-2.0.3.ebuild133
-rw-r--r--net-p2p/deluge/deluge-9999.ebuild56
-rw-r--r--net-p2p/deluge/files/deluge-2.0.3-UI-status.patch31
-rw-r--r--net-p2p/deluge/files/deluge-2.0.3-setup.py.patch11
-rw-r--r--net-p2p/deluge/metadata.xml4
6 files changed, 205 insertions, 31 deletions
diff --git a/net-p2p/deluge/Manifest b/net-p2p/deluge/Manifest
index 9f49e45f37be..437ebf60a93b 100644
--- a/net-p2p/deluge/Manifest
+++ b/net-p2p/deluge/Manifest
@@ -1 +1,2 @@
DIST deluge-1.3.15.tar.bz2 1775913 BLAKE2B 9d5224766051d52b6e075dcafab5716793081c78ba69da616fc98f2c463ddc7676b2c2ce8f54b81e1480cf4344582245733033cf5927a9692bc43ec0a23f0001 SHA512 1d0f93a8c5081b807a390f79101d7f26751b0dfc47efe4c3573541014f9e5969461e2d421d17646c17fb81eb4f66f25f5ddce63b9bd226989adb7d7506146bda
+DIST deluge-2.0.3.tar.xz 1777624 BLAKE2B d090e63e7e18c7b420e1c4239c833512a04a72e8b2c494bc8a3a03a3b7a03050eed894de84d7a26a416417b0c874a82809398fcaf57972b1056e2fcceb9d092d SHA512 3abec24495b22ec10649865c7ce7c3271224c7d25c0647b43f3c177b7ccb45d4c5c593f8c89d8bc8eac85ae5dc737f9960827587912dd527bb96100304a7d480
diff --git a/net-p2p/deluge/deluge-2.0.3.ebuild b/net-p2p/deluge/deluge-2.0.3.ebuild
new file mode 100644
index 000000000000..f347e4c3ee39
--- /dev/null
+++ b/net-p2p/deluge/deluge-2.0.3.ebuild
@@ -0,0 +1,133 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+PYTHON_COMPAT=( python2_7 python3_{5,6} )
+DISTUTILS_SINGLE_IMPL=1
+inherit distutils-r1 systemd
+
+DESCRIPTION="BitTorrent client with a client/server model"
+HOMEPAGE="https://deluge-torrent.org/"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://git.deluge-torrent.org/${PN}"
+else
+ SRC_URI="http://download.deluge-torrent.org/source/2.0/${P}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="console geoip gtk libnotify sound webinterface"
+REQUIRED_USE="
+ ${PYTHON_REQUIRED_USE}
+ libnotify? ( gtk )
+ sound? ( gtk )
+"
+
+DEPEND="net-libs/libtorrent-rasterbar[python,${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-util/intltool
+ dev-python/wheel[${PYTHON_USEDEP}]
+ acct-group/deluge
+ acct-user/deluge"
+RDEPEND="dev-python/chardet[${PYTHON_USEDEP}]
+ dev-python/distro[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ dev-python/pyxdg[${PYTHON_USEDEP}]
+ dev-python/rencode[${PYTHON_USEDEP}]
+ dev-python/setproctitle[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ >=dev-python/twisted-17.1.0[crypt,${PYTHON_USEDEP}]
+ >=dev-python/zope-interface-4.4.2[${PYTHON_USEDEP}]
+ geoip? ( dev-python/geoip-python[${PYTHON_USEDEP}] )
+ gtk? (
+ sound? ( dev-python/pygame[${PYTHON_USEDEP}] )
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ gnome-base/librsvg
+ libnotify? ( x11-libs/libnotify )
+ )
+ net-libs/libtorrent-rasterbar[python,${PYTHON_USEDEP}]
+ webinterface? ( dev-python/mako[${PYTHON_USEDEP}] )"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-2.0.3-setup.py.patch"
+ "${FILESDIR}/${PN}-2.0.3-UI-status.patch"
+)
+
+python_prepare_all() {
+ local args=(
+ -e "/Compiling po file/a \\\tuptoDate = False"
+ )
+ sed -i "${args[@]}" -- 'setup.py' || die
+ args=(
+ -e 's|"new_release_check": True|"new_release_check": False|'
+ -e 's|"check_new_releases": True|"check_new_releases": False|'
+ -e 's|"show_new_releases": True|"show_new_releases": False|'
+ )
+ sed -i "${args[@]}" -- 'deluge/core/preferencesmanager.py' || die
+
+ distutils-r1_python_prepare_all
+}
+
+esetup.py() {
+ # bug 531370: deluge has its own plugin system. No need to relocate its egg info files.
+ # Override this call from the distutils-r1 eclass.
+ # This does not respect the distutils-r1 API. DONOT copy this example.
+ set -- "${PYTHON}" setup.py "$@"
+ echo "$@"
+ "$@" || die
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ if ! use console ; then
+ rm -rf "${D}/usr/$(get_libdir)/python2.7/site-packages/deluge/ui/console/" || die
+ rm -f "${D}/usr/bin/deluge-console" || die
+ rm -f "${D}/usr/share/man/man1/deluge-console.1" ||die
+ fi
+ if ! use gtk ; then
+ rm -rf "${D}/usr/$(get_libdir)/python2.7/site-packages/deluge/ui/gtkui/" || die
+ rm -rf "${D}/usr/share/icons/" || die
+ rm -f "${D}/usr/bin/deluge-gtk" || die
+ rm -f "${D}/usr/share/man/man1/deluge-gtk.1" || die
+ rm -f "${D}/usr/share/applications/deluge.desktop" || die
+ fi
+ if use webinterface; then
+ newinitd "${FILESDIR}/deluge-web.init" deluge-web
+ newconfd "${FILESDIR}/deluge-web.conf" deluge-web
+ systemd_newunit "${FILESDIR}/deluge-web.service-2" deluge-web.service
+ systemd_install_serviced "${FILESDIR}/deluge-web.service.conf"
+ else
+ rm -rf "${D}/usr/$(get_libdir)/python2.7/site-packages/deluge/ui/web/" || die
+ rm -f "${D}/usr/bin/deluge-web" || die
+ rm -f "${D}/usr/share/man/man1/deluge-web.1" || die
+ fi
+ newinitd "${FILESDIR}"/deluged.init-2 deluged
+ newconfd "${FILESDIR}"/deluged.conf-2 deluged
+ systemd_newunit "${FILESDIR}"/deluged.service-2 deluged.service
+ systemd_install_serviced "${FILESDIR}"/deluged.service.conf
+}
+
+pkg_postinst() {
+ elog
+ elog "If, after upgrading, deluge doesn't work, please remove the"
+ elog "'~/.config/deluge' directory and try again, but make a backup"
+ elog "first!"
+ elog
+ elog "To start the daemon either run 'deluged' as user"
+ elog "or modify /etc/conf.d/deluged and run"
+ elog "/etc/init.d/deluged start as root"
+ elog "You can still use deluge the old way"
+ elog
+ elog "Systemd unit files for deluged and deluge-web no longer source"
+ elog "/etc/conf.d/deluge* files. Environment variable customization now"
+ elog "happens in /etc/systemd/system/deluged.service.d/00gentoo.conf"
+ elog "and /etc/systemd/system/deluge-web.service.d/00gentoo.conf"
+ elog
+ elog "For more information look at https://dev.deluge-torrent.org/wiki/Faq"
+ elog
+}
diff --git a/net-p2p/deluge/deluge-9999.ebuild b/net-p2p/deluge/deluge-9999.ebuild
index 9989834d9973..f347e4c3ee39 100644
--- a/net-p2p/deluge/deluge-9999.ebuild
+++ b/net-p2p/deluge/deluge-9999.ebuild
@@ -1,24 +1,21 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
+EAPI="7"
-PYTHON_COMPAT=( python2_7 )
+PYTHON_COMPAT=( python2_7 python3_{5,6} )
DISTUTILS_SINGLE_IMPL=1
-PLOCALES="af ar ast be bg bn bs ca cs cy da de el en_AU en_CA en_GB eo es et eu fa fi fo fr fy ga gl he hi hr hu id is it iu ja ka kk km kn ko ku ky la lb lt lv mk ml ms nap nb nds nl nn oc pl pms pt pt_BR ro ru si sk sl sr sv ta te th tl tlh tr uk ur vi zh_CN zh_HK zh_TW"
-inherit distutils-r1 eutils systemd l10n
+inherit distutils-r1 systemd
DESCRIPTION="BitTorrent client with a client/server model"
HOMEPAGE="https://deluge-torrent.org/"
if [[ ${PV} == 9999 ]]; then
inherit git-r3
- EGIT_REPO_URI="git://deluge-torrent.org/${PN}.git
- http://git.deluge-torrent.org/${PN}"
- SRC_URI=""
+ EGIT_REPO_URI="https://git.deluge-torrent.org/${PN}"
else
- SRC_URI="http://download.deluge-torrent.org/source/${P}.tar.bz2"
- KEYWORDS="~amd64 ~arm ~ppc ~sparc ~x86"
+ SRC_URI="http://download.deluge-torrent.org/source/2.0/${P}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
fi
LICENSE="GPL-2"
@@ -26,37 +23,41 @@ SLOT="0"
IUSE="console geoip gtk libnotify sound webinterface"
REQUIRED_USE="
${PYTHON_REQUIRED_USE}
- sound? ( gtk )
libnotify? ( gtk )
+ sound? ( gtk )
"
-PATCHES=(
- "${FILESDIR}/${PN}-1.3.12-fix_scheduler_plugin.patch"
-)
-CDEPEND=">=net-libs/libtorrent-rasterbar-0.14.9[python,${PYTHON_USEDEP}]"
-DEPEND="${CDEPEND}
+DEPEND="net-libs/libtorrent-rasterbar[python,${PYTHON_USEDEP}]
dev-python/setuptools[${PYTHON_USEDEP}]
dev-util/intltool
+ dev-python/wheel[${PYTHON_USEDEP}]
acct-group/deluge
acct-user/deluge"
-RDEPEND="${CDEPEND}
- dev-python/chardet[${PYTHON_USEDEP}]
+RDEPEND="dev-python/chardet[${PYTHON_USEDEP}]
+ dev-python/distro[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
dev-python/pyopenssl[${PYTHON_USEDEP}]
dev-python/pyxdg[${PYTHON_USEDEP}]
+ dev-python/rencode[${PYTHON_USEDEP}]
dev-python/setproctitle[${PYTHON_USEDEP}]
- || ( >=dev-python/twisted-16.0.0[${PYTHON_USEDEP}]
- >=dev-python/twisted-web-13.0[${PYTHON_USEDEP}]
- )
- geoip? ( dev-libs/geoip )
+ dev-python/six[${PYTHON_USEDEP}]
+ >=dev-python/twisted-17.1.0[crypt,${PYTHON_USEDEP}]
+ >=dev-python/zope-interface-4.4.2[${PYTHON_USEDEP}]
+ geoip? ( dev-python/geoip-python[${PYTHON_USEDEP}] )
gtk? (
sound? ( dev-python/pygame[${PYTHON_USEDEP}] )
- dev-python/pygobject:2[${PYTHON_USEDEP}]
- >=dev-python/pygtk-2.12[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
gnome-base/librsvg
- libnotify? ( dev-python/notify-python[${PYTHON_USEDEP}] )
+ libnotify? ( x11-libs/libnotify )
)
+ net-libs/libtorrent-rasterbar[python,${PYTHON_USEDEP}]
webinterface? ( dev-python/mako[${PYTHON_USEDEP}] )"
+PATCHES=(
+ "${FILESDIR}/${PN}-2.0.3-setup.py.patch"
+ "${FILESDIR}/${PN}-2.0.3-UI-status.patch"
+)
+
python_prepare_all() {
local args=(
-e "/Compiling po file/a \\\tuptoDate = False"
@@ -69,13 +70,6 @@ python_prepare_all() {
)
sed -i "${args[@]}" -- 'deluge/core/preferencesmanager.py' || die
- local loc_dir="${S}/deluge/i18n"
- l10n_find_plocales_changes "${loc_dir}" "" ".po"
- rm_loc() {
- rm -vf "${loc_dir}/${1}.po" || die
- }
- l10n_for_each_disabled_locale_do rm_loc
-
distutils-r1_python_prepare_all
}
diff --git a/net-p2p/deluge/files/deluge-2.0.3-UI-status.patch b/net-p2p/deluge/files/deluge-2.0.3-UI-status.patch
new file mode 100644
index 000000000000..bef102062a04
--- /dev/null
+++ b/net-p2p/deluge/files/deluge-2.0.3-UI-status.patch
@@ -0,0 +1,31 @@
+From 53391b513f96ce3b8e9cc55f63e5db0c57b6e839 Mon Sep 17 00:00:00 2001
+From: Andrew Stone <a@stoney.io>
+Date: Wed, 3 Jul 2019 16:55:40 -0700
+Subject: [PATCH] [GTK] Fix ordering in status tab
+
+---
+ deluge/ui/gtk3/glade/main_window.tabs.ui | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/deluge/ui/gtk3/glade/main_window.tabs.ui b/deluge/ui/gtk3/glade/main_window.tabs.ui
+index 30bd395bd..e9a4b60a1 100644
+--- a/deluge/ui/gtk3/glade/main_window.tabs.ui
++++ b/deluge/ui/gtk3/glade/main_window.tabs.ui
+@@ -112,7 +112,7 @@
+ </object>
+ <packing>
+ <property name="left_attach">1</property>
+- <property name="top_attach">0</property>
++ <property name="top_attach">3</property>
+ </packing>
+ </child>
+ <child>
+@@ -312,7 +312,7 @@
+ </object>
+ <packing>
+ <property name="left_attach">1</property>
+- <property name="top_attach">3</property>
++ <property name="top_attach">0</property>
+ </packing>
+ </child>
+ <child>
diff --git a/net-p2p/deluge/files/deluge-2.0.3-setup.py.patch b/net-p2p/deluge/files/deluge-2.0.3-setup.py.patch
new file mode 100644
index 000000000000..dba520f61c01
--- /dev/null
+++ b/net-p2p/deluge/files/deluge-2.0.3-setup.py.patch
@@ -0,0 +1,11 @@
+diff -ur deluge-2.0.3.orig/setup.py deluge-2.0.3/setup.py
+--- deluge-2.0.3.orig/setup.py 2019-07-25 18:19:04.624650797 +0200
++++ deluge-2.0.3/setup.py 2019-07-25 18:19:42.984276752 +0200
+@@ -221,7 +221,6 @@
+ )
+
+ print('Compiling po files from %s...' % po_dir)
+- uptoDate = False
+ for path, names, filenames in os.walk(po_dir):
+ for f in filenames:
+ upto_date = False
diff --git a/net-p2p/deluge/metadata.xml b/net-p2p/deluge/metadata.xml
index 5a74432b6fe5..d528c24819ad 100644
--- a/net-p2p/deluge/metadata.xml
+++ b/net-p2p/deluge/metadata.xml
@@ -9,6 +9,10 @@
<email>k_f@gentoo.org</email>
<name>Kristian Fiskerstrand</name>
</maintainer>
+ <maintainer type="person">
+ <email>candrews@gentoo.org</email>
+ <name>Craig Andrews</name>
+ </maintainer>
<maintainer type="project">
<email>proxy-maint@gentoo.org</email>
<name>Gentoo Proxy Maintainers Project</name>