summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2015-11-27 15:06:37 -0500
committerAnthony G. Basile <blueness@gentoo.org>2015-11-27 15:08:39 -0500
commit3121d9bc59a2ba614c279b0591bffd4dd95852a4 (patch)
tree9c3728bd71fd935facd3710e6e6c7f50102ee866 /net-p2p/bitcoind/bitcoind-0.11.2.ebuild
parentnet-p2p/bitcoin-cli: remove older unstable versions (diff)
downloadgentoo-3121d9bc59a2ba614c279b0591bffd4dd95852a4.tar.gz
gentoo-3121d9bc59a2ba614c279b0591bffd4dd95852a4.tar.bz2
gentoo-3121d9bc59a2ba614c279b0591bffd4dd95852a4.zip
net-p2p/bitcoind: version bump to 0.11.2
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'net-p2p/bitcoind/bitcoind-0.11.2.ebuild')
-rw-r--r--net-p2p/bitcoind/bitcoind-0.11.2.ebuild71
1 files changed, 71 insertions, 0 deletions
diff --git a/net-p2p/bitcoind/bitcoind-0.11.2.ebuild b/net-p2p/bitcoind/bitcoind-0.11.2.ebuild
new file mode 100644
index 000000000000..ae38e8ce005b
--- /dev/null
+++ b/net-p2p/bitcoind/bitcoind-0.11.2.ebuild
@@ -0,0 +1,71 @@
+# Copyright 2010-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+BITCOINCORE_COMMITHASH="7e278929df53e1fb4191bc5ba3176a177ce718bf"
+BITCOINCORE_LJR_DATE="20151118"
+BITCOINCORE_IUSE="addrindex examples ljr test upnp +wallet zeromq"
+BITCOINCORE_ADDRINDEX_DIFF="7e278929df53e1fb4191bc5ba3176a177ce718bf...fddd278524c96aac9de63edeae5aef247ece4af4"
+BITCOINCORE_ADDRINDEX_PATCHFILE="bitcoin-addrindex-v0.11.2.patch"
+BITCOINCORE_POLICY_PATCHES="cpfp dcmp rbf spamfilter"
+BITCOINCORE_NEED_LEVELDB=1
+BITCOINCORE_NEED_LIBSECP256K1=1
+inherit bash-completion-r1 bitcoincore user systemd
+
+DESCRIPTION="Original Bitcoin crypto-currency wallet for automated services"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~mips ~ppc ~x86 ~amd64-linux ~x86-linux"
+
+pkg_setup() {
+ local UG='bitcoin'
+ enewgroup "${UG}"
+ enewuser "${UG}" -1 -1 /var/lib/bitcoin "${UG}"
+}
+
+src_prepare() {
+ sed -i 's/have bitcoind &&//;s/^\(complete -F _bitcoind bitcoind\) bitcoin-cli$/\1/' contrib/${PN}.bash-completion || die
+ bitcoincore_src_prepare
+}
+
+src_configure() {
+ bitcoincore_conf \
+ --with-daemon
+}
+
+src_install() {
+ bitcoincore_src_install
+
+ insinto /etc/bitcoin
+ newins "${FILESDIR}/bitcoin.conf" bitcoin.conf
+ fowners bitcoin:bitcoin /etc/bitcoin/bitcoin.conf
+ fperms 600 /etc/bitcoin/bitcoin.conf
+
+ newconfd "contrib/init/bitcoind.openrcconf" ${PN}
+ newinitd "contrib/init/bitcoind.openrc" ${PN}
+ systemd_dounit "${FILESDIR}/bitcoind.service"
+
+ keepdir /var/lib/bitcoin/.bitcoin
+ fperms 700 /var/lib/bitcoin
+ fowners bitcoin:bitcoin /var/lib/bitcoin/
+ fowners bitcoin:bitcoin /var/lib/bitcoin/.bitcoin
+ dosym /etc/bitcoin/bitcoin.conf /var/lib/bitcoin/.bitcoin/bitcoin.conf
+
+ dodoc doc/assets-attribution.md doc/bips.md doc/tor.md
+ doman contrib/debian/manpages/{bitcoind.1,bitcoin.conf.5}
+
+ use zeromq && dodoc doc/zmq.md
+
+ newbashcomp contrib/${PN}.bash-completion ${PN}
+
+ if use examples; then
+ docinto examples
+ dodoc -r contrib/{bitrpc,qos,spendfrom,tidy_datadir.sh}
+ use zeromq && dodoc -r contrib/zmq
+ fi
+
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}/bitcoind.logrotate-r1" bitcoind
+}