summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-news/rsstail
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-news/rsstail')
-rw-r--r--net-news/rsstail/Manifest1
-rw-r--r--net-news/rsstail/metadata.xml9
-rw-r--r--net-news/rsstail/rsstail-1.8.ebuild32
3 files changed, 42 insertions, 0 deletions
diff --git a/net-news/rsstail/Manifest b/net-news/rsstail/Manifest
new file mode 100644
index 000000000000..9df4de8be389
--- /dev/null
+++ b/net-news/rsstail/Manifest
@@ -0,0 +1 @@
+DIST rsstail-1.8.tgz 5085 SHA256 19284f3eca4bfa649f53848e19e6ee134bce17ccf2a22919cc8c600684877801 SHA512 9a603b384f866fec55ea57572f15aadc467133e12509ec36fe034e1bce89fd1ff3d4982a34d44621413d374ebb17f30e7192c4f1e463f0b05ee2d9537f2a8dbc WHIRLPOOL df022333d8ef01a223540fddb247d4cd283cd74428d4f8185cba7b6c6f29e10d5014104a428c417bd7e5111c5f048b9374455e9ca4d6e4aaba7fdf44a76ae3e8
diff --git a/net-news/rsstail/metadata.xml b/net-news/rsstail/metadata.xml
new file mode 100644
index 000000000000..351ed5142b29
--- /dev/null
+++ b/net-news/rsstail/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>net-news</herd>
+ <longdescription lang="en">
+ RSSTail is more or less an rss reader: it monitors an rss-feed and if it
+ detects a new entry it'll emit only that new entry.
+ </longdescription>
+</pkgmetadata>
diff --git a/net-news/rsstail/rsstail-1.8.ebuild b/net-news/rsstail/rsstail-1.8.ebuild
new file mode 100644
index 000000000000..e162f03636dc
--- /dev/null
+++ b/net-news/rsstail/rsstail-1.8.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit toolchain-funcs
+
+DESCRIPTION="A tail-like RSS-reader"
+HOMEPAGE="http://www.vanheusden.com/rsstail/"
+SRC_URI="http://www.vanheusden.com/${PN}/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND=">=net-libs/libmrss-0.17.1"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS} -DVERSION=\\\"\$(VERSION)\\\"" \
+ LDFLAGS="${LDFLAGS} -lmrss"
+}
+
+src_install() {
+ dobin rsstail
+ doman rsstail.1
+ newdoc readme.txt README
+}