summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2020-01-11 12:27:51 -0500
committerMike Gilbert <floppym@gentoo.org>2020-01-11 12:36:08 -0500
commitb9f7df9e9c531dd6d7f29b315cd1af6a5a48d854 (patch)
treef0b865f9e8a31947063011b14de73debef901780 /net-nds/rpcbind/rpcbind-9999.ebuild
parentapp-editors/xemacs: Use EAPI=7 and use utf-8 for info (diff)
downloadgentoo-b9f7df9e9c531dd6d7f29b315cd1af6a5a48d854.tar.gz
gentoo-b9f7df9e9c531dd6d7f29b315cd1af6a5a48d854.tar.bz2
gentoo-b9f7df9e9c531dd6d7f29b315cd1af6a5a48d854.zip
net-nds/rpcbind: fix detection of rpcsvc/mount.h
Dropped ~riscv keyword due to sys-fs/quota. Closes: https://bugs.gentoo.org/665222 Package-Manager: Portage-2.3.84_p2, Repoman-2.3.20_p24 Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'net-nds/rpcbind/rpcbind-9999.ebuild')
-rw-r--r--net-nds/rpcbind/rpcbind-9999.ebuild10
1 files changed, 8 insertions, 2 deletions
diff --git a/net-nds/rpcbind/rpcbind-9999.ebuild b/net-nds/rpcbind/rpcbind-9999.ebuild
index 7e3bbeae8e85..59bcc41863e0 100644
--- a/net-nds/rpcbind/rpcbind-9999.ebuild
+++ b/net-nds/rpcbind/rpcbind-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit systemd
+inherit flag-o-matic systemd
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="git://linux-nfs.org/~steved/rpcbind.git"
@@ -25,6 +25,7 @@ CDEPEND=">=net-libs/libtirpc-0.2.3:=
systemd? ( sys-apps/systemd:= )
tcpd? ( sys-apps/tcp-wrappers )"
DEPEND="${CDEPEND}
+ sys-fs/quota[rpc]
virtual/pkgconfig"
RDEPEND="${CDEPEND}
selinux? ( sec-policy/selinux-rpcbind )"
@@ -45,6 +46,11 @@ src_configure() {
$(use_enable warmstarts)
$(use_enable tcpd libwrap)
)
+
+ # Allow configure to find /usr/include/rpc/rpc.h in rpcsvc/mount.h
+ # https://bugs.gentoo.org/665222
+ append-cppflags "$($(tc-getPKG_CONFIG) --cflags libtirpc)"
+
econf "${myeconfargs[@]}"
}