summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2024-08-25 13:32:39 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2024-08-25 13:34:25 -0700
commit9fe404138fa2136da29108e542713187e5d13b75 (patch)
treef1a8941982933c7f712124b5e59ddafe6d8a4eb6 /net-nds/openldap
parentnet-irc/inspircd: drop 3.16.1 (diff)
downloadgentoo-9fe404138fa2136da29108e542713187e5d13b75.tar.gz
gentoo-9fe404138fa2136da29108e542713187e5d13b75.tar.bz2
gentoo-9fe404138fa2136da29108e542713187e5d13b75.zip
net-nds/openldap: QA fix, false positive on strip
STRIP was already patched out in all the paths that actually generated final objects or binaries, but that wasn't enough to stop the QA test firing. Fix it a bit more (package output is identical). Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> Closes: https://bugs.gentoo.org/show_bug.cgi?id=840451
Diffstat (limited to 'net-nds/openldap')
-rw-r--r--net-nds/openldap/openldap-2.6.8.ebuild33
1 files changed, 25 insertions, 8 deletions
diff --git a/net-nds/openldap/openldap-2.6.8.ebuild b/net-nds/openldap/openldap-2.6.8.ebuild
index 894ea2a9ae3a..250d4ce0b66e 100644
--- a/net-nds/openldap/openldap-2.6.8.ebuild
+++ b/net-nds/openldap/openldap-2.6.8.ebuild
@@ -394,8 +394,11 @@ build_contrib_module() {
einfo "Compiling contrib-module: $1"
local target="${2:-all}"
emake \
- LDAP_BUILD="${BUILD_DIR}" prefix="${EPREFIX}/usr" \
- CC="${CC}" libexecdir="${EPREFIX}/usr/$(get_libdir)/openldap" \
+ CC="${CC}" \
+ LDAP_BUILD="${BUILD_DIR}" \
+ libexecdir="${EPREFIX}/usr/$(get_libdir)/openldap" \
+ prefix="${EPREFIX}/usr" \
+ STRIP=/bin/true \
"${target}"
popd &>/dev/null || die
}
@@ -534,7 +537,9 @@ multilib_src_configure() {
tc-export AR CC CXX
- ECONF_SOURCE="${S}" econf \
+ ECONF_SOURCE="${S}" \
+ STRIP=/bin/true \
+ econf \
--libexecdir="${EPREFIX}"/usr/$(get_libdir)/openldap \
--localstatedir="${EPREFIX}"/var \
--runstatedir="${EPREFIX}"/run \
@@ -570,13 +575,19 @@ src_configure_cxx() {
append-ldflags -L"${BUILD_DIR}"/libraries/liblber/.libs -L"${BUILD_DIR}"/libraries/libldap/.libs
append-cppflags -I"${BUILD_DIR}"/include
- ECONF_SOURCE="${S}"/contrib/ldapc++ econf "${myconf_ldapcpp[@]}"
+ ECONF_SOURCE="${S}"/contrib/ldapc++ \
+ STRIP=/bin/true \
+ econf \
+ "${myconf_ldapcpp[@]}"
popd &>/dev/null || die "popd contrib/ldapc++"
}
multilib_src_compile() {
tc-export AR CC CXX
- emake CC="$(tc-getCC)" SHELL="${EPREFIX}"/bin/sh
+ emake \
+ CC="$(tc-getCC)" \
+ SHELL="${EPREFIX}"/bin/sh \
+ STRIP="/bin/true"
if ! use minimal && multilib_is_native_abi ; then
if use cxx ; then
@@ -614,8 +625,10 @@ multilib_src_compile() {
pushd "${S}/contrib/slapd-modules/samba4" &>/dev/null || die "pushd contrib/slapd-modules/samba4"
emake \
+ CC="$(tc-getCC)" \
LDAP_BUILD="${BUILD_DIR}" \
- CC="$(tc-getCC)" libexecdir="${EPREFIX}/usr/$(get_libdir)/openldap"
+ libexecdir="${EPREFIX}/usr/$(get_libdir)/openldap" \
+ STRIP=/bin/true
popd &>/dev/null || die
fi
@@ -695,8 +708,12 @@ multilib_src_test() {
}
multilib_src_install() {
- emake CC="$(tc-getCC)" \
- DESTDIR="${D}" SHELL="${EPREFIX}"/bin/sh install
+ emake \
+ CC="$(tc-getCC)" \
+ DESTDIR="${D}" \
+ SHELL="${EPREFIX}"/bin/sh \
+ STRIP=/bin/true \
+ install
if ! use minimal && multilib_is_native_abi; then
# openldap modules go here