summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Jolly <Matt.Jolly@footclan.ninja>2023-08-11 19:10:14 +1000
committerSam James <sam@gentoo.org>2023-08-15 06:16:47 +0100
commita4e4f560028082b774a6bc6950be4e2c39b26b24 (patch)
tree0eb9c0ca3c99ac48d218369d3a5cfccf42491aa4 /net-misc
parentnet-misc/curl: make openssl and nghttp3 mutually exclusive (diff)
downloadgentoo-a4e4f560028082b774a6bc6950be4e2c39b26b24.tar.gz
gentoo-a4e4f560028082b774a6bc6950be4e2c39b26b24.tar.bz2
gentoo-a4e4f560028082b774a6bc6950be4e2c39b26b24.zip
net-misc/curl: set minimum versions for http2 tcp2 depends
Bug: https://bugs.gentoo.org/910089 Signed-off-by: Matt Jolly <Matt.Jolly@footclan.ninja> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/curl/curl-8.1.2.ebuild8
-rw-r--r--net-misc/curl/curl-8.2.1.ebuild7
-rw-r--r--net-misc/curl/curl-9999.ebuild15
3 files changed, 20 insertions, 10 deletions
diff --git a/net-misc/curl/curl-8.1.2.ebuild b/net-misc/curl/curl-8.1.2.ebuild
index 171b7855d16c..caa759da561a 100644
--- a/net-misc/curl/curl-8.1.2.ebuild
+++ b/net-misc/curl/curl-8.1.2.ebuild
@@ -51,13 +51,13 @@ RDEPEND="
sys-libs/zlib[${MULTILIB_USEDEP}]
adns? ( net-dns/c-ares:=[${MULTILIB_USEDEP}] )
brotli? ( app-arch/brotli:=[${MULTILIB_USEDEP}] )
- http2? ( net-libs/nghttp2:=[${MULTILIB_USEDEP}] )
+ http2? ( >=net-libs/nghttp2-1.12.0:=[${MULTILIB_USEDEP}] )
idn? ( net-dns/libidn2:=[static-libs?,${MULTILIB_USEDEP}] )
kerberos? ( >=virtual/krb5-0-r1[${MULTILIB_USEDEP}] )
- ldap? ( net-nds/openldap:=[${MULTILIB_USEDEP}] )
+ ldap? ( net-nds/openldap:=[static-libs?,${MULTILIB_USEDEP}] )
nghttp3? (
- net-libs/nghttp3[${MULTILIB_USEDEP}]
- net-libs/ngtcp2[ssl,${MULTILIB_USEDEP}]
+ >=net-libs/nghttp3-0.11.0[${MULTILIB_USEDEP}]
+ >=net-libs/ngtcp2-0.15.0[gnutls,ssl,-openssl,${MULTILIB_USEDEP}]
)
rtmp? ( media-video/rtmpdump[${MULTILIB_USEDEP}] )
ssh? ( net-libs/libssh2[${MULTILIB_USEDEP}] )
diff --git a/net-misc/curl/curl-8.2.1.ebuild b/net-misc/curl/curl-8.2.1.ebuild
index cc5b940fbf1c..72c9069bc754 100644
--- a/net-misc/curl/curl-8.2.1.ebuild
+++ b/net-misc/curl/curl-8.2.1.ebuild
@@ -53,13 +53,13 @@ RDEPEND="
sys-libs/zlib[${MULTILIB_USEDEP}]
adns? ( net-dns/c-ares:=[${MULTILIB_USEDEP}] )
brotli? ( app-arch/brotli:=[${MULTILIB_USEDEP}] )
- http2? ( >=net-libs/nghttp2-1.15.0:=[${MULTILIB_USEDEP}] )
+ http2? ( >=net-libs/nghttp2-1.12.0:=[${MULTILIB_USEDEP}] )
idn? ( net-dns/libidn2:=[static-libs?,${MULTILIB_USEDEP}] )
kerberos? ( >=virtual/krb5-0-r1[${MULTILIB_USEDEP}] )
ldap? ( net-nds/openldap:=[static-libs?,${MULTILIB_USEDEP}] )
nghttp3? (
- net-libs/nghttp3[${MULTILIB_USEDEP}]
- net-libs/ngtcp2[gnutls,ssl,-openssl,${MULTILIB_USEDEP}]
+ >=net-libs/nghttp3-0.13.0[${MULTILIB_USEDEP}]
+ >=net-libs/ngtcp2-0.17.0[gnutls,ssl,-openssl,${MULTILIB_USEDEP}]
)
rtmp? ( media-video/rtmpdump[${MULTILIB_USEDEP}] )
ssh? ( net-libs/libssh2[${MULTILIB_USEDEP}] )
@@ -87,6 +87,7 @@ RDEPEND="
)
zstd? ( app-arch/zstd:=[${MULTILIB_USEDEP}] )
"
+
DEPEND="${RDEPEND}"
BDEPEND="
dev-lang/perl
diff --git a/net-misc/curl/curl-9999.ebuild b/net-misc/curl/curl-9999.ebuild
index b2ec02b6d7e6..63a8fa2ec57b 100644
--- a/net-misc/curl/curl-9999.ebuild
+++ b/net-misc/curl/curl-9999.ebuild
@@ -47,17 +47,24 @@ REQUIRED_USE="
curl_ssl_rustls? ( rustls )
"
+# cURL's docs and CI/CD are great resources for confirming supported versions
+# particulary for fast-moving targets like HTTP/2 and TCP/2 e.g.:
+# - https://github.com/curl/curl/blob/master/docs/HTTP3.md
+# - https://github.com/curl/curl/blob/master/.github/workflows/quiche-linux.yml
+# However 'supported' vs 'works' are two entirely different things; be sane but
+# don't be afraid to require a later version.
+
RDEPEND="
sys-libs/zlib[${MULTILIB_USEDEP}]
adns? ( net-dns/c-ares:=[${MULTILIB_USEDEP}] )
brotli? ( app-arch/brotli:=[${MULTILIB_USEDEP}] )
- http2? ( >=net-libs/nghttp2-1.15.0:=[${MULTILIB_USEDEP}] )
+ http2? ( >=net-libs/nghttp2-1.12.0:=[${MULTILIB_USEDEP}] )
idn? ( net-dns/libidn2:=[static-libs?,${MULTILIB_USEDEP}] )
kerberos? ( >=virtual/krb5-0-r1[${MULTILIB_USEDEP}] )
ldap? ( net-nds/openldap:=[static-libs?,${MULTILIB_USEDEP}] )
nghttp3? (
- net-libs/nghttp3[${MULTILIB_USEDEP}]
- net-libs/ngtcp2[ssl,${MULTILIB_USEDEP}]
+ >=net-libs/nghttp3-0.14.0[${MULTILIB_USEDEP}]
+ >=net-libs/ngtcp2-0.18.0[gnutls,ssl,-openssl,${MULTILIB_USEDEP}]
)
rtmp? ( media-video/rtmpdump[${MULTILIB_USEDEP}] )
ssh? ( net-libs/libssh2[${MULTILIB_USEDEP}] )
@@ -85,7 +92,9 @@ RDEPEND="
)
zstd? ( app-arch/zstd:=[${MULTILIB_USEDEP}] )
"
+
DEPEND="${RDEPEND}"
+
BDEPEND="
dev-lang/perl
virtual/pkgconfig