summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-09-10 17:57:10 +0200
committerMichał Górny <mgorny@gentoo.org>2024-09-10 18:28:02 +0200
commit9a77794f96c0c39c7d311fd7e793c7c8fcf2501a (patch)
tree27298ee1cdcebf7b0bf7dc5f93299fdc20448b5e /net-misc
parentdev-python/pdm: Bump to 2.18.2 (diff)
downloadgentoo-9a77794f96c0c39c7d311fd7e793c7c8fcf2501a.tar.gz
gentoo-9a77794f96c0c39c7d311fd7e793c7c8fcf2501a.tar.bz2
gentoo-9a77794f96c0c39c7d311fd7e793c7c8fcf2501a.zip
net-misc/tuba: Bump to 0.8.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/tuba/Manifest1
-rw-r--r--net-misc/tuba/tuba-0.8.4.ebuild75
2 files changed, 76 insertions, 0 deletions
diff --git a/net-misc/tuba/Manifest b/net-misc/tuba/Manifest
index 710a29046a4d..27b9ede55b74 100644
--- a/net-misc/tuba/Manifest
+++ b/net-misc/tuba/Manifest
@@ -1,2 +1,3 @@
DIST Tuba-0.8.2.gh.tar.gz 1751598 BLAKE2B 9fb0a32d7731ca406a6f79223c862fbe0b75493ace5dc2d83cdab111e955ded2f1b42c31542e38b027245df29ba6a84d88014cafdba0214bdb22910c933989bd SHA512 5d00843ae54c7f32adf5bdbecf0798730f797f778aea55bdc6fff1bf7fdb3b386544a209bd621a92774dcbe25d26503ca9da73211355866452069b6fa4542360
DIST Tuba-0.8.3.gh.tar.gz 1783840 BLAKE2B 11f98de167107bdc53f42aa6e33af14d946b7745e530623b174832bc7ce363ca7b63f83ed2d58f9b179144ebf0499d6773f5be54c2f8fa0f8897b6a2ae020fe8 SHA512 29082a84e0b5149f8a8610575965d252826d564f28eb128a9db3c215a2c1edda23a3b6316f8b62c22a37ab9d340f94e571ea8be96719a3ff714a6b26da90a314
+DIST Tuba-0.8.4.gh.tar.gz 1803987 BLAKE2B 9ec1647bc255a3cef37293fc86f81eed534f4a313e3ec0ab81318766972ed01100b30afcc05448f5344637da08962bb72dc2eb5d44fc0561ce1a61c48b9b8b5d SHA512 8484cdb898174958c1e79ddfd6fab9e74693bca19d1eddde504679d1074cac986580dcf2e2c98fa13ab54fec2a4ffc25b1977bc6e62f1b3a524a6810b2ac268f
diff --git a/net-misc/tuba/tuba-0.8.4.ebuild b/net-misc/tuba/tuba-0.8.4.ebuild
new file mode 100644
index 000000000000..e75bb85f2c86
--- /dev/null
+++ b/net-misc/tuba/tuba-0.8.4.ebuild
@@ -0,0 +1,75 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome2-utils meson optfeature vala
+
+MY_P=${P^}
+DESCRIPTION="Browse the Fediverse (GTK client)"
+HOMEPAGE="
+ https://tuba.geopjr.dev/
+ https://github.com/GeopJr/Tuba/
+"
+SRC_URI="
+ https://github.com/GeopJr/Tuba/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="GPL-3 CC-BY-SA-4.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+# TODO: optional dep on libspelling-1
+DEPEND="
+ app-crypt/libsecret[introspection,vala]
+ >=dev-libs/glib-2.76.0:2
+ dev-libs/icu:=
+ >=dev-libs/json-glib-1.4.4[introspection]
+ >=dev-libs/libgee-0.8.5:0.8[introspection]
+ dev-libs/libxml2
+ >=gui-libs/gtk-4.13.4:4[gstreamer,introspection]
+ >=gui-libs/libadwaita-1.5:1[introspection,vala]
+ >=gui-libs/gtksourceview-5.6.0:5[introspection,vala]
+ net-libs/libsoup:3.0[introspection,vala]
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ $(vala_depend)
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local emesonargs=(
+ # disable calling updaters (see pkg_post*)
+ -Ddistro=true
+ # not packaged
+ -Dclapper=false
+ )
+
+ vala_setup
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ dosym dev.geopjr.Tuba /usr/bin/tuba
+}
+
+pkg_postinst() {
+ optfeature "WebP image support" gui-libs/gdk-pixbuf-loader-webp
+
+ gnome2_schemas_update
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_schemas_update
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}