summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Kohler <bkohler@gentoo.org>2020-12-30 09:32:13 -0600
committerBen Kohler <bkohler@gentoo.org>2020-12-30 09:32:36 -0600
commit93fd19e645c7bc2484cac4c24bb36e244a13ee01 (patch)
tree340b9bc8693d73d14b6a9eb0bf913b13353fb788 /net-misc
parentsys-kernel/gentoo-sources: Linux patch updates (diff)
downloadgentoo-93fd19e645c7bc2484cac4c24bb36e244a13ee01.tar.gz
gentoo-93fd19e645c7bc2484cac4c24bb36e244a13ee01.tar.bz2
gentoo-93fd19e645c7bc2484cac4c24bb36e244a13ee01.zip
net-misc/spice-gtk: handle python deps & remove -Werror
Simple sed to remove Werror for now, it is already removed in upstream git so this fix can be removed for next release. Closes: https://bugs.gentoo.org/744841 Closes: https://bugs.gentoo.org/718556 Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Ben Kohler <bkohler@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/spice-gtk/spice-gtk-0.38-r1.ebuild126
-rw-r--r--net-misc/spice-gtk/spice-gtk-9999.ebuild16
2 files changed, 141 insertions, 1 deletions
diff --git a/net-misc/spice-gtk/spice-gtk-0.38-r1.ebuild b/net-misc/spice-gtk/spice-gtk-0.38-r1.ebuild
new file mode 100644
index 000000000000..0102b373e378
--- /dev/null
+++ b/net-misc/spice-gtk/spice-gtk-0.38-r1.ebuild
@@ -0,0 +1,126 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+VALA_MIN_API_VERSION="0.14"
+VALA_USE_DEPEND="vapigen"
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit desktop eutils meson python-any-r1 readme.gentoo-r1 vala xdg-utils
+
+DESCRIPTION="Set of GObject and Gtk objects for connecting to Spice servers and a client GUI"
+HOMEPAGE="https://www.spice-space.org https://cgit.freedesktop.org/spice/spice-gtk/"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+SRC_URI="https://www.spice-space.org/download/gtk/${P}.tar.xz"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="+gtk3 +introspection libressl lz4 mjpeg policykit pulseaudio sasl smartcard usbredir vala webdav"
+
+# TODO:
+# * check if sys-freebsd/freebsd-lib (from virtual/acl) provides acl/libacl.h
+# * use external pnp.ids as soon as that means not pulling in gnome-desktop
+RDEPEND="
+ >=dev-libs/glib-2.46:2
+ dev-libs/json-glib:0=
+ media-libs/gst-plugins-base:1.0
+ media-libs/gst-plugins-good:1.0
+ media-libs/gstreamer:1.0[introspection?]
+ media-libs/opus
+ sys-libs/zlib
+ virtual/jpeg:0=
+ >=x11-libs/cairo-1.2
+ >=x11-libs/pixman-0.17.7
+ gtk3? ( x11-libs/gtk+:3[introspection?] )
+ introspection? ( dev-libs/gobject-introspection )
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ lz4? ( app-arch/lz4 )
+ pulseaudio? (
+ media-plugins/gst-plugins-pulse:1.0
+ )
+ sasl? ( dev-libs/cyrus-sasl )
+ smartcard? ( app-emulation/qemu[smartcard] )
+ usbredir? (
+ sys-apps/hwids
+ >=sys-apps/usbredir-0.4.2
+ virtual/libusb:1
+ policykit? (
+ sys-apps/acl
+ >=sys-auth/polkit-0.110-r1
+ )
+ )
+ webdav? (
+ net-libs/phodav:2.0
+ >=net-libs/libsoup-2.49.91 )
+"
+# TODO: spice-gtk has an automagic dependency on x11-libs/libva without a
+# configure knob. The package is relatively lightweight so we just depend
+# on it unconditionally for now. It would be cleaner to transform this into
+# a USE="vaapi" conditional and patch the buildsystem...
+RDEPEND="${RDEPEND}
+ amd64? ( x11-libs/libva:= )
+ arm64? ( x11-libs/libva:= )
+ x86? ( x11-libs/libva:= )
+"
+DEPEND="${RDEPEND}
+ >=app-emulation/spice-protocol-0.14.1
+ dev-perl/Text-CSV
+ dev-util/glib-utils
+ >=dev-util/gtk-doc-am-1.14
+ >=dev-util/intltool-0.40.0
+ >=sys-devel/gettext-0.17
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )
+"
+
+BDEPEND="
+ $(python_gen_any_dep '
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/pyparsing[${PYTHON_USEDEP}]
+ ')
+"
+
+python_check_deps() {
+ has_version "dev-python/six[${PYTHON_USEDEP}]" &&
+ has_version "dev-python/pyparsing[${PYTHON_USEDEP}]"
+}
+
+src_prepare() {
+ default
+ sed -i -e "/^ '-Werror',/d" \
+ subprojects/spice-common/meson.build || die
+ use vala && vala_src_prepare
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature gtk3 gtk)
+ $(meson_feature introspection)
+ $(meson_use mjpeg builtin-mjpeg)
+ $(meson_feature policykit polkit)
+ $(meson_feature pulseaudio pulse)
+ $(meson_feature lz4)
+ $(meson_feature sasl)
+ $(meson_feature smartcard)
+ $(meson_feature usbredir)
+ $(meson_feature vala vapi)
+ $(meson_feature webdav)
+ )
+
+ if use usbredir; then
+ emesonargs+=( -D "usb-acl-helper-dir=/usr/libexec" )
+ emesonargs+=( -D "usb-ids-path=/usr/share/misc/usb.ids" )
+ fi
+
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+
+ make_desktop_entry spicy Spicy "utilities-terminal" "Network;RemoteAccess;"
+ readme.gentoo_create_doc
+}
diff --git a/net-misc/spice-gtk/spice-gtk-9999.ebuild b/net-misc/spice-gtk/spice-gtk-9999.ebuild
index e262e6bf9e87..c507c8b5b368 100644
--- a/net-misc/spice-gtk/spice-gtk-9999.ebuild
+++ b/net-misc/spice-gtk/spice-gtk-9999.ebuild
@@ -6,7 +6,9 @@ EAPI=7
VALA_MIN_API_VERSION="0.14"
VALA_USE_DEPEND="vapigen"
-inherit desktop eutils git-r3 meson readme.gentoo-r1 vala xdg-utils
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit desktop eutils git-r3 meson python-any-r1 readme.gentoo-r1 vala xdg-utils
DESCRIPTION="Set of GObject and Gtk objects for connecting to Spice servers and a client GUI"
HOMEPAGE="https://www.spice-space.org https://cgit.freedesktop.org/spice/spice-gtk/"
@@ -74,6 +76,18 @@ DEPEND="${RDEPEND}
vala? ( $(vala_depend) )
"
+BDEPEND="
+ $(python_gen_any_dep '
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/pyparsing[${PYTHON_USEDEP}]
+ ')
+"
+
+python_check_deps() {
+ has_version "dev-python/six[${PYTHON_USEDEP}]" &&
+ has_version "dev-python/pyparsing[${PYTHON_USEDEP}]"
+}
+
src_prepare() {
default