summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-10-17 22:46:27 +0100
committerSam James <sam@gentoo.org>2022-10-17 22:46:47 +0100
commit6e9f8924475a0e11d472029ac8ec06a455cab0b2 (patch)
tree7aa950df20e5f2661e417d3c523567cd5776e9f2 /net-misc
parentprofiles/features/musl: mask dev-util/rr on musl (diff)
downloadgentoo-6e9f8924475a0e11d472029ac8ec06a455cab0b2.tar.gz
gentoo-6e9f8924475a0e11d472029ac8ec06a455cab0b2.tar.bz2
gentoo-6e9f8924475a0e11d472029ac8ec06a455cab0b2.zip
net-misc/whois: sync live
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/whois/whois-9999.ebuild25
1 files changed, 14 insertions, 11 deletions
diff --git a/net-misc/whois/whois-9999.ebuild b/net-misc/whois/whois-9999.ebuild
index 8330f6ba0af9..4c1dfcda83b9 100644
--- a/net-misc/whois/whois-9999.ebuild
+++ b/net-misc/whois/whois-9999.ebuild
@@ -5,21 +5,24 @@ EAPI=7
inherit toolchain-funcs
-MY_P="${P/-/_}"
-DESCRIPTION="improved Whois Client"
+MY_P=${P/-/_}
+DESCRIPTION="Improved Whois Client"
HOMEPAGE="https://github.com/rfc1036/whois"
-if [[ "${PV}" == *9999 ]] ; then
+
+if [[ ${PV} == *9999 ]] ; then
inherit git-r3
EGIT_REPO_URI="https://github.com/rfc1036/whois.git"
else
- #SRC_URI="mirror://debian/pool/main/w/whois/${MY_P}.tar.xz"
- SRC_URI="https://github.com/rfc1036/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ SRC_URI="mirror://debian/pool/main/w/whois/${MY_P}.tar.xz"
+ #SRC_URI="https://github.com/rfc1036/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}"/${PN}
+
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
fi
+
LICENSE="GPL-2"
SLOT="0"
IUSE="iconv idn nls xcrypt"
-RESTRICT="test" #59327
RDEPEND="
iconv? ( virtual/libiconv )
@@ -43,6 +46,7 @@ PATCHES=(
src_prepare() {
default
+
if use nls ; then
sed -i -e 's:#\(.*pos\):\1:' Makefile || die
else
@@ -58,21 +62,20 @@ src_configure() { :; } # expected no-op
src_compile() {
unset HAVE_ICONV HAVE_LIBIDN
+
use iconv && export HAVE_ICONV=1
use idn && export HAVE_LIBIDN=1
use xcrypt && export HAVE_XCRYPT=1
+
tc-export CC
+
emake CFLAGS="${CFLAGS} ${CPPFLAGS}"
}
src_install() {
emake BASEDIR="${ED}" prefix=/usr install
+
insinto /etc
doins whois.conf
dodoc README debian/changelog
-
- if [[ ${USERLAND} != "GNU" ]]; then
- mv "${ED}"/usr/share/man/man1/{whois,mdwhois}.1 || die
- mv "${ED}"/usr/bin/{whois,mdwhois} || die
- fi
}