summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-02-03 08:10:42 +0100
committerMichał Górny <mgorny@gentoo.org>2024-02-03 08:22:38 +0100
commit5e7f4b4f3708da3ddb4cde85dd8f3afab15c5ee7 (patch)
treef3cd87ffb5fa2edd314af95a0cc379079b2f0145 /net-misc
parentnet-misc/tuba: Remove old (diff)
downloadgentoo-5e7f4b4f3708da3ddb4cde85dd8f3afab15c5ee7.tar.gz
gentoo-5e7f4b4f3708da3ddb4cde85dd8f3afab15c5ee7.tar.bz2
gentoo-5e7f4b4f3708da3ddb4cde85dd8f3afab15c5ee7.zip
net-misc/tuba: Bump to 0.6.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/tuba/Manifest1
-rw-r--r--net-misc/tuba/tuba-0.6.3.ebuild72
2 files changed, 73 insertions, 0 deletions
diff --git a/net-misc/tuba/Manifest b/net-misc/tuba/Manifest
index acf89c9f370a..a22248dc040a 100644
--- a/net-misc/tuba/Manifest
+++ b/net-misc/tuba/Manifest
@@ -1 +1,2 @@
DIST Tuba-0.6.2.gh.tar.gz 1100473 BLAKE2B e499a5d8363e46c5a1a875adf2f8bbbf7c787f52111684a9724bde452cacd2d604b41b575fc3a153843546ec23275aa76e4726cef89860288e8967f30ddbc08a SHA512 ae171ddb696d79a6791613a0aedecd1e8ad28ed71bcc966176512e95016bb2dd29805b74f10565c3d3d70f2910c1ae4dc829d6d67de10a677decc3a2bd81aeab
+DIST Tuba-0.6.3.gh.tar.gz 1124191 BLAKE2B b5a7107c94d9adf89fc02224891c12b71fc2b640e962006fbfcf1d0673e5f3f73b11423b6d66e8952e2aef122ade6a57607cced5d4707bd91193157fd561ce11 SHA512 b987b9b8434a0abd086a3197154b27bd4a0bca69df07bcec26c59a2da51cf447943e7a05a83529a99670f2b1b7ea1a7dce1da39148844d23706940f3a0a423d8
diff --git a/net-misc/tuba/tuba-0.6.3.ebuild b/net-misc/tuba/tuba-0.6.3.ebuild
new file mode 100644
index 000000000000..7b80ad8dfb31
--- /dev/null
+++ b/net-misc/tuba/tuba-0.6.3.ebuild
@@ -0,0 +1,72 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome2-utils meson optfeature vala
+
+MY_P=${P^}
+DESCRIPTION="Browse the Fediverse (GTK client)"
+HOMEPAGE="
+ https://tuba.geopjr.dev/
+ https://github.com/GeopJr/Tuba/
+"
+SRC_URI="
+ https://github.com/GeopJr/Tuba/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="GPL-3 CC-BY-SA-4.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+# TODO: optional dep on libspelling-1
+DEPEND="
+ app-crypt/libsecret[introspection]
+ >=dev-libs/glib-2.76.0:2
+ >=dev-libs/json-glib-1.4.4[introspection]
+ >=dev-libs/libgee-0.8.5:0.8[introspection]
+ dev-libs/libxml2
+ >=gui-libs/gtk-4.11.3:4[gstreamer,introspection]
+ >=gui-libs/libadwaita-1.4:1[introspection,vala]
+ >=gui-libs/gtksourceview-5.6.0:5[introspection,vala]
+ net-libs/libsoup:3.0[introspection]
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ $(vala_depend)
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local emesonargs=(
+ # disable calling updaters (see pkg_post*)
+ -Ddistro=true
+ )
+
+ vala_setup
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ dosym dev.geopjr.Tuba /usr/bin/tuba
+}
+
+pkg_postinst() {
+ optfeature "WebP image support" gui-libs/gdk-pixbuf-loader-webp
+
+ gnome2_schemas_update
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_schemas_update
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}