summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Jolly <kangie@gentoo.org>2024-11-04 17:24:14 +1000
committerMatt Jolly <kangie@gentoo.org>2024-11-09 16:25:41 +1000
commit01ba4dc61965ef7658a24728841c04c9a1ce4871 (patch)
treea2a6b927779e5990ff87ec4589373d1d89129a63 /net-misc
parentprofiles: mask dev-lang/starlark-rust (diff)
downloadgentoo-01ba4dc61965ef7658a24728841c04c9a1ce4871.tar.gz
gentoo-01ba4dc61965ef7658a24728841c04c9a1ce4871.tar.bz2
gentoo-01ba4dc61965ef7658a24728841c04c9a1ce4871.zip
*/*: update for slotted Rust
Tidyups: - $(cargo_crate_uris) - Rust BDEPENDS come from the eclass except in very rare circumstances (RUST_OPTIONAL=1) - RUST_M{AX,IN}_VER where required. - Suboptimal crate separator (`-` -> `@`) Signed-off-by: Matt Jolly <kangie@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/39218 Signed-off-by: Matt Jolly <kangie@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/asahi-btsync/asahi-btsync-0.2.0-r1.ebuild (renamed from net-misc/asahi-btsync/asahi-btsync-0.2.0.ebuild)10
-rw-r--r--net-misc/asahi-wifisync/asahi-wifisync-0.2.0-r1.ebuild (renamed from net-misc/asahi-wifisync/asahi-wifisync-0.2.0.ebuild)8
-rw-r--r--net-misc/geckodriver/geckodriver-0.35.0-r1.ebuild (renamed from net-misc/geckodriver/geckodriver-0.35.0.ebuild)1
-rw-r--r--net-misc/hurl/hurl-4.1.0-r1.ebuild (renamed from net-misc/hurl/hurl-4.1.0.ebuild)0
-rw-r--r--net-misc/hurl/hurl-5.0.1-r1.ebuild (renamed from net-misc/hurl/hurl-5.0.1.ebuild)0
-rw-r--r--net-misc/websocat/websocat-1.12.0-r1.ebuild (renamed from net-misc/websocat/websocat-1.12.0.ebuild)1
-rw-r--r--net-misc/websocat/websocat-1.13.0-r1.ebuild (renamed from net-misc/websocat/websocat-1.13.0.ebuild)1
-rw-r--r--net-misc/zerotier/zerotier-1.14.1-r1.ebuild (renamed from net-misc/zerotier/zerotier-1.14.1.ebuild)4
-rw-r--r--net-misc/zerotier/zerotier-1.14.2-r1.ebuild (renamed from net-misc/zerotier/zerotier-1.14.2.ebuild)4
9 files changed, 24 insertions, 5 deletions
diff --git a/net-misc/asahi-btsync/asahi-btsync-0.2.0.ebuild b/net-misc/asahi-btsync/asahi-btsync-0.2.0-r1.ebuild
index 38625d6d5889..e28ae111043a 100644
--- a/net-misc/asahi-btsync/asahi-btsync-0.2.0.ebuild
+++ b/net-misc/asahi-btsync/asahi-btsync-0.2.0-r1.ebuild
@@ -69,6 +69,9 @@ CRATES="
windows_x86_64_msvc@0.52.0
"
+# stdsimd
+RUST_MAX_VER=1.77.1
+
inherit cargo linux-info
# Releases are not tagged
@@ -89,10 +92,15 @@ LICENSE+=" MIT Unicode-DFS-2016 ZLIB"
SLOT="0"
KEYWORDS="~arm64"
+pkg_setup() {
+ linux-info_pkg_setup
+ rust_pkg_setup
+}
+
pkg_pretend() {
if use kernel_linux; then
linux_config_exists || die "No suitable kernel configuration could be found"
CONFIG_EXTRA="~MTD_SPI_NOR"
check_extra_config
fi
-}
+ }
diff --git a/net-misc/asahi-wifisync/asahi-wifisync-0.2.0.ebuild b/net-misc/asahi-wifisync/asahi-wifisync-0.2.0-r1.ebuild
index 4ab24a1b1b1e..cde1356d1786 100644
--- a/net-misc/asahi-wifisync/asahi-wifisync-0.2.0.ebuild
+++ b/net-misc/asahi-wifisync/asahi-wifisync-0.2.0-r1.ebuild
@@ -69,6 +69,9 @@ CRATES="
windows_x86_64_msvc@0.52.0
"
+# stdsimd
+RUST_MAX_VER=1.77.1
+
inherit cargo linux-info
# Releases are not tagged
@@ -89,6 +92,11 @@ LICENSE+=" MIT Unicode-DFS-2016 ZLIB"
SLOT="0"
KEYWORDS="~arm64"
+pkg_setup() {
+ linux-info_pkg_setup
+ rust_pkg_setup
+}
+
pkg_pretend() {
if use kernel_linux; then
linux_config_exists || die "No suitable kernel configuration could be found"
diff --git a/net-misc/geckodriver/geckodriver-0.35.0.ebuild b/net-misc/geckodriver/geckodriver-0.35.0-r1.ebuild
index 53a9994179ab..1f881c9a5b31 100644
--- a/net-misc/geckodriver/geckodriver-0.35.0.ebuild
+++ b/net-misc/geckodriver/geckodriver-0.35.0-r1.ebuild
@@ -240,6 +240,7 @@ RDEPEND="!www-client/firefox[geckodriver(-)]"
pkg_setup() {
QA_FLAGS_IGNORED="/usr/$(get_libdir)/firefox/geckodriver"
+ rust_pkg_setup
}
src_prepare() {
diff --git a/net-misc/hurl/hurl-4.1.0.ebuild b/net-misc/hurl/hurl-4.1.0-r1.ebuild
index 856d7cca73a5..856d7cca73a5 100644
--- a/net-misc/hurl/hurl-4.1.0.ebuild
+++ b/net-misc/hurl/hurl-4.1.0-r1.ebuild
diff --git a/net-misc/hurl/hurl-5.0.1.ebuild b/net-misc/hurl/hurl-5.0.1-r1.ebuild
index 8715ac33605a..8715ac33605a 100644
--- a/net-misc/hurl/hurl-5.0.1.ebuild
+++ b/net-misc/hurl/hurl-5.0.1-r1.ebuild
diff --git a/net-misc/websocat/websocat-1.12.0.ebuild b/net-misc/websocat/websocat-1.12.0-r1.ebuild
index 52fc47b607b2..95fa03089c59 100644
--- a/net-misc/websocat/websocat-1.12.0.ebuild
+++ b/net-misc/websocat/websocat-1.12.0-r1.ebuild
@@ -31,7 +31,6 @@ RDEPEND="
)
"
DEPEND="
- ${RUST_DEPEND}
${RDEPEND}
"
QA_FLAGS_IGNORED="/usr/bin/websocat"
diff --git a/net-misc/websocat/websocat-1.13.0.ebuild b/net-misc/websocat/websocat-1.13.0-r1.ebuild
index e42ad159e087..cb5f4a415b7e 100644
--- a/net-misc/websocat/websocat-1.13.0.ebuild
+++ b/net-misc/websocat/websocat-1.13.0-r1.ebuild
@@ -29,7 +29,6 @@ RDEPEND="
)
"
DEPEND="
- ${RUST_DEPEND}
${RDEPEND}
"
QA_FLAGS_IGNORED="/usr/bin/websocat"
diff --git a/net-misc/zerotier/zerotier-1.14.1.ebuild b/net-misc/zerotier/zerotier-1.14.1-r1.ebuild
index f6f30f150077..ce8818618cac 100644
--- a/net-misc/zerotier/zerotier-1.14.1.ebuild
+++ b/net-misc/zerotier/zerotier-1.14.1-r1.ebuild
@@ -380,6 +380,8 @@ declare -A GIT_CRATES=(
[temporal-sdk]='https://github.com/temporalio/sdk-core;a8150d5c7c3fc1bfd5a941fd315abff1556cd9dc;sdk-core-%commit%/sdk'
)
+RUST_OPTIONAL=1
+
inherit cargo systemd toolchain-funcs
DESCRIPTION="A software-based managed Ethernet switch for planet Earth"
@@ -407,7 +409,7 @@ RDEPEND="
DEPEND="${RDEPEND}"
BDEPEND="
sso? (
- virtual/rust
+ ${RUST_DEPEND}
)
"
diff --git a/net-misc/zerotier/zerotier-1.14.2.ebuild b/net-misc/zerotier/zerotier-1.14.2-r1.ebuild
index 16179d08188e..8125b3a115da 100644
--- a/net-misc/zerotier/zerotier-1.14.2.ebuild
+++ b/net-misc/zerotier/zerotier-1.14.2-r1.ebuild
@@ -381,6 +381,8 @@ declare -A GIT_CRATES=(
[temporal-sdk]='https://github.com/temporalio/sdk-core;730aadcc02767ae630e88f8f8c788a85d6bc81e6;sdk-core-%commit%/sdk'
)
+RUST_OPTIONAL=1
+
inherit cargo systemd toolchain-funcs
DESCRIPTION="A software-based managed Ethernet switch for planet Earth"
@@ -408,7 +410,7 @@ RDEPEND="
DEPEND="${RDEPEND}"
BDEPEND="
sso? (
- virtual/rust
+ ${RUST_DEPEND}
)
"