summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-06-01 21:18:52 +0200
committerMaciej Barć <xgqt@gentoo.org>2024-06-02 15:37:45 +0200
commit7533e56dda02bb225b174b10530131aa1c253ae0 (patch)
treebb912ee4f4d2d03865907f7f3fc9462a21b26e68 /net-misc/gallery-dl
parentdev-scheme/chibi: sync live 9999 version (diff)
downloadgentoo-7533e56dda02bb225b174b10530131aa1c253ae0.tar.gz
gentoo-7533e56dda02bb225b174b10530131aa1c253ae0.tar.bz2
gentoo-7533e56dda02bb225b174b10530131aa1c253ae0.zip
net-misc/gallery-dl: bump to 1.27.0
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'net-misc/gallery-dl')
-rw-r--r--net-misc/gallery-dl/Manifest1
-rw-r--r--net-misc/gallery-dl/gallery-dl-1.27.0.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/net-misc/gallery-dl/Manifest b/net-misc/gallery-dl/Manifest
index 36f39dcc40a0..25823e830774 100644
--- a/net-misc/gallery-dl/Manifest
+++ b/net-misc/gallery-dl/Manifest
@@ -1,2 +1,3 @@
DIST gallery-dl-1.26.9-5227bb6.patch 3415 BLAKE2B 864d6877ba9f6ee6449465ebce9b6648325c176f2ae4062c27e7059852b05983a99f203aabc9e3c361214b14d489bdb450920879171385474ddec50d83f1b937 SHA512 6931eeb00f6fcd6b9005672aa23ed2b0270846758a762a8a86ef51ca860bea2563673b02881abd5a1a224b7518a89e66de46da5cc0a7994d58078886aa090c64
DIST gallery-dl-1.26.9.gh.tar.gz 670467 BLAKE2B 849d20ff6fd802915b3bc4f6bb11d638d1e8f24f1dbdcfd5946461798044d59bf9243faa370cdddcdffe40a24d39d44a43abc79b4c8e89e7c60b40e5e204603a SHA512 54c2a86a67c53b7d5c62e6c23c549fd89503386549dc9d2f9c7de058b52ecb60b5089555e97dd0b63d33686e1bd08a3be940152715a6d26647e6949e641df9cb
+DIST gallery-dl-1.27.0.gh.tar.gz 682957 BLAKE2B 7a376c22d970533ac3668d9893fed74551100463d7d24c93940971238c568b70c644cd78df1edb506c9a5ef0d7154d3566f61fb9bcc047c47f0868900936b5d5 SHA512 129df83eafecf3ce680318ff9360fd99feb2136e236f377eb7921406e3f4ea93bb2479265dcec18cae77b83f013223612c0cae7ffd7ac2e122e0395de7beb92a
diff --git a/net-misc/gallery-dl/gallery-dl-1.27.0.ebuild b/net-misc/gallery-dl/gallery-dl-1.27.0.ebuild
new file mode 100644
index 000000000000..fea34fbde450
--- /dev/null
+++ b/net-misc/gallery-dl/gallery-dl-1.27.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+PYTHON_REQ_USE="sqlite,ssl,xml(+)"
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Download image galleries and collections from several image hosting sites"
+HOMEPAGE="https://github.com/mikf/gallery-dl/"
+
+if [[ "${PV}" == *9999* ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/mikf/${PN}.git"
+else
+ SRC_URI="https://github.com/mikf/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+
+RDEPEND="
+ >=dev-python/requests-2.11.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest
+
+src_prepare() {
+ # Tests against real servers, some tests always fail and some are subject to change.
+ rm test/test_results.py || die
+
+ distutils-r1_src_prepare
+}
+
+python_compile_all() {
+ emake PYTHON="${EPYTHON}" data/completion/{,_}gallery-dl man
+}
+
+pkg_postinst() {
+ optfeature "Pixiv Ugoira to WebM conversion" media-video/ffmpeg
+ optfeature "video downloads" net-misc/yt-dlp
+}