summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2016-05-03 18:27:07 -0500
committerAustin English <wizardedit@gentoo.org>2016-05-03 19:08:37 -0500
commit74c97e15d808a626f7e9e83a6631ab399e2433ad (patch)
tree412d7a6be587079b67ba54833a220194a4d3866c /net-misc/fakeidentd
parentnet-misc/cbqinit: remove old version (diff)
downloadgentoo-74c97e15d808a626f7e9e83a6631ab399e2433ad.tar.gz
gentoo-74c97e15d808a626f7e9e83a6631ab399e2433ad.tar.bz2
gentoo-74c97e15d808a626f7e9e83a6631ab399e2433ad.zip
net-misc/fakeidentd: use #!/sbin/openrc-run instead of #!/sbin/runscript
Gentoo-Bug: https://bugs.gentoo.org/573846 Package-Manager: portage-2.2.26
Diffstat (limited to 'net-misc/fakeidentd')
-rw-r--r--net-misc/fakeidentd/fakeidentd-2.6-r1.ebuild41
-rw-r--r--net-misc/fakeidentd/files/fakeidentd.rc4
2 files changed, 43 insertions, 2 deletions
diff --git a/net-misc/fakeidentd/fakeidentd-2.6-r1.ebuild b/net-misc/fakeidentd/fakeidentd-2.6-r1.ebuild
new file mode 100644
index 000000000000..6b2098748b9f
--- /dev/null
+++ b/net-misc/fakeidentd/fakeidentd-2.6-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="A static, secure identd. One source file only!"
+HOMEPAGE="http://www.guru-group.fi/~too/sw/"
+SRC_URI="http://www.guru-group.fi/~too/sw/identd.readme -> ${P}.readme
+ http://www.guru-group.fi/~too/sw/releases/identd.c -> ${P}.c"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ~ia64 ppc ppc64 ~sh sparc x86"
+IUSE=""
+
+echoit() {
+ echo "$@"
+ "$@"
+}
+
+src_unpack() {
+ mkdir -p "${S}"
+ echoit cp "${DISTDIR}"/${P}.{c,readme} "${S}" || die
+}
+
+src_compile() {
+ echoit $(tc-getCC) ${CFLAGS} ${LDFLAGS} \
+ -DTRG=\"${PN}\" -DUSE_UNIX_OS -DVERSION=\"${PV}\" \
+ -o ${PN} ${P}.c || die
+}
+
+src_install() {
+ dosbin ${PN}
+ newdoc ${P}.readme identd.readme
+
+ newinitd "${FILESDIR}"/fakeidentd.rc fakeidentd
+ newconfd "${FILESDIR}"/fakeidentd.confd fakeidentd
+}
diff --git a/net-misc/fakeidentd/files/fakeidentd.rc b/net-misc/fakeidentd/files/fakeidentd.rc
index 79082f069b8f..4510f7450706 100644
--- a/net-misc/fakeidentd/files/fakeidentd.rc
+++ b/net-misc/fakeidentd/files/fakeidentd.rc
@@ -1,5 +1,5 @@
-#!/sbin/runscript
-# Copyright 1999-2004 Gentoo Foundation
+#!/sbin/openrc-run
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$