summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/electrum
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/electrum')
-rw-r--r--net-misc/electrum/Manifest2
-rw-r--r--net-misc/electrum/electrum-2.1.1.ebuild144
-rw-r--r--net-misc/electrum/electrum-2.3.3.ebuild144
-rw-r--r--net-misc/electrum/metadata.xml32
4 files changed, 322 insertions, 0 deletions
diff --git a/net-misc/electrum/Manifest b/net-misc/electrum/Manifest
new file mode 100644
index 000000000000..bad03d534301
--- /dev/null
+++ b/net-misc/electrum/Manifest
@@ -0,0 +1,2 @@
+DIST Electrum-2.1.1.tar.gz 1778994 SHA256 958c7113072aa4a00a7e58a6e325d952fc35896a8678952cf6487636f74164e0 SHA512 06277a810a6533cc800c6813f874a0a6e3a7e598bdd47b73a6edb440bc5efefc56edacc44c15349e3d0c72d350700c67025f43e5478b4ae838af57acc1c91f52 WHIRLPOOL 2bf9392ebbd6e7b63e4e1e12cf72356dae1e1605a3c543c3a174229247fbb280412df5fac37a195b815018b8425d88618be54d4f3b58e37273ba40776f6b3765
+DIST Electrum-2.3.3.tar.gz 1971994 SHA256 72bac30a4d82c8fbc453fab2d1fa391af690884e1727088aa969d25891a9fc0d SHA512 26c2d3eaece738a67546168d82a89c7bd5c71a146c678d186514626027d6edac4e985f08e5d6ce34217b91cefa88be0174f5f45e8caba5da4c50911780e37f1b WHIRLPOOL e10bf9d10c64e1950dd2bb48ce1fca2950acdeefd99483825751acbbf29806494cbb629ac1d51f24978a8a6a2df2ce73de2910380f8e26e4a0884bcc1f116406
diff --git a/net-misc/electrum/electrum-2.1.1.ebuild b/net-misc/electrum/electrum-2.1.1.ebuild
new file mode 100644
index 000000000000..6307463abbea
--- /dev/null
+++ b/net-misc/electrum/electrum-2.1.1.ebuild
@@ -0,0 +1,144 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="ncurses?"
+
+inherit eutils distutils-r1 gnome2-utils
+
+MY_P="Electrum-${PV}"
+DESCRIPTION="User friendly Bitcoin client"
+HOMEPAGE="https://electrum.org/"
+SRC_URI="https://download.electrum.org/${MY_P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+LINGUAS="ar_SA cs_CZ da_DK de_DE el_GR eo_UY es_ES fr_FR hu_HU hy_AM id_ID it_IT ja_JP ky_KG lv_LV nl_NL pl_PL pt_BR pt_PT ro_RO ru_RU sk_SK sl_SI ta_IN th_TH vi_VN zh_CN"
+
+IUSE="cli cosign +fiat greenaddress_it gtk3 ncurses qrcode +qt4 sync trustedcoin_com vkb"
+
+for lingua in ${LINGUAS}; do
+ IUSE+=" linguas_${lingua}"
+done
+
+REQUIRED_USE="
+ || ( cli gtk3 ncurses qt4 )
+ cosign? ( qt4 )
+ fiat? ( qt4 )
+ greenaddress_it? ( qt4 )
+ qrcode? ( qt4 )
+ sync? ( qt4 )
+ trustedcoin_com? ( qt4 )
+ vkb? ( qt4 )
+"
+
+RDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/ecdsa-0.9[${PYTHON_USEDEP}]
+ dev-python/slowaes[${PYTHON_USEDEP}]
+ dev-python/pbkdf2[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/pyasn1[${PYTHON_USEDEP}]
+ dev-python/pyasn1-modules[${PYTHON_USEDEP}]
+ dev-python/tlslite[${PYTHON_USEDEP}]
+ dev-python/qrcode[${PYTHON_USEDEP}]
+ dev-python/socksipy[${PYTHON_USEDEP}]
+ dev-libs/protobuf[python,${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ gtk3? (
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ x11-libs/gtk+:3[introspection]
+ )
+ qrcode? ( media-gfx/zbar[python,v4l,${PYTHON_USEDEP}] )
+ qt4? (
+ dev-python/PyQt4[${PYTHON_USEDEP}]
+ )
+ ncurses? ( dev-lang/python )
+"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS="RELEASE-NOTES"
+
+src_prepare() {
+ # Don't advise using PIP
+ sed -i "s/On Linux, try 'sudo pip install zbar'/Re-emerge Electrum with the qrcode USE flag/" lib/qrscanner.py || die
+
+ # Prevent icon from being installed in the wrong location
+ sed -i '/icons/d' setup.py || die
+
+ validate_desktop_entries
+
+ # Remove unrequested localization files:
+ for lang in ${LINGUAS}; do
+ use "linguas_${lang}" && continue
+ rm -r "lib/locale/${lang}" || die
+ done
+
+ local wordlist=
+ # french is unfinished
+ for wordlist in \
+ $(usex linguas_es_ES '' spanish) \
+ $(usex linguas_pt_BR '' $(usex linguas_pt_PT '' portuguese)) \
+ french \
+ $(usex linguas_ja_JP '' japanese) \
+ ; do
+ rm "lib/wordlist/${wordlist}.txt" || die
+ sed -i "/${wordlist}\\.txt/d" lib/mnemonic.py || die
+ done
+
+ # Remove unrequested GUI implementations:
+ local gui
+ for gui in \
+ $(usex cli '' stdio) \
+ $(usex gtk3 '' gtk ) \
+ $(usex qt4 '' qt ) \
+ $(usex ncurses '' text ) \
+ ; do
+ rm gui/"${gui}"* -r || die
+ done
+
+ if ! use qt4; then
+ sed -i "s/'electrum_gui\\.qt',//;/\"qt\\/themes/d" setup.py || die
+ local bestgui=$(usex gtk3 gtk $(usex ncurses text stdio))
+ sed -i "s/\(config.get('gui', \?\)'classic'/\1'${bestgui}'/" electrum || die
+ fi
+
+ local plugin
+ # btchipwallet requires python btchip module (and dev-python/pyusb)
+ # trezor requires python trezorlib module
+ for plugin in \
+ $(usex cosign '' cosigner_pool ) \
+ $(usex fiat '' exchange_rate ) \
+ $(usex greenaddress_it '' greenaddress_instant) \
+ $(usex sync '' labels ) \
+ trezor \
+ $(usex trustedcoin_com '' trustedcoin ) \
+ $(usex vkb '' virtualkeyboard ) \
+ ; do
+ rm plugins/"${plugin}"* || die
+ done
+
+ distutils-r1_src_prepare
+}
+
+src_install() {
+ doicon -s 128 icons/${PN}.png
+ distutils-r1_src_install
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/net-misc/electrum/electrum-2.3.3.ebuild b/net-misc/electrum/electrum-2.3.3.ebuild
new file mode 100644
index 000000000000..64d73284704d
--- /dev/null
+++ b/net-misc/electrum/electrum-2.3.3.ebuild
@@ -0,0 +1,144 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="ncurses?"
+
+inherit eutils distutils-r1 gnome2-utils
+
+MY_P="Electrum-${PV}"
+DESCRIPTION="User friendly Bitcoin client"
+HOMEPAGE="https://electrum.org/"
+SRC_URI="https://download.electrum.org/${MY_P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+LINGUAS="ar_SA cs_CZ da_DK de_DE el_GR eo_UY es_ES fr_FR hu_HU hy_AM id_ID it_IT ja_JP ky_KG lv_LV nl_NL pl_PL pt_BR pt_PT ro_RO ru_RU sk_SK sl_SI ta_IN th_TH vi_VN zh_CN"
+
+IUSE="cli cosign +fiat greenaddress_it gtk3 ncurses qrcode +qt4 sync trustedcoin_com vkb"
+
+for lingua in ${LINGUAS}; do
+ IUSE+=" linguas_${lingua}"
+done
+
+REQUIRED_USE="
+ || ( cli gtk3 ncurses qt4 )
+ cosign? ( qt4 )
+ fiat? ( qt4 )
+ greenaddress_it? ( qt4 )
+ qrcode? ( qt4 )
+ sync? ( qt4 )
+ trustedcoin_com? ( qt4 )
+ vkb? ( qt4 )
+"
+
+RDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/ecdsa-0.9[${PYTHON_USEDEP}]
+ dev-python/slowaes[${PYTHON_USEDEP}]
+ dev-python/pbkdf2[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/pyasn1[${PYTHON_USEDEP}]
+ dev-python/pyasn1-modules[${PYTHON_USEDEP}]
+ dev-python/tlslite[${PYTHON_USEDEP}]
+ dev-python/qrcode[${PYTHON_USEDEP}]
+ dev-python/socksipy[${PYTHON_USEDEP}]
+ dev-libs/protobuf[python,${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ gtk3? (
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ x11-libs/gtk+:3[introspection]
+ )
+ qrcode? ( media-gfx/zbar[python,v4l,${PYTHON_USEDEP}] )
+ qt4? (
+ dev-python/PyQt4[${PYTHON_USEDEP}]
+ )
+ ncurses? ( dev-lang/python )
+"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS="RELEASE-NOTES"
+
+src_prepare() {
+ # Don't advise using PIP
+ sed -i "s/On Linux, try 'sudo pip install zbar'/Re-emerge Electrum with the qrcode USE flag/" lib/qrscanner.py || die
+
+ # Prevent icon from being installed in the wrong location
+ sed -i '/icons/d' setup.py || die
+
+ validate_desktop_entries
+
+ # Remove unrequested localization files:
+ for lang in ${LINGUAS}; do
+ use "linguas_${lang}" && continue
+ rm -r "lib/locale/${lang}" || die
+ done
+
+ local wordlist=
+ # french is unfinished
+ for wordlist in \
+ $(usex linguas_es_ES '' spanish) \
+ $(usex linguas_pt_BR '' $(usex linguas_pt_PT '' portuguese)) \
+ french \
+ $(usex linguas_ja_JP '' japanese) \
+ ; do
+ rm "lib/wordlist/${wordlist}.txt" || die
+ sed -i "/${wordlist}\\.txt/d" lib/mnemonic.py || die
+ done
+
+ # Remove unrequested GUI implementations:
+ local gui
+ for gui in \
+ $(usex cli '' stdio) \
+ $(usex gtk3 '' gtk ) \
+ $(usex qt4 '' qt ) \
+ $(usex ncurses '' text ) \
+ ; do
+ rm gui/"${gui}"* -r || die
+ done
+
+ if ! use qt4; then
+ sed -i "s/'electrum_gui\\.qt',//;/\"qt\\/themes/d" setup.py || die
+ local bestgui=$(usex gtk3 gtk $(usex ncurses text stdio))
+ sed -i "s/\(config.get('gui', \?\)'classic'/\1'${bestgui}'/" electrum || die
+ fi
+
+ local plugin
+ # btchipwallet requires python btchip module (and dev-python/pyusb)
+ # trezor requires python trezorlib module
+ for plugin in \
+ $(usex cosign '' cosigner_pool ) \
+ $(usex fiat '' exchange_rate ) \
+ $(usex greenaddress_it '' greenaddress_instant) \
+ $(usex sync '' labels ) \
+ trezor \
+ $(usex trustedcoin_com '' trustedcoin ) \
+ $(usex vkb '' virtualkeyboard ) \
+ ; do
+ rm plugins/"${plugin}"* || die
+ done
+
+ distutils-r1_src_prepare
+}
+
+src_install() {
+ doicon -s 128 icons/${PN}.png
+ distutils-r1_src_install
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/net-misc/electrum/metadata.xml b/net-misc/electrum/metadata.xml
new file mode 100644
index 000000000000..b87011874fc5
--- /dev/null
+++ b/net-misc/electrum/metadata.xml
@@ -0,0 +1,32 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>blueness@gentoo.org</email>
+ <name>Anthony G. Basile</name>
+ </maintainer>
+ <maintainer>
+ <email>luke-jr+gentoobugs@utopios.org</email>
+ <name>Luke Dashjr</name>
+ </maintainer>
+ <maintainer>
+ <email>maksverver@geocities.com</email>
+ <name>Maks Verver</name>
+ </maintainer>
+ <maintainer>
+ <email>emery@vfemail.net</email>
+ <name>Emery Hemingway</name>
+ </maintainer>
+ <use>
+ <flag name='cli'>Enables the CLI interface</flag>
+ <flag name='cosign'>Enable plugin to support multisig wallets between multiple Electrum clients</flag>
+ <flag name='fiat'>Enable plugin for looking up fiat values of bitcoin</flag>
+ <flag name='greenaddress_it'>Enable plugin to verify GreenAddress.it instant transactions</flag>
+ <flag name='gtk3'>Enable support for gtk+3</flag>
+ <flag name='qrcode'>Enable QR code scanning with <pkg>media-gfx/zbar</pkg></flag>
+ <flag name='sync'>Enable plugin to sync wallet metadata across multiple Electrum clients</flag>
+ <flag name='trustedcoin_com'>Enable plugin to use two-factor service by TrustedCoin.com</flag>
+ <flag name='vkb'>Enable plugin for virtual keyboard</flag>
+ </use>
+</pkgmetadata>