summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArmas Spann <zappel@simple-co.de>2024-01-31 15:37:29 +0100
committerMaciej Barć <xgqt@gentoo.org>2024-02-01 11:10:14 +0100
commit5ff9d37a4a52b1ad126422ebcd48cf098f4dc5e6 (patch)
treee2e3eb72635e069a93d884752db11a8319c6191a /net-misc/croc
parentacct-user/croc: bump to 0-r2; take up maintainership (diff)
downloadgentoo-5ff9d37a4a52b1ad126422ebcd48cf098f4dc5e6.tar.gz
gentoo-5ff9d37a4a52b1ad126422ebcd48cf098f4dc5e6.tar.bz2
gentoo-5ff9d37a4a52b1ad126422ebcd48cf098f4dc5e6.zip
net-misc/croc: bump to 9.6.6; take up maintainership
Changes: - Version bump to 9.6.6 - Updated to EAPI 8 - Added myself as a proxy maintainer for this package Signed-off-by: Armas Spann <zappel@simple-co.de> Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'net-misc/croc')
-rw-r--r--net-misc/croc/Manifest2
-rw-r--r--net-misc/croc/croc-9.6.6.ebuild51
-rw-r--r--net-misc/croc/metadata.xml17
3 files changed, 66 insertions, 4 deletions
diff --git a/net-misc/croc/Manifest b/net-misc/croc/Manifest
index a9c654a82144..a3bac37040d9 100644
--- a/net-misc/croc/Manifest
+++ b/net-misc/croc/Manifest
@@ -2,3 +2,5 @@ DIST croc-9.6.2-deps.tar.xz 27304100 BLAKE2B 6eac681bcc60db0b81abad19c3d8d994f2e
DIST croc-9.6.2.tar.gz 507769 BLAKE2B df99a7d5d60f753d4d7fd5924bb09be6b21513acbc0c454d2e199fca4ab38eee0b443a091e3b3c64e155cb460e760959d955969231df8a93da2472a6b93703f0 SHA512 a3ad2f6a4bc6a45fa356963bd123ea755caa30c6a3b63e63cc67823ce27d44d62610ff9bfa498f694e356f673c3fcb3cec7ac669bedcde6eaf63111a78538965
DIST croc-9.6.4-deps.tar.xz 26792064 BLAKE2B 31ead16462c1e10fff9e756c44f4ac7d47dcaa444dcb2fdcdd7f762d1617640a736d4223f74c9dd4f27b62bb3d635fe3035ec0127b3e50a7d8fa83ba26cdce43 SHA512 bc69c6d678888621d93be878a49ad71c04e6b38742d1c1558a1a84d1a63c71c9a901149048e6e4f0385514dbb551e89585e8ed25fc6ec89b9f2437f78f52a1e5
DIST croc-9.6.4.tar.gz 508495 BLAKE2B 985b3f27fd807e62eda121dcad45e150621ff50cf82fc778cac601fdb16e0aab6bab886326bd80b0cc218608ddddd42a3f537fdfeec3948d1617a4169fefdd0e SHA512 d6eab257ee49d12d07e38b37ae1d60cbf70f627618ea32f2ec74370a09e78cad929de4b7d2bd02e9f300f698d45c8c28f4b4eb337a0be8f29e046fee4bb19b1f
+DIST croc-9.6.6-vendor.tar.xz 972376 BLAKE2B ad1f77ef5d26ace05edffd3628da3c1ab393549d17761c70c3302e35179587097657a1d1e82f9be1732fb5d7df9a2f0eac6e003c43b0767d56662d87a5159d51 SHA512 53fc2af249ff62b702587bd89155c5432415dc6d8d8643453cb6d17f46b74cf669ecc7f06a5f64da459c690858126202be365d25ec31e73840621de2bf68faba
+DIST croc-9.6.6.tar.gz 511129 BLAKE2B 550228f7911ffbeac656fe7930f879db7ab8630e52acbd8a859a14219673937f2994d3fd02e42999754e5a701b9b3296ab7907c231fac2e4a37c51588b864190 SHA512 0e3dec57d0d1337c9f45c81fa71f6d9673cc76f5c53ae9b0068f9e388788c433debebb536a43ec578b58e80b9da482949ff16cc63a883b8085fbec54a932bde2
diff --git a/net-misc/croc/croc-9.6.6.ebuild b/net-misc/croc/croc-9.6.6.ebuild
new file mode 100644
index 000000000000..b1612329093f
--- /dev/null
+++ b/net-misc/croc/croc-9.6.6.ebuild
@@ -0,0 +1,51 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit bash-completion-r1 go-module systemd
+
+DESCRIPTION="Easily and securely send things from one computer to another"
+HOMEPAGE="https://github.com/schollz/croc"
+SRC_URI="https://github.com/schollz/croc/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz
+https://dev.gentoo.org/~xgqt/distfiles/deps/${P}-vendor.tar.xz
+"
+
+LICENSE="Apache-2.0 BSD BSD-2 MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ acct-group/croc
+ acct-user/croc
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-disable-network-tests-r1.patch"
+)
+
+DOCS=( README.md )
+
+src_prepare() {
+ default
+ # Replace User=nobody with User=croc
+ sed -i -e "s|\(^User=\).*|\1croc|g" croc.service || die
+ # Rename bash completion function
+ sed -i -e "s|_cli_bash_autocomplete|_croc|g" \
+ src/install/bash_autocomplete || die
+}
+
+src_compile() {
+ ego build
+}
+
+src_install() {
+ dobin croc
+ systemd_dounit croc.service
+ newbashcomp src/install/bash_autocomplete croc
+ einstalldocs
+}
+
+src_test() {
+ ego test -work ./...
+}
diff --git a/net-misc/croc/metadata.xml b/net-misc/croc/metadata.xml
index b14d4f0b4014..c51b4929e88d 100644
--- a/net-misc/croc/metadata.xml
+++ b/net-misc/croc/metadata.xml
@@ -1,8 +1,17 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <!-- maintainer-needed -->
- <upstream>
- <remote-id type="github">schollz/croc</remote-id>
- </upstream>
+ <maintainer type="person" proxied="yes">
+ <name>Armas Spann</name>
+ <email>zappel@simple-co.de</email>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">schollz/croc</remote-id>
+ <doc>https://schollz.com/tinker/croc6/</doc>
+ <bugs-to>https://github.com/schollz/croc/issues</bugs-to>
+ </upstream>
</pkgmetadata>