summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJaco Kroon <jaco@uls.co.za>2022-12-22 16:45:01 +0200
committerViorel Munteanu <ceamac@gentoo.org>2023-01-04 11:19:58 +0200
commit5bb39bc1257b8183868cc9af5c69c1e2bbcb9012 (patch)
tree770c5aea4be48582263460669f732c818094630f /net-misc/anydesk
parentsys-apps/moar: block dev-lang/moarvm (diff)
downloadgentoo-5bb39bc1257b8183868cc9af5c69c1e2bbcb9012.tar.gz
gentoo-5bb39bc1257b8183868cc9af5c69c1e2bbcb9012.tar.bz2
gentoo-5bb39bc1257b8183868cc9af5c69c1e2bbcb9012.zip
net-misc/anydesk: add 6.2.1
NOTE: gtkglext dep is still required. dev-libs/atk replaced with app-accessibility/at-spi2-core:2 added media-libs/libglvnd Closes: https://bugs.gentoo.org/887809 Signed-off-by: Jaco Kroon <jaco@uls.co.za> Closes: https://github.com/gentoo/gentoo/pull/28760 Signed-off-by: Viorel Munteanu <ceamac@gentoo.org>
Diffstat (limited to 'net-misc/anydesk')
-rw-r--r--net-misc/anydesk/Manifest1
-rw-r--r--net-misc/anydesk/anydesk-6.2.1.ebuild101
2 files changed, 102 insertions, 0 deletions
diff --git a/net-misc/anydesk/Manifest b/net-misc/anydesk/Manifest
index 2ae71ad5cfd4..1146fa58155c 100644
--- a/net-misc/anydesk/Manifest
+++ b/net-misc/anydesk/Manifest
@@ -1 +1,2 @@
DIST anydesk-6.2.0-amd64.tar.gz 6216311 BLAKE2B ffdd139e5e67cf9da5eefcd8c261a52d5e556923353baec8d848aea95a6583280845c3d2cf9c34fbcbecf9ddb3991aa59542baf74f2761cc4a7ee69637be0bd4 SHA512 673e5a0a0ca6d2c550c9c01a07edd2096db26416286a5a603adfc7a844d864f327061e0906978c6e4cd0871859f12f281a52b3bceffe8a6014a1bb3c54322ab6
+DIST anydesk-6.2.1-amd64.tar.gz 6634159 BLAKE2B 03abb9c3a990a8e4b53505896ebef253c386f578a275ccbec55e85cbb27e5c0f140863c6dc407b1d0cc2f2975b63bcd13487e27425b16cd3fdb42fd71a646e97 SHA512 2a36eb0698d18d7f779a9c7b8a17b2a9964fc10ba1ce65a68555332e58fd316b8541ef5443c8f8a62a30711e8dd19174d599ac2cdccd581da645c6b6a7e000ae
diff --git a/net-misc/anydesk/anydesk-6.2.1.ebuild b/net-misc/anydesk/anydesk-6.2.1.ebuild
new file mode 100644
index 000000000000..90d3f93c2857
--- /dev/null
+++ b/net-misc/anydesk/anydesk-6.2.1.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+inherit desktop optfeature systemd xdg-utils
+
+DESCRIPTION="Feature rich multi-platform remote desktop application"
+HOMEPAGE="https://anydesk.com"
+SRC_URI="https://download.anydesk.com/linux/${P}-amd64.tar.gz
+ https://download.anydesk.com/linux/generic-linux/${P}-amd64.tar.gz"
+
+# OpeSSL/SSLeay, libvpx, zlib, Xiph, xxHash
+LICENSE="AnyDesk-TOS BSD BSD-2 openssl ZLIB"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+
+# x11-libs/gtkglext is required and cannot be mitigated: https://bugs.gentoo.org/868255
+RDEPEND="
+ app-accessibility/at-spi2-core:2
+ dev-libs/glib:2
+ media-libs/fontconfig:1.0
+ media-libs/freetype:2
+ media-libs/glu
+ media-libs/libglvnd
+ sys-auth/polkit
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:2
+ x11-libs/gtkglext
+ x11-libs/libX11
+ x11-libs/libxcb
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXi
+ x11-libs/libxkbfile
+ x11-libs/libXrandr
+ x11-libs/libXrender
+ x11-libs/libXtst
+ x11-libs/pango
+"
+BDEPEND="dev-util/patchelf"
+
+RESTRICT="bindist mirror"
+
+QA_PREBUILT="opt/${PN}/*"
+
+src_install() {
+ local dst="/opt/${PN}"
+
+ exeinto ${dst}
+ doexe ${PN}
+
+ dodir /opt/bin
+ dosym "${dst}/${PN}" "/opt/bin/${PN}"
+
+ newinitd "${FILESDIR}/anydesk.init" anydesk
+ systemd_newunit "${FILESDIR}/anydesk-4.0.1.service" anydesk.service
+
+ insinto /usr/share/polkit-1/actions
+ doins polkit-1/com.anydesk.anydesk.policy
+
+ insinto /usr/share
+ doins -r icons
+
+ domenu "${FILESDIR}/anydesk.desktop"
+
+ dodoc copyright README
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ elog "To run AnyDesk as background service use:"
+ elog
+ elog "OpenRC:"
+ elog "# rc-service anydesk start"
+ elog "# rc-update add anydesk default"
+ elog
+ elog "Systemd:"
+ elog "# systemctl start anydesk.service"
+ elog "# systemctl enable anydesk.service"
+ elog
+ elog "Please see README at /usr/share/doc/${PF}/README.bz2 for"
+ elog "further information about the linux version of AnyDesk."
+ elog
+ fi
+
+ optfeature_header "AnyDesk uses additional tools to query information about the host:"
+ optfeature "lsb_release" sys-apps/lsb-release
+ optfeature "lspci" sys-apps/pciutils
+ optfeature "lsusb" sys-apps/usbutils
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}