summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2015-12-16 19:30:06 +0800
committerIan Delaney <idella4@gentoo.org>2015-12-16 19:30:06 +0800
commit6e510a5184061dde30c1430279c2a638aeef09b0 (patch)
tree99b05f948fbf5c0bc317de1df31655aad4846109 /net-libs
parentapp-misc/elasticsearch: add the elasticsearch.init5 script to FILESDIR (diff)
parentnet-libs/librsync: version bump to 2.0.0, fix #525396 (diff)
downloadgentoo-6e510a5184061dde30c1430279c2a638aeef09b0.tar.gz
gentoo-6e510a5184061dde30c1430279c2a638aeef09b0.tar.bz2
gentoo-6e510a5184061dde30c1430279c2a638aeef09b0.zip
Merge remote-tracking branch 'remotes/axelgenus/librsync-2.0'
Pull request: https://github.com/gentoo/gentoo/pull/475
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/librsync/Manifest1
-rw-r--r--net-libs/librsync/librsync-2.0.0.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/net-libs/librsync/Manifest b/net-libs/librsync/Manifest
index f189840c93fb..224f662d0abf 100644
--- a/net-libs/librsync/Manifest
+++ b/net-libs/librsync/Manifest
@@ -1 +1,2 @@
DIST librsync-0.9.7.tar.gz 453802 SHA256 6633e4605662763a03bb6388529cbdfd3b11a9ec55b8845351c1bd9a92bc41d6 SHA512 339362fd01c94411849d3e4a6e95db1bef6cffa0475b1af49d73f11be0421a12d4c73ecbf1a272af01b2a21cec81b4a801c1f7d735e107d0242707fb4c45f9ef WHIRLPOOL 7cf5cc675c4bf4e041d9132f0a8311f83e827bfa7dd75180f3153cabeab41a94011e1a9b56e63a61dbe119444e2c24a39054986d97b686db99293ad9177b2bf7
+DIST librsync-2.0.0.tar.gz 155049 SHA256 b5c4dd114289832039397789e42d4ff0d1108ada89ce74f1999398593fae2169 SHA512 1a88dcc3aa60949e058c57eb0df3e0086823c493de40fed927246f5aada6274db57202074456a0ce5d9aa8b81b41836b0d6221ded6a75d43829572584177e8c0 WHIRLPOOL a09e76a712ca21a37bc3d06cf2f97a0e7201cfcf82c18cbebf3f07bfd453ac3503d18c900b7c1136e0319ec7f3b7c4a6c43611648c78b31fe13c7298ccf016e0
diff --git a/net-libs/librsync/librsync-2.0.0.ebuild b/net-libs/librsync/librsync-2.0.0.ebuild
new file mode 100644
index 000000000000..bd51b8fbe2f6
--- /dev/null
+++ b/net-libs/librsync/librsync-2.0.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils
+
+DESCRIPTION="Remote delta-compression library"
+HOMEPAGE="http://librsync.sourcefrog.net/"
+SRC_URI="https://github.com/librsync/librsync/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+
+RDEPEND="dev-libs/popt"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ # isprefix_test does not work in portage environment
+ sed -i '169 s/^/#/' CMakeLists.txt || die
+
+ # fix compiling with multilib-strict feature enabled
+ sed -i "242 s/lib/$(get_libdir)/" CMakeLists.txt || die
+
+ cmake-utils_src_prepare
+}