summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdrian Schollmeyer <nex+b-g-o@nexadn.de>2024-02-20 18:25:53 +0100
committerViorel Munteanu <ceamac@gentoo.org>2024-02-29 18:14:22 +0200
commit045904004c73abfe698bffc55f77273f1b9e32a2 (patch)
tree6cd23878192ab225a67e29e70627e2bdb1ac9bfb /net-irc
parentsys-apps/syd: add 3.14.1, drop 3.13.1 (diff)
downloadgentoo-045904004c73abfe698bffc55f77273f1b9e32a2.tar.gz
gentoo-045904004c73abfe698bffc55f77273f1b9e32a2.tar.bz2
gentoo-045904004c73abfe698bffc55f77273f1b9e32a2.zip
net-irc/hexchat: add 2.16.2
Closes: https://bugs.gentoo.org/924289 Signed-off-by: Adrian Schollmeyer <nex+b-g-o@nexadn.de> Signed-off-by: Viorel Munteanu <ceamac@gentoo.org>
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/hexchat/Manifest1
-rw-r--r--net-irc/hexchat/hexchat-2.16.2.ebuild138
2 files changed, 139 insertions, 0 deletions
diff --git a/net-irc/hexchat/Manifest b/net-irc/hexchat/Manifest
index 5d8f6c9d2b9d..30dbde40883e 100644
--- a/net-irc/hexchat/Manifest
+++ b/net-irc/hexchat/Manifest
@@ -1 +1,2 @@
DIST hexchat-2.16.1.tar.xz 1349536 BLAKE2B 6e1d9f7c36affc94356e0124ea445f019d8f00b643896ec004af17059befadfcd8fc1b75ef9fba277542dcf8593e8e4683a709a4c4cbaaaf4f3122d8488dc6ce SHA512 9e6baa30ec8c3ce4fb56e2c82625da63295040eaf93a542aec8a4a18a6a3c95d69d1d4ffabc952bcdcd7b754afef234b348f296143991fafd0550342db95ce0e
+DIST hexchat-2.16.2.tar.xz 1352304 BLAKE2B 4977e44733539f9f7f1bbd7c66d0f945bdd6696650ad75975a19f2de931377626124aaed8fc2f98f345de2a00787eda2077ed7a5364d811f07237d88a8cc88dc SHA512 2ceb4332328c4acf55a46bf5c45788a7f3a73fd2ffd676751c75cc08ca04ced5569c1e6406877e6f2972b8967e94bea2ad70a6966ade7cd811b5c4d700409ee2
diff --git a/net-irc/hexchat/hexchat-2.16.2.ebuild b/net-irc/hexchat/hexchat-2.16.2.ebuild
new file mode 100644
index 000000000000..1958b10d37e7
--- /dev/null
+++ b/net-irc/hexchat/hexchat-2.16.2.ebuild
@@ -0,0 +1,138 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+LUA_COMPAT=( lua5-{1..5} luajit )
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit lua-single meson mono-env python-single-r1 xdg
+
+DESCRIPTION="Graphical IRC client based on XChat"
+HOMEPAGE="https://hexchat.github.io/"
+
+if [[ "${PV}" == "9999" ]] ; then
+ inherit git-r3
+ # We need to empty SRC_URI or else mono-env breaks the live ebuild
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/${PN}/${PN}.git"
+else
+ SRC_URI="https://github.com/${PN}/${PN}/releases/download/v${PV}/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux"
+fi
+
+LICENSE="GPL-2 plugin-fishlim? ( MIT )"
+SLOT="0"
+IUSE="dbus debug +gtk libcanberra lua perl plugin-checksum plugin-fishlim plugin-sysinfo python ssl theme-manager"
+REQUIRED_USE="lua? ( ${LUA_REQUIRED_USE} )
+ plugin-fishlim? ( ssl )
+ python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="
+ dev-libs/glib:2
+ dbus? ( dev-libs/dbus-glib )
+ gtk? (
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:2
+ x11-libs/libX11
+ x11-libs/pango
+ )
+ libcanberra? ( media-libs/libcanberra )
+ lua? ( ${LUA_DEPS} )
+ perl? ( dev-lang/perl:= )
+ plugin-sysinfo? ( sys-apps/pciutils )
+ python? (
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ dev-python/cffi[${PYTHON_USEDEP}]
+ ' 'python*')
+ )
+ ssl? ( dev-libs/openssl:0= )
+ theme-manager? (
+ || (
+ (
+ dev-lang/mono[minimal]
+ dev-dotnet/libgdiplus
+ )
+ dev-lang/mono[-minimal]
+ )
+ )"
+
+DEPEND="${RDEPEND}"
+BDEPEND="
+ app-arch/xz-utils
+ app-text/iso-codes
+ dev-util/glib-utils
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+pkg_setup() {
+ use lua && lua-single_pkg_setup
+ use python && python-single-r1_pkg_setup
+ if use theme-manager ; then
+ mono-env_pkg_setup
+ export XDG_CACHE_HOME="${T}/.cache"
+ fi
+}
+
+src_configure() {
+ local emesonargs=(
+ -Ddbus-service-use-appid=false
+ -Dinstall-appdata=false
+ -Dplugin=true
+ $(meson_feature dbus)
+ $(meson_feature libcanberra)
+ $(meson_feature ssl tls)
+ $(meson_use gtk gtk-frontend)
+ $(meson_use !gtk text-frontend)
+ $(meson_use theme-manager)
+
+ $(meson_use plugin-checksum with-checksum)
+ $(meson_use plugin-fishlim with-fishlim)
+ -Dwith-lua="$(usex lua "${ELUA}" false)"
+ -Dwith-perl="$(usex perl "${EPREFIX}"/usr/bin/perl false)"
+ -Dwith-python="$(usex python "${EPYTHON/.*}" false)"
+ $(meson_use plugin-sysinfo with-sysinfo)
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ dodoc readme.md
+ find "${ED}" -type f -name '*.la' -delete || die
+}
+
+pkg_preinst() {
+ if use gtk ; then
+ xdg_pkg_preinst
+ fi
+}
+
+pkg_postinst() {
+ if use gtk ; then
+ xdg_pkg_postinst
+ else
+ elog "You have disabled the gtk USE flag. This means you don't have"
+ elog "the GTK-GUI for HexChat but only a text interface called \"hexchat-text\"."
+ fi
+
+ if use theme-manager ; then
+ elog "Themes are available at:"
+ elog " https://hexchat.github.io/themes.html"
+ fi
+
+ elog
+ elog "optional dependencies:"
+ elog " media-sound/sox (sound playback if you don't have libcanberra"
+ elog " enabled)"
+ elog " x11-themes/sound-theme-freedesktop (default BEEP sound,"
+ elog " needs libcanberra enabled)"
+}
+
+pkg_postrm() {
+ if use gtk ; then
+ xdg_pkg_postrm
+ fi
+}