summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2018-04-07 10:38:08 +0200
committerHans de Graaff <graaff@gentoo.org>2018-04-07 10:38:34 +0200
commit4e61d05c9aecb3eee317fc1b12b3397f44d0ca91 (patch)
treec5584d658140104a950bd87ec26ef501f1d8b407 /net-irc/epic5
parentdev-python/discogs-client: Tested on python3* (diff)
downloadgentoo-4e61d05c9aecb3eee317fc1b12b3397f44d0ca91.tar.gz
gentoo-4e61d05c9aecb3eee317fc1b12b3397f44d0ca91.tar.bz2
gentoo-4e61d05c9aecb3eee317fc1b12b3397f44d0ca91.zip
net-irc/epic5: fix ruby support, bug 650342
Switch to ruby-single.eclass. This fixes bug 650342 but also simplifies ruby dependency handling. Remove the REQUIRED_USE since this will always be a blocker for most people and simply build against the currently selected ruby version provided by ruby-single. This is in effect what the ebuild was doing before anyway. Include correct slot for ncurses. Use EAPI=6. Closes: https://bugs.gentoo.org/650342 Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'net-irc/epic5')
-rw-r--r--net-irc/epic5/epic5-1.1.10-r2.ebuild77
1 files changed, 77 insertions, 0 deletions
diff --git a/net-irc/epic5/epic5-1.1.10-r2.ebuild b/net-irc/epic5/epic5-1.1.10-r2.ebuild
new file mode 100644
index 000000000000..323296c7006d
--- /dev/null
+++ b/net-irc/epic5/epic5-1.1.10-r2.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby22 ruby23"
+
+inherit autotools eutils multilib ruby-single toolchain-funcs
+
+DESCRIPTION="Epic5 IRC Client"
+SRC_URI="ftp://ftp.epicsol.org/pub/epic/EPIC5-PRODUCTION/${P}.tar.bz2"
+HOMEPAGE="http://epicsol.org/"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="archive ipv6 perl tcl ruby socks5 valgrind"
+
+RDEPEND="
+ >=dev-libs/openssl-0.9.8e-r3:0
+ >=sys-libs/ncurses-5.6-r2:0
+ virtual/libiconv
+ archive? ( app-arch/libarchive )
+ perl? ( >=dev-lang/perl-5.8.8-r2 )
+ tcl? ( dev-lang/tcl:0 )
+ socks5? ( net-proxy/dante )
+ ruby? ( ${RUBY_DEPS} )"
+DEPEND="${RDEPEND}
+ valgrind? ( dev-util/valgrind )"
+
+S=${WORKDIR}/${P}
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PN}-1.1.2-libarchive-automagic.patch \
+ "${FILESDIR}"/${P}-ruby-automagic-as-needed.patch \
+ "${FILESDIR}"/${P}-tcl-automagic-as-needed.patch \
+ "${FILESDIR}"/${PN}-1.1.2-perl-automagic-as-needed.patch \
+ "${FILESDIR}"/${P}-without-localdir.patch \
+ "${FILESDIR}"/${P}-socks5-libsocks.patch
+
+ eapply_user
+
+ eautoconf
+}
+
+src_configure() {
+ # Because of our REQUIRED_USE constraints above, we know that
+ # ruby_get_use_implementations will only ever return one ruby
+ # implementation.
+ econf \
+ --libexecdir="${EPREFIX}"/usr/lib/misc \
+ $(use_with archive libarchive) \
+ $(use_with ipv6) \
+ $(use_with perl) \
+ $(use_with ruby) \
+ $(use_with socks5) \
+ $(use_with tcl tcl "${EPREFIX}"/usr/$(get_libdir)/tclConfig.sh) \
+ $(use_with valgrind valgrind)
+}
+
+src_compile() {
+ # parallel build failure
+ emake -j1
+}
+
+src_install () {
+ default
+
+ dodoc BUG_FORM COPYRIGHT EPIC4-USERS-README README KNOWNBUGS VOTES
+
+ cd "${S}"/doc || die
+ docinto doc
+ dodoc \
+ *.txt colors EPIC* IRCII_VERSIONS missing \
+ nicknames outputhelp README.SSL SILLINESS TS4
+}