summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorQuincy Fleming <quincyf467@protonmail.com>2024-05-15 08:43:44 +0000
committerYixun Lan <dlan@gentoo.org>2024-05-15 08:50:52 +0000
commit120013af5e426be31d56a12b672429380d506959 (patch)
treea8bedfec39c4350951834d2e545a50b2116d1a52 /net-im
parentapp-emulation/wine-staging: enable py3.13 (diff)
downloadgentoo-120013af5e426be31d56a12b672429380d506959.tar.gz
gentoo-120013af5e426be31d56a12b672429380d506959.tar.bz2
gentoo-120013af5e426be31d56a12b672429380d506959.zip
net-im/telegram-desktop: fix compile error
fix case with USE=X disabled and USE=wayland enabled Closes: https://bugs.gentoo.org/931923 Closes: https://github.com/gentoo/gentoo/pull/36680 Acked-by: Esteve Varela Colominas <esteve.varela@gmail.com> Signed-off-by: Quincy Fleming <quincyf467@protonmail.com> Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'net-im')
-rw-r--r--net-im/telegram-desktop/files/tdesktop-5.0.1-qt6-no-wayland.patch20
-rw-r--r--net-im/telegram-desktop/telegram-desktop-5.0.1-r1.ebuild (renamed from net-im/telegram-desktop/telegram-desktop-5.0.1.ebuild)0
2 files changed, 10 insertions, 10 deletions
diff --git a/net-im/telegram-desktop/files/tdesktop-5.0.1-qt6-no-wayland.patch b/net-im/telegram-desktop/files/tdesktop-5.0.1-qt6-no-wayland.patch
index 10a8743a0d31..2c10ceb9b388 100644
--- a/net-im/telegram-desktop/files/tdesktop-5.0.1-qt6-no-wayland.patch
+++ b/net-im/telegram-desktop/files/tdesktop-5.0.1-qt6-no-wayland.patch
@@ -9,8 +9,8 @@ be seen, depending on what upstream thinks about this.
https://bugs.gentoo.org/928451
https://github.com/desktop-app/cmake_helpers/commit/a428df5440e76a726abc30924766ac7da0cb381c
---- tdesktop-5.0.1-full.orig/Telegram/lib_base/base/platform/linux/base_linux_xdg_activation_token.cpp
-+++ tdesktop-5.0.1-full/Telegram/lib_base/base/platform/linux/base_linux_xdg_activation_token.cpp
+--- a/Telegram/lib_base/base/platform/linux/base_linux_xdg_activation_token.cpp
++++ b/Telegram/lib_base/base/platform/linux/base_linux_xdg_activation_token.cpp
@@ -15,7 +15,7 @@
namespace base::Platform {
@@ -20,14 +20,14 @@ https://github.com/desktop-app/cmake_helpers/commit/a428df5440e76a726abc30924766
const auto window = QGuiApplication::focusWindow();
if (!window) {
callback({});
---- tdesktop-5.0.1-full.orig/Telegram/lib_ui/ui/platform/linux/ui_utility_linux.cpp
-+++ tdesktop-5.0.1-full/Telegram/lib_ui/ui/platform/linux/ui_utility_linux.cpp
+--- a/Telegram/lib_ui/ui/platform/linux/ui_utility_linux.cpp
++++ b/Telegram/lib_ui/ui/platform/linux/ui_utility_linux.cpp
@@ -413,7 +413,7 @@
}
#endif // !DESKTOP_APP_DISABLE_X11_INTEGRATION
-#if QT_VERSION >= QT_VERSION_CHECK(6, 5, 0)
-+#if !defined DESKTOP_APP_DISABLE_X11_INTEGRATION && QT_VERSION >= QT_VERSION_CHECK(6, 5, 0)
++#if !defined DESKTOP_APP_DISABLE_WAYLAND_INTEGRATION && QT_VERSION >= QT_VERSION_CHECK(6, 5, 0)
void ShowWaylandWindowMenu(not_null<QWidget*> widget, const QPoint &point) {
static const auto wl_proxy_marshal_array = [] {
void (*result)(
@@ -67,8 +67,8 @@ https://github.com/desktop-app/cmake_helpers/commit/a428df5440e76a726abc30924766
if (::Platform::IsWayland()) {
ShowWaylandWindowMenu(widget, point);
return;
---- tdesktop-5.0.1-full.orig/cmake/options.cmake
-+++ tdesktop-5.0.1-full/cmake/options.cmake
+--- a/cmake/options.cmake
++++ b/cmake/options.cmake
@@ -23,6 +23,13 @@
)
endif()
@@ -76,15 +76,15 @@ https://github.com/desktop-app/cmake_helpers/commit/a428df5440e76a726abc30924766
+if (DESKTOP_APP_DISABLE_WAYLAND_INTEGRATION)
+ target_compile_definitions(common_options
+ INTERFACE
-+ DESKTOP_APP_DISABLE_WAYLAND_INTEGRATION
++ DESKTOP_APP_DISABLE_WAYLAND_INTEGRATION
+ )
+endif()
+
if (WIN32)
include(cmake/options_win.cmake)
elseif (APPLE)
---- tdesktop-5.0.1-full.orig/cmake/variables.cmake
-+++ tdesktop-5.0.1-full/cmake/variables.cmake
+--- a/cmake/variables.cmake
++++ b/cmake/variables.cmake
@@ -21,6 +21,7 @@
option(DESKTOP_APP_LOTTIE_USE_CACHE "Use caching in lottie animations." ON)
diff --git a/net-im/telegram-desktop/telegram-desktop-5.0.1.ebuild b/net-im/telegram-desktop/telegram-desktop-5.0.1-r1.ebuild
index 0dfe60495f3e..0dfe60495f3e 100644
--- a/net-im/telegram-desktop/telegram-desktop-5.0.1.ebuild
+++ b/net-im/telegram-desktop/telegram-desktop-5.0.1-r1.ebuild