summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Kinard <kumba@gentoo.org>2024-08-04 18:26:59 -0400
committerJoshua Kinard <kumba@gentoo.org>2024-08-04 18:29:31 -0400
commitab85233daba06aabebadda800b5355791a86979f (patch)
treef30eb52fce17cedb70b6a221e9eaacc64df8ffc4 /net-dns
parentsci-libs/openlibm: Bump to 0.8.3 (diff)
downloadgentoo-ab85233daba06aabebadda800b5355791a86979f.tar.gz
gentoo-ab85233daba06aabebadda800b5355791a86979f.tar.bz2
gentoo-ab85233daba06aabebadda800b5355791a86979f.zip
net-dns/nsd: Fix an autoconf check in simdzone src
Added a patch to fix an autoconf check in the simdzone src configure.ac file for Westmere detection that was calling a non-existent C function and breaking the test. Patch submitted to upstream as NLnetLabs/simdzone PR#224. Closes: https://bugs.gentoo.org/937318 Reported-by: Agostino Sarubbo <ago@gentoo.org> Signed-off-by: Joshua Kinard <kumba@gentoo.org>
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/nsd/files/nsd-4.10.1-simdzone-configure_ac-_mm_popcnt_u64.patch12
-rw-r--r--net-dns/nsd/nsd-4.10.1-r2.ebuild (renamed from net-dns/nsd/nsd-4.10.1-r1.ebuild)1
2 files changed, 13 insertions, 0 deletions
diff --git a/net-dns/nsd/files/nsd-4.10.1-simdzone-configure_ac-_mm_popcnt_u64.patch b/net-dns/nsd/files/nsd-4.10.1-simdzone-configure_ac-_mm_popcnt_u64.patch
new file mode 100644
index 000000000000..5d6a38c64a0d
--- /dev/null
+++ b/net-dns/nsd/files/nsd-4.10.1-simdzone-configure_ac-_mm_popcnt_u64.patch
@@ -0,0 +1,12 @@
+diff -Naurp a/simdzone/configure.ac b/simdzone/configure.ac
+--- a/simdzone/configure.ac 2024-08-02 08:05:01.000000000 -0400
++++ b/simdzone/configure.ac 2024-08-04 17:56:15.810347292 -0400
+@@ -76,7 +76,7 @@ AC_INCLUDES_DEFAULT
+ int main(int argc, char *argv[])
+ {
+ (void)argv;
+- uint64_t popcnt = _mm_popcnt_64((uint64_t)argc);
++ uint64_t popcnt = _mm_popcnt_u64((uint64_t)argc);
+ return popcnt == 11;
+ }
+ ]])
diff --git a/net-dns/nsd/nsd-4.10.1-r1.ebuild b/net-dns/nsd/nsd-4.10.1-r2.ebuild
index 099b81460652..06ee9f176c22 100644
--- a/net-dns/nsd/nsd-4.10.1-r1.ebuild
+++ b/net-dns/nsd/nsd-4.10.1-r2.ebuild
@@ -49,6 +49,7 @@ BDEPEND="
"
PATCHES=(
+ "${FILESDIR}/${PN}-4.10.1-simdzone-configure_ac-_mm_popcnt_u64.patch"
"${FILESDIR}/${PN}-munin-gentoo-paths.patch"
)