summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJaco Kroon <jaco@uls.co.za>2024-11-21 00:23:13 +0200
committerSam James <sam@gentoo.org>2024-11-24 23:18:34 +0000
commit478d1858d3deea472be8f143e999ed7b9955633a (patch)
treec0ad31a458a3e7f71e024d056af71203c5c88f6f /net-dialup/xl2tpd
parentnet-print/cups-filters: build w/ -std=gnu17 (diff)
downloadgentoo-478d1858d3deea472be8f143e999ed7b9955633a.tar.gz
gentoo-478d1858d3deea472be8f143e999ed7b9955633a.tar.bz2
gentoo-478d1858d3deea472be8f143e999ed7b9955633a.zip
net-dialup/xl2tpd: -r3 for c23 patch.
Upstream: https://github.com/xelerance/xl2tpd/pull/269 Closes: https://bugs.gentoo.org/944070 Signed-off-by: Jaco Kroon <jaco@uls.co.za> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-dialup/xl2tpd')
-rw-r--r--net-dialup/xl2tpd/files/xl2tpd-1.3.18-r3-Fix-compiling-with-C23.patch37
-rw-r--r--net-dialup/xl2tpd/xl2tpd-1.3.18-r3.ebuild70
2 files changed, 107 insertions, 0 deletions
diff --git a/net-dialup/xl2tpd/files/xl2tpd-1.3.18-r3-Fix-compiling-with-C23.patch b/net-dialup/xl2tpd/files/xl2tpd-1.3.18-r3-Fix-compiling-with-C23.patch
new file mode 100644
index 000000000000..0bd9199554ff
--- /dev/null
+++ b/net-dialup/xl2tpd/files/xl2tpd-1.3.18-r3-Fix-compiling-with-C23.patch
@@ -0,0 +1,37 @@
+From 07f0a12f1f3c10f5be31e4474bcb5422d0d5e9b3 Mon Sep 17 00:00:00 2001
+From: Jaco Kroon <jaco@uls.co.za>
+Date: Thu, 21 Nov 2024 00:12:29 +0200
+Subject: [PATCH] Fix compiling with C23.
+
+https://bugs.gentoo.org/944070
+Signed-off-by: Jaco Kroon <jaco@uls.co.za>
+---
+ xl2tpd.c | 5 +++--
+ 1 file changed, 3 insertions(+), 2 deletions(-)
+
+diff --git a/xl2tpd.c b/xl2tpd.c
+index 791d5a4..4bf15fd 100644
+--- a/xl2tpd.c
++++ b/xl2tpd.c
+@@ -74,7 +74,7 @@ static int control_handle_lac_hangup(FILE* resf, char* bufp);
+ static int control_handle_lac_disconnect(FILE* resf, char* bufp);
+ static int control_handle_lac_add_modify(FILE* resf, char* bufp);
+ static int control_handle_lac_remove(FILE* resf, char* bufp);
+-static int control_handle_lac_status();
++static int control_handle_lac_status(FILE* resf, char* bufp);
+ static int control_handle_lns_remove(FILE* resf, char* bufp);
+
+ static struct control_requests_handler control_handlers[] = {
+@@ -1549,7 +1549,8 @@ static int control_handle_lac_remove(FILE* resf, char* bufp){
+ return 1;
+ }
+
+-static int control_handle_lac_status(){
++static int control_handle_lac_status(FILE*, char*)
++{
+ show_status ();
+ return 1;
+ }
+--
+2.44.2
+
diff --git a/net-dialup/xl2tpd/xl2tpd-1.3.18-r3.ebuild b/net-dialup/xl2tpd/xl2tpd-1.3.18-r3.ebuild
new file mode 100644
index 000000000000..099f33dfe940
--- /dev/null
+++ b/net-dialup/xl2tpd/xl2tpd-1.3.18-r3.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit systemd toolchain-funcs tmpfiles
+
+DESCRIPTION="A modern version of the Layer 2 Tunneling Protocol (L2TP) daemon"
+HOMEPAGE="https://github.com/xelerance/xl2tpd"
+SRC_URI="https://github.com/xelerance/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~mips ~ppc ~ppc64 ~riscv ~x86"
+IUSE="+kernel"
+
+DEPEND="
+ net-libs/libpcap
+ >=sys-kernel/linux-headers-2.6"
+
+RDEPEND="
+ ${DEPEND}
+ net-dialup/ppp"
+
+DOCS=( CREDITS README.md BUGS CHANGES TODO doc/README.patents )
+
+PATCHES=(
+ "${FILESDIR}/xl2tpd-1.3.18-r1-close-calls-when-pppd-terminates.patch"
+ "${FILESDIR}/xl2tpd-1.3.18-r2-Pass-remotenumber-to-pppd.patch"
+ "${FILESDIR}/xl2tpd-1.3.18-r3-Fix-compiling-with-C23.patch"
+)
+
+src_prepare() {
+ default
+ sed -e 's:/var/run/:/run/:' -i \
+ file.h \
+ l2tp.h \
+ xl2tpd-control.c \
+ doc/l2tp-secrets.5 \
+ doc/xl2tpd.8 \
+ doc/xl2tpd.conf.5 \
+ || die "Error updating /var/run to /run"
+}
+
+src_compile() {
+ tc-export CC
+ local OSFLAGS="-DLINUX"
+ use kernel && OSFLAGS+=" -DUSE_KERNEL"
+ emake OSFLAGS="${OSFLAGS}"
+}
+
+src_install() {
+ emake PREFIX=/usr DESTDIR="${D}" install
+
+ newinitd "${FILESDIR}"/xl2tpd-init-r1 xl2tpd
+
+ systemd_dounit "${FILESDIR}"/xl2tpd.service
+ dotmpfiles "${FILESDIR}"/xl2tpd.conf
+
+ einstalldocs
+
+ insinto /etc/xl2tpd
+ newins doc/l2tpd.conf.sample xl2tpd.conf
+ insopts -m 0600
+ newins doc/l2tp-secrets.sample l2tp-secrets
+}
+
+pkg_postinst() {
+ tmpfiles_process xl2tpd.conf
+}