summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-05-01 08:59:34 +0100
committerSam James <sam@gentoo.org>2023-05-01 09:00:42 +0100
commitba8d3ccfbcb2693d480c960c864545f358ac6be7 (patch)
tree3f4563ed3e549c70af912117f0dcf9f2ccd8d71f /net-analyzer
parentnet-analyzer/wireshark: drop 3.6.11-r1, 4.0.3-r1 (diff)
downloadgentoo-ba8d3ccfbcb2693d480c960c864545f358ac6be7.tar.gz
gentoo-ba8d3ccfbcb2693d480c960c864545f358ac6be7.tar.bz2
gentoo-ba8d3ccfbcb2693d480c960c864545f358ac6be7.zip
net-analyzer/wireshark: enable py3.11, restrict tests temporarily
We need to restrict tests for now because Wireshark w/ py3.11 uses pytest internals that got removed. Unfortunately, when running tests w/ unittest, some tests end up failing (and it's not easy to skip them), and it's much slower. Closes: https://bugs.gentoo.org/897078 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/wireshark/wireshark-3.6.12-r1.ebuild6
-rw-r--r--net-analyzer/wireshark/wireshark-3.6.13.ebuild6
-rw-r--r--net-analyzer/wireshark/wireshark-4.0.4-r1.ebuild6
-rw-r--r--net-analyzer/wireshark/wireshark-4.0.5.ebuild6
-rw-r--r--net-analyzer/wireshark/wireshark-9999.ebuild6
5 files changed, 20 insertions, 10 deletions
diff --git a/net-analyzer/wireshark/wireshark-3.6.12-r1.ebuild b/net-analyzer/wireshark/wireshark-3.6.12-r1.ebuild
index e037030ee391..0079012cf99c 100644
--- a/net-analyzer/wireshark/wireshark-3.6.12-r1.ebuild
+++ b/net-analyzer/wireshark/wireshark-3.6.12-r1.ebuild
@@ -4,7 +4,7 @@
EAPI=8
LUA_COMPAT=( lua5-{1..2} )
-PYTHON_COMPAT=( python3_{9..10} )
+PYTHON_COMPAT=( python3_{9..11} )
inherit fcaps flag-o-matic lua-single python-any-r1 qmake-utils xdg cmake
@@ -32,7 +32,9 @@ IUSE+=" sdjournal test +text2pcap tfshark +tshark +udpdump zlib +zstd"
REQUIRED_USE="lua? ( ${LUA_REQUIRED_USE} )
plugin-ifdemo? ( plugins qt5 )"
-RESTRICT="!test? ( test )"
+# Tests restricted for now because rely on pytest internals w/ >=3.11
+# See bug #897078 and https://gitlab.com/wireshark/wireshark/-/issues/18740.
+RESTRICT="!test? ( test ) test"
# bug #753062 for speexdsp
RDEPEND="acct-group/pcap
diff --git a/net-analyzer/wireshark/wireshark-3.6.13.ebuild b/net-analyzer/wireshark/wireshark-3.6.13.ebuild
index 0e8916b20943..1e4730af8694 100644
--- a/net-analyzer/wireshark/wireshark-3.6.13.ebuild
+++ b/net-analyzer/wireshark/wireshark-3.6.13.ebuild
@@ -4,7 +4,7 @@
EAPI=8
LUA_COMPAT=( lua5-{1..2} )
-PYTHON_COMPAT=( python3_{9..10} )
+PYTHON_COMPAT=( python3_{9..11} )
inherit fcaps flag-o-matic lua-single python-any-r1 qmake-utils xdg cmake
@@ -32,7 +32,9 @@ IUSE+=" sdjournal test +text2pcap tfshark +tshark +udpdump zlib +zstd"
REQUIRED_USE="lua? ( ${LUA_REQUIRED_USE} )
plugin-ifdemo? ( plugins qt5 )"
-RESTRICT="!test? ( test )"
+# Tests restricted for now because rely on pytest internals w/ >=3.11
+# See bug #897078 and https://gitlab.com/wireshark/wireshark/-/issues/18740.
+RESTRICT="!test? ( test ) test"
# bug #753062 for speexdsp
RDEPEND="acct-group/pcap
diff --git a/net-analyzer/wireshark/wireshark-4.0.4-r1.ebuild b/net-analyzer/wireshark/wireshark-4.0.4-r1.ebuild
index b80599dfacbf..6039d7e9573b 100644
--- a/net-analyzer/wireshark/wireshark-4.0.4-r1.ebuild
+++ b/net-analyzer/wireshark/wireshark-4.0.4-r1.ebuild
@@ -4,7 +4,7 @@
EAPI=8
LUA_COMPAT=( lua5-{1..2} )
-PYTHON_COMPAT=( python3_{9..10} )
+PYTHON_COMPAT=( python3_{9..11} )
inherit fcaps flag-o-matic readme.gentoo-r1 lua-single python-any-r1 qmake-utils xdg cmake
@@ -35,7 +35,9 @@ REQUIRED_USE="
lua? ( ${LUA_REQUIRED_USE} )
"
-RESTRICT="!test? ( test )"
+# Tests restricted for now because rely on pytest internals w/ >=3.11
+# See bug #897078 and https://gitlab.com/wireshark/wireshark/-/issues/18740.
+RESTRICT="!test? ( test ) test"
# bug #753062 for speexdsp
RDEPEND="
diff --git a/net-analyzer/wireshark/wireshark-4.0.5.ebuild b/net-analyzer/wireshark/wireshark-4.0.5.ebuild
index f22f7cd62c6b..36658422a00e 100644
--- a/net-analyzer/wireshark/wireshark-4.0.5.ebuild
+++ b/net-analyzer/wireshark/wireshark-4.0.5.ebuild
@@ -4,7 +4,7 @@
EAPI=8
LUA_COMPAT=( lua5-{1..2} )
-PYTHON_COMPAT=( python3_{9..10} )
+PYTHON_COMPAT=( python3_{9..11} )
inherit fcaps flag-o-matic readme.gentoo-r1 lua-single python-any-r1 qmake-utils xdg cmake
@@ -35,7 +35,9 @@ REQUIRED_USE="
lua? ( ${LUA_REQUIRED_USE} )
"
-RESTRICT="!test? ( test )"
+# Tests restricted for now because rely on pytest internals w/ >=3.11
+# See bug #897078 and https://gitlab.com/wireshark/wireshark/-/issues/18740.
+RESTRICT="!test? ( test ) test"
# bug #753062 for speexdsp
RDEPEND="
diff --git a/net-analyzer/wireshark/wireshark-9999.ebuild b/net-analyzer/wireshark/wireshark-9999.ebuild
index 62593372fe05..2c6116786ce7 100644
--- a/net-analyzer/wireshark/wireshark-9999.ebuild
+++ b/net-analyzer/wireshark/wireshark-9999.ebuild
@@ -4,7 +4,7 @@
EAPI=8
LUA_COMPAT=( lua5-{1..2} )
-PYTHON_COMPAT=( python3_{9..10} )
+PYTHON_COMPAT=( python3_{9..11} )
inherit fcaps flag-o-matic lua-single python-any-r1 qmake-utils xdg cmake
@@ -35,7 +35,9 @@ REQUIRED_USE="
lua? ( ${LUA_REQUIRED_USE} )
"
-RESTRICT="!test? ( test )"
+# Tests restricted for now because rely on pytest internals w/ >=3.11
+# See bug #897078 and https://gitlab.com/wireshark/wireshark/-/issues/18740.
+RESTRICT="!test? ( test ) test"
# bug #753062 for speexdsp
RDEPEND="