summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-12-11 12:18:15 +0100
committerMichał Górny <mgorny@gentoo.org>2024-12-11 12:53:14 +0100
commita114d7cd8ea451b83f111a86fc4a648985bdb01d (patch)
tree28603817791ee6e8b7129ff794f0822fa17ef72e /net-analyzer
parentMove {sys-libs → llvm-runtimes}/libcxx (diff)
downloadgentoo-a114d7cd8ea451b83f111a86fc4a648985bdb01d.tar.gz
gentoo-a114d7cd8ea451b83f111a86fc4a648985bdb01d.tar.bz2
gentoo-a114d7cd8ea451b83f111a86fc4a648985bdb01d.zip
Move {sys-libs → llvm-runtimes}/compiler-rt-sanitizers
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/gvm-libs/gvm-libs-22.11.0.ebuild6
-rw-r--r--net-analyzer/gvm-libs/gvm-libs-22.15.0.ebuild6
2 files changed, 6 insertions, 6 deletions
diff --git a/net-analyzer/gvm-libs/gvm-libs-22.11.0.ebuild b/net-analyzer/gvm-libs/gvm-libs-22.11.0.ebuild
index 4a1a8696879f..6f08ac076fc1 100644
--- a/net-analyzer/gvm-libs/gvm-libs-22.11.0.ebuild
+++ b/net-analyzer/gvm-libs/gvm-libs-22.11.0.ebuild
@@ -54,9 +54,9 @@ BDEPEND="
pkg_setup() {
if tc-is-clang; then
local clang_major_version=$(clang-major-version);
- if ! has_version "sys-libs/compiler-rt-sanitizers:${clang_major_version}[profile]"; then
- eerror "Compiling this package with clang requires sys-libs/compiler-rt-sanitizers to be built with 'profile' USE flag enabled"
- die "Clang detected, but sys-libs/compiler-rt-sanitizers not build with 'profile' USE flag enabled"
+ if ! has_version "llvm-runtimes/compiler-rt-sanitizers:${clang_major_version}[profile]"; then
+ eerror "Compiling this package with clang requires llvm-runtimes/compiler-rt-sanitizers to be built with 'profile' USE flag enabled"
+ die "Clang detected, but llvm-runtimes/compiler-rt-sanitizers not build with 'profile' USE flag enabled"
fi
fi
}
diff --git a/net-analyzer/gvm-libs/gvm-libs-22.15.0.ebuild b/net-analyzer/gvm-libs/gvm-libs-22.15.0.ebuild
index 6eb7dab05f46..32fb4dbd8411 100644
--- a/net-analyzer/gvm-libs/gvm-libs-22.15.0.ebuild
+++ b/net-analyzer/gvm-libs/gvm-libs-22.15.0.ebuild
@@ -55,9 +55,9 @@ BDEPEND="
pkg_setup() {
if tc-is-clang; then
local clang_major_version=$(clang-major-version);
- if ! has_version "sys-libs/compiler-rt-sanitizers:${clang_major_version}[profile]"; then
- eerror "Compiling this package with clang requires sys-libs/compiler-rt-sanitizers to be built with 'profile' USE flag enabled"
- die "Clang detected, but sys-libs/compiler-rt-sanitizers not build with 'profile' USE flag enabled"
+ if ! has_version "llvm-runtimes/compiler-rt-sanitizers:${clang_major_version}[profile]"; then
+ eerror "Compiling this package with clang requires llvm-runtimes/compiler-rt-sanitizers to be built with 'profile' USE flag enabled"
+ die "Clang detected, but llvm-runtimes/compiler-rt-sanitizers not build with 'profile' USE flag enabled"
fi
fi
}