summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-analyzer/iptstate
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-analyzer/iptstate')
-rw-r--r--net-analyzer/iptstate/Manifest1
-rw-r--r--net-analyzer/iptstate/files/iptstate-2.2.5-gentoo.patch26
-rw-r--r--net-analyzer/iptstate/iptstate-2.2.5.ebuild33
-rw-r--r--net-analyzer/iptstate/metadata.xml9
4 files changed, 69 insertions, 0 deletions
diff --git a/net-analyzer/iptstate/Manifest b/net-analyzer/iptstate/Manifest
new file mode 100644
index 000000000000..03d719f15656
--- /dev/null
+++ b/net-analyzer/iptstate/Manifest
@@ -0,0 +1 @@
+DIST iptstate-2.2.5.tar.bz2 28270 SHA256 4e4d881b701fc4599a252021d6ef579eb17aea711fbc07f95df61465b38e1055 SHA512 044bbcf96225cc52b82428792d685d19f964520f7f20a9d3fa7e53430c1f552c0f09338a5d347b08e2500206cd7634a6b4a3acffbfd9e59e4657afb6df461795 WHIRLPOOL 193623aeb5a082fa51613c22e01b22d7d8db83099061961ace7e753bd06e16cdc4b001f73d1b5d20e8eafeb3a1412744a95c10d3fab672c2644408ec125369d9
diff --git a/net-analyzer/iptstate/files/iptstate-2.2.5-gentoo.patch b/net-analyzer/iptstate/files/iptstate-2.2.5-gentoo.patch
new file mode 100644
index 000000000000..fdaeeb7867b2
--- /dev/null
+++ b/net-analyzer/iptstate/files/iptstate-2.2.5-gentoo.patch
@@ -0,0 +1,26 @@
+--- a/Makefile
++++ b/Makefile
+@@ -17,12 +17,11 @@
+ ### ADVANCED USERS AND PACKAGERS MIGHT WANT TO CHANGE THIS
+
+ CXX?= g++
+-CXXFLAGS?= -g -Wall -O2
++CXXFLAGS+= -Wall
+ CXXFILES?= iptstate.cc
+
+ # THIS IS FOR NORMAL COMPILATION
+-LIBS?= -lncurses -lnetfilter_conntrack
+-CPPFLAGS=
++LIBS= $(shell $(PKG_CONFIG) --libs ncurses libnetfilter_conntrack)
+
+ ### YOU SHOULDN'T NEED TO CHANGE ANYTHING BELOW THIS
+
+@@ -45,7 +44,7 @@
+ echo "+------------------------------------------------------------+" ;\
+ echo "";
+
+- $(CXX) $(CXXFLAGS) $(CXXFILES) -o iptstate $(LIBS) $(CPPFLAGS)
++ $(CXX) $(LDFLAGS) $(CXXFLAGS) $(CPPFLAGS) $(CXXFILES) -o iptstate $(LIBS)
+ @touch iptstate
+
+ @\
diff --git a/net-analyzer/iptstate/iptstate-2.2.5.ebuild b/net-analyzer/iptstate/iptstate-2.2.5.ebuild
new file mode 100644
index 000000000000..66712b916b86
--- /dev/null
+++ b/net-analyzer/iptstate/iptstate-2.2.5.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils toolchain-funcs
+
+DESCRIPTION="IP Tables State displays states being kept by iptables in a top-like format"
+HOMEPAGE="http://www.phildev.net/iptstate/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="amd64 ~hppa ~ppc x86"
+
+RDEPEND="
+ >=sys-libs/ncurses-5.7-r7
+ >=net-libs/libnetfilter_conntrack-0.0.50
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+ tc-export CXX PKG_CONFIG
+}
+
+src_install() {
+ emake PREFIX="${D}"/usr install
+ dodoc BUGS Changelog CONTRIB README WISHLIST
+}
diff --git a/net-analyzer/iptstate/metadata.xml b/net-analyzer/iptstate/metadata.xml
new file mode 100644
index 000000000000..facd2fdc2084
--- /dev/null
+++ b/net-analyzer/iptstate/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>netmon</herd>
+ <longdescription>IP Tables State displays states being kept by iptables in a top-like format</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">iptstate</remote-id>
+ </upstream>
+</pkgmetadata>