summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-video/flumotion
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-video/flumotion')
-rw-r--r--media-video/flumotion/Manifest2
-rwxr-xr-xmedia-video/flumotion/files/flumotion-init-0.2.017
-rw-r--r--media-video/flumotion/files/flumotion-init-323
-rw-r--r--media-video/flumotion/flumotion-0.10.1.ebuild124
-rw-r--r--media-video/flumotion/flumotion-0.8.1-r1.ebuild124
-rw-r--r--media-video/flumotion/flumotion-0.8.1.ebuild112
-rw-r--r--media-video/flumotion/metadata.xml5
7 files changed, 407 insertions, 0 deletions
diff --git a/media-video/flumotion/Manifest b/media-video/flumotion/Manifest
new file mode 100644
index 000000000000..4820bf4c74e8
--- /dev/null
+++ b/media-video/flumotion/Manifest
@@ -0,0 +1,2 @@
+DIST flumotion-0.10.1.tar.bz2 1640721 SHA256 8c6913a3b2ed7adb6294c644762bebdac4d75b1b752a4ffd3589dcfa5b778d21 SHA512 ef157a73c97de934deaad22e1be8b3f109e47a0898a674f542d17b84edcca50f6ca6c4790419a9514e291ec8e4651ba840491e21439c5342d03a4a46c5805bfb WHIRLPOOL 9796f22e862c69220dabbfd9b9c899d6b5d5e4d6bb20203016f3ab7ac6c8ecd36cdbfea03438384be101407eeddfcfd6fc47337edcd15dd1a4f67dcb222d8e71
+DIST flumotion-0.8.1.tar.bz2 1516513 SHA256 ae53684e504ef8793a08e70d17892a090c53ebf9bd470f8081b9c9949d53db4d SHA512 87fa4b517d9ab59d0fc624e1047aad26d4319cedd36c6cfaab751fc3c984281b18c640caa8a363b39b3df1c2a6d5a4adbe627525dac155ef263b635884300994 WHIRLPOOL 9ceca56fd9d63b0bcceff9354f5f90d7d724d6fc37e218031d4124ee19bad07ed18aca39407d3b75a1cd1f2c54d0892bafc13fb04d8f6208119e463f52239b8b
diff --git a/media-video/flumotion/files/flumotion-init-0.2.0 b/media-video/flumotion/files/flumotion-init-0.2.0
new file mode 100755
index 000000000000..de571785ff38
--- /dev/null
+++ b/media-video/flumotion/files/flumotion-init-0.2.0
@@ -0,0 +1,17 @@
+#!/sbin/runscript
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting Flumotion"
+ HOME=/usr/share/flumotion start-stop-daemon -o --start --chuid flumotion:flumotion --exec /usr/sbin/flumotion start
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping Flumotion"
+ /usr/sbin/flumotion stop
+ eend $?
+}
diff --git a/media-video/flumotion/files/flumotion-init-3 b/media-video/flumotion/files/flumotion-init-3
new file mode 100644
index 000000000000..898eae048766
--- /dev/null
+++ b/media-video/flumotion/files/flumotion-init-3
@@ -0,0 +1,23 @@
+#!/sbin/runscript
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting Flumotion"
+ if [ ! -d /var/run/flumotion ] ; then
+ mkdir /var/run/flumotion
+ chown flumotion:flumotion /var/run/flumotion
+ chmod 755 /var/run/flumotion
+ fi
+
+ start-stop-daemon -o --start --chuid flumotion:flumotion --exec /usr/sbin/flumotion start
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping Flumotion"
+ /usr/sbin/flumotion stop
+ eend $?
+}
diff --git a/media-video/flumotion/flumotion-0.10.1.ebuild b/media-video/flumotion/flumotion-0.10.1.ebuild
new file mode 100644
index 000000000000..52222970c1f4
--- /dev/null
+++ b/media-video/flumotion/flumotion-0.10.1.ebuild
@@ -0,0 +1,124 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils fdo-mime flag-o-matic multilib python-single-r1 toolchain-funcs user virtualx # AC_CHECK_PROG for Xvfb
+
+DESCRIPTION="Flumotion Streaming server"
+HOMEPAGE="http://www.flumotion.net/"
+SRC_URI="http://www.flumotion.net/src/${PN}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1" # LICENSE.LGPL
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="doc test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+# TODO:
+
+# These would be from 0.6.2's ebuild
+# media-plugins/gst-plugins-libpng:0.10
+# dev-python/twisted-web
+# dev-python/twisted-names
+# dev-python/imaging
+
+# These are from README
+RDEPEND="
+ dev-python/gst-python:0.10[${PYTHON_USEDEP}]
+ dev-python/kiwi[${PYTHON_USEDEP}]
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ dev-python/pygtk:2[${PYTHON_USEDEP}]
+ dev-python/twisted-core[${PYTHON_USEDEP}]
+ media-libs/gstreamer:0.10
+ media-libs/gst-plugins-base:0.10
+ media-libs/gst-plugins-good:0.10
+ media-plugins/gst-plugins-ogg:0.10
+ media-plugins/gst-plugins-theora:0.10
+ media-plugins/gst-plugins-vorbis:0.10
+"
+# These are from README and error and trial FEATURES="test" Import's
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+ doc? ( dev-python/epydoc[${PYTHON_USEDEP}] )
+ test? ( dev-python/icalendar[${PYTHON_USEDEP}]
+ dev-python/pychecker[${PYTHON_USEDEP}]
+ dev-python/twisted-conch[${PYTHON_USEDEP}] )"
+
+src_prepare() {
+ # Fix .desktop file
+ sed -e 's/.png//' -i data/flumotion-admin.desktop.in || die
+
+ # Fix shebangs
+ sed -e '1 s:.*:#!/usr/bin/env python:' \
+ -i bin/flu*.in bin/runtest.in misc/flu*.in || die
+ python_fix_shebang bin/flu*.in bin/runtest.in misc/flu*.in
+}
+
+src_configure() {
+ append-cflags -fno-strict-aliasing
+
+ econf \
+ --localstatedir=/var \
+ $(use_enable doc docs)
+}
+
+src_compile() {
+ emake -j1 fdpass_so_LINK="$(tc-getCC) ${LDFLAGS} -shared -o fdpass.so"
+}
+
+src_test() {
+ # FIXME: restrict unittests to flumotion source folder
+ # other tests are failing in weird ways and does not seem to test much of flumotion
+ Xemake -j1 check -C flumotion
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" install
+ einstalldocs
+ dodoc RELEASE
+
+ keepdir /var/log/flumotion
+
+ newinitd "${FILESDIR}"/flumotion-init-3 flumotion
+
+ # /usr/share/hal/fdi/policy/20thirdparty/91-flumotion-device-policy.fdi
+ rm -rf "${D}"/usr/share/hal || die
+
+ dodir /etc/flumotion
+ dodir /etc/flumotion/managers
+ dodir /etc/flumotion/managers/default
+ dodir /etc/flumotion/managers/default/flows
+ dodir /etc/flumotion/workers
+
+ pushd conf
+ insinto /etc/flumotion/managers/default
+ doins managers/default/planet.xml
+ insinto /etc/flumotion/workers
+ doins workers/default.xml
+ insinto /etc/flumotion
+ doins default.pem
+ popd
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+
+ if ! enewgroup flumotion || ! enewuser flumotion -1 -1 /usr/share/flumotion flumotion,audio,video,sys; then
+ die "Unable to add flumotion user and flumotion group."
+ fi
+
+ for dir in /usr/share/flumotion /var/log/flumotion ; do
+ chown -R flumotion:flumotion "${dir}"
+ chmod -R 755 "${dir}"
+ done
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+}
diff --git a/media-video/flumotion/flumotion-0.8.1-r1.ebuild b/media-video/flumotion/flumotion-0.8.1-r1.ebuild
new file mode 100644
index 000000000000..ff28bf39ef8a
--- /dev/null
+++ b/media-video/flumotion/flumotion-0.8.1-r1.ebuild
@@ -0,0 +1,124 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils fdo-mime flag-o-matic multilib python-single-r1 toolchain-funcs user virtualx # AC_CHECK_PROG for Xvfb
+
+DESCRIPTION="Flumotion Streaming server"
+HOMEPAGE="http://www.flumotion.net/"
+SRC_URI="http://www.flumotion.net/src/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2" # LICENSE.Flumotion
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+# TODO:
+
+# These would be from 0.6.2's ebuild
+# media-plugins/gst-plugins-libpng:0.10
+# dev-python/twisted-web
+# dev-python/twisted-names
+# dev-python/imaging
+
+# These are from README
+RDEPEND="
+ dev-python/gst-python:0.10[${PYTHON_USEDEP}]
+ dev-python/kiwi[${PYTHON_USEDEP}]
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ dev-python/pygtk:2[${PYTHON_USEDEP}]
+ dev-python/twisted-core[${PYTHON_USEDEP}]
+ media-libs/gstreamer:0.10
+ media-libs/gst-plugins-base:0.10
+ media-libs/gst-plugins-good:0.10
+ media-plugins/gst-plugins-ogg:0.10
+ media-plugins/gst-plugins-theora:0.10
+ media-plugins/gst-plugins-vorbis:0.10
+"
+# These are from README and error and trial FEATURES="test" Import's
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+ doc? ( dev-python/epydoc[${PYTHON_USEDEP}] )
+ test? ( dev-python/icalendar[${PYTHON_USEDEP}]
+ dev-python/pychecker[${PYTHON_USEDEP}]
+ dev-python/twisted-conch[${PYTHON_USEDEP}] )"
+
+src_prepare() {
+ # Fix .desktop file
+ sed -e 's/.png//' -i data/flumotion-admin.desktop.in || die
+
+ # Fix shebangs
+ sed -e '1 s:.*:#!/usr/bin/env python:' \
+ -i bin/flu*.in bin/runtest.in misc/flu*.in || die
+ python_fix_shebang bin/flu*.in bin/runtest.in misc/flu*.in
+}
+
+src_configure() {
+ append-cflags -fno-strict-aliasing
+
+ econf \
+ --localstatedir=/var \
+ $(use_enable doc docs)
+}
+
+src_compile() {
+ emake -j1 fdpass_so_LINK="$(tc-getCC) ${LDFLAGS} -shared -o fdpass.so"
+}
+
+src_test() {
+ # FIXME: restrict unittests to flumotion source folder
+ # other tests are failing in weird ways and does not seem to test much of flumotion
+ Xemake -j1 check -C flumotion
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" install
+ einstalldocs
+ dodoc RELEASE
+
+ keepdir /var/log/flumotion
+
+ newinitd "${FILESDIR}"/flumotion-init-3 flumotion
+
+ # /usr/share/hal/fdi/policy/20thirdparty/91-flumotion-device-policy.fdi
+ rm -rf "${D}"/usr/share/hal || die
+
+ dodir /etc/flumotion
+ dodir /etc/flumotion/managers
+ dodir /etc/flumotion/managers/default
+ dodir /etc/flumotion/managers/default/flows
+ dodir /etc/flumotion/workers
+
+ pushd conf
+ insinto /etc/flumotion/managers/default
+ doins managers/default/planet.xml
+ insinto /etc/flumotion/workers
+ doins workers/default.xml
+ insinto /etc/flumotion
+ doins default.pem
+ popd
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+
+ if ! enewgroup flumotion || ! enewuser flumotion -1 -1 /usr/share/flumotion flumotion,audio,video,sys; then
+ die "Unable to add flumotion user and flumotion group."
+ fi
+
+ for dir in /usr/share/flumotion /var/log/flumotion ; do
+ chown -R flumotion:flumotion "${dir}"
+ chmod -R 755 "${dir}"
+ done
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+}
diff --git a/media-video/flumotion/flumotion-0.8.1.ebuild b/media-video/flumotion/flumotion-0.8.1.ebuild
new file mode 100644
index 000000000000..6724950daf32
--- /dev/null
+++ b/media-video/flumotion/flumotion-0.8.1.ebuild
@@ -0,0 +1,112 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=3
+
+PYTHON_DEPEND="2:2.6"
+
+inherit eutils user flag-o-matic multilib python toolchain-funcs virtualx # AC_CHECK_PROG for Xvfb
+
+DESCRIPTION="Flumotion Streaming server"
+HOMEPAGE="http://www.flumotion.net/"
+SRC_URI="http://www.flumotion.net/src/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2" # LICENSE.Flumotion
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+# TODO:
+
+# These would be from 0.6.2's ebuild
+# media-plugins/gst-plugins-libpng:0.10
+# dev-python/twisted-web
+# dev-python/twisted-names
+# dev-python/imaging
+
+# These are from README
+RDEPEND="dev-python/gst-python:0.10
+ dev-python/kiwi
+ dev-python/pycairo
+ =dev-python/pygtk-2*
+ dev-python/twisted-core
+ media-libs/gstreamer:0.10
+ media-libs/gst-plugins-base:0.10
+ media-libs/gst-plugins-good:0.10
+ media-plugins/gst-plugins-ogg:0.10
+ media-plugins/gst-plugins-theora:0.10
+ media-plugins/gst-plugins-vorbis:0.10"
+# These are from README and error and trial FEATURES="test" Import's
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ doc? ( dev-python/epydoc )
+ test? ( dev-python/icalendar
+ dev-python/pychecker
+ dev-python/twisted-conch )"
+
+src_prepare() {
+ rm -f py-compile
+ ln -s $(type -P true) py-compile
+}
+
+src_configure() {
+ append-cflags -fno-strict-aliasing
+
+ econf \
+ --localstatedir=/var \
+ $(use_enable doc docs)
+}
+
+src_compile() {
+ emake -j1 fdpass_so_LINK="$(tc-getCC) ${LDFLAGS} -shared -o fdpass.so" || die
+}
+
+src_test() {
+ Xemake -j1 check || die
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog NEWS README RELEASE TODO
+
+ keepdir /var/log/flumotion
+ keepdir /var/run/flumotion
+
+ newinitd "${FILESDIR}"/flumotion-init-0.2.0 flumotion
+
+ # /usr/share/hal/fdi/policy/20thirdparty/91-flumotion-device-policy.fdi
+ rm -rf "${D}"/usr/share/hal
+
+ dodir /etc/flumotion
+ dodir /etc/flumotion/managers
+ dodir /etc/flumotion/managers/default
+ dodir /etc/flumotion/managers/default/flows
+ dodir /etc/flumotion/workers
+
+ pushd conf
+ insinto /etc/flumotion/managers/default
+ doins managers/default/planet.xml || die
+ insinto /etc/flumotion/workers
+ doins workers/default.xml || die
+ insinto /etc/flumotion
+ doins default.pem || die
+ popd
+}
+
+pkg_postinst() {
+ if ! enewgroup flumotion || ! enewuser flumotion -1 -1 /usr/share/flumotion flumotion,audio,video,sys; then
+ die "Unable to add flumotion user and flumotion group."
+ fi
+
+ for dir in /usr/share/flumotion /var/log/flumotion /var/run/flumotion; do
+ chown -R flumotion:flumotion "${dir}"
+ chmod -R 755 "${dir}"
+ done
+
+ python_mod_optimize /usr/$(get_libdir)/flumotion/python
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/$(get_libdir)/flumotion/python
+}
diff --git a/media-video/flumotion/metadata.xml b/media-video/flumotion/metadata.xml
new file mode 100644
index 000000000000..dec0396a21e7
--- /dev/null
+++ b/media-video/flumotion/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>gstreamer</herd>
+</pkgmetadata>