summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2019-03-13 14:24:55 +0100
committerAlexis Ballier <aballier@gentoo.org>2019-03-13 16:03:23 +0100
commit3ca628cd162471fffef3545173f08431e33624c8 (patch)
tree6ec9bea7ffdc09d994551d98afe6b2790f7791d7 /media-video/ffmpeg
parentnet-analyzer/gvm-tools: new package. (diff)
downloadgentoo-3ca628cd162471fffef3545173f08431e33624c8.tar.gz
gentoo-3ca628cd162471fffef3545173f08431e33624c8.tar.bz2
gentoo-3ca628cd162471fffef3545173f08431e33624c8.zip
media-video/ffmpeg: add libxml2 useflag
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'media-video/ffmpeg')
-rw-r--r--media-video/ffmpeg/ffmpeg-4.1.1.ebuild3
-rw-r--r--media-video/ffmpeg/ffmpeg-9999.ebuild3
-rw-r--r--media-video/ffmpeg/metadata.xml1
3 files changed, 5 insertions, 2 deletions
diff --git a/media-video/ffmpeg/ffmpeg-4.1.1.ebuild b/media-video/ffmpeg/ffmpeg-4.1.1.ebuild
index e83dfb437272..12b71fa688bb 100644
--- a/media-video/ffmpeg/ffmpeg-4.1.1.ebuild
+++ b/media-video/ffmpeg/ffmpeg-4.1.1.ebuild
@@ -64,7 +64,7 @@ fi
# foo is added to IUSE.
FFMPEG_FLAG_MAP=(
+bzip2:bzlib cpudetection:runtime-cpudetect debug gcrypt gnutls gmp
- +gpl +hardcoded-tables +iconv libressl:libtls lzma +network opencl
+ +gpl +hardcoded-tables +iconv libressl:libtls libxml2 lzma +network opencl
openssl +postproc samba:libsmbclient sdl:ffplay sdl:sdl2 vaapi vdpau
X:xlib xcb:libxcb xcb:libxcb-shm xcb:libxcb-xfixes +zlib
# libavdevice options
@@ -215,6 +215,7 @@ RDEPEND="
libilbc? ( >=media-libs/libilbc-2[${MULTILIB_USEDEP}] )
libsoxr? ( >=media-libs/soxr-0.1.0[${MULTILIB_USEDEP}] )
libv4l? ( >=media-libs/libv4l-0.9.5[${MULTILIB_USEDEP}] )
+ libxml2? ( dev-libs/libxml2:=[${MULTILIB_USEDEP}] )
lv2? ( media-libs/lv2[${MULTILIB_USEDEP}] media-libs/lilv[${MULTILIB_USEDEP}] )
lzma? ( >=app-arch/xz-utils-5.0.5-r1[${MULTILIB_USEDEP}] )
mmal? ( media-libs/raspberrypi-userland )
diff --git a/media-video/ffmpeg/ffmpeg-9999.ebuild b/media-video/ffmpeg/ffmpeg-9999.ebuild
index df4ddb5f0091..612d0d3fd708 100644
--- a/media-video/ffmpeg/ffmpeg-9999.ebuild
+++ b/media-video/ffmpeg/ffmpeg-9999.ebuild
@@ -64,7 +64,7 @@ fi
# foo is added to IUSE.
FFMPEG_FLAG_MAP=(
+bzip2:bzlib cpudetection:runtime-cpudetect debug gcrypt gnutls gmp
- +gpl +hardcoded-tables +iconv libressl:libtls lzma +network opencl
+ +gpl +hardcoded-tables +iconv libressl:libtls libxml2 lzma +network opencl
openssl +postproc samba:libsmbclient sdl:ffplay sdl:sdl2 vaapi vdpau
X:xlib xcb:libxcb xcb:libxcb-shm xcb:libxcb-xfixes +zlib
# libavdevice options
@@ -215,6 +215,7 @@ RDEPEND="
libilbc? ( >=media-libs/libilbc-2[${MULTILIB_USEDEP}] )
libsoxr? ( >=media-libs/soxr-0.1.0[${MULTILIB_USEDEP}] )
libv4l? ( >=media-libs/libv4l-0.9.5[${MULTILIB_USEDEP}] )
+ libxml2? ( dev-libs/libxml2:=[${MULTILIB_USEDEP}] )
lv2? ( media-libs/lv2[${MULTILIB_USEDEP}] media-libs/lilv[${MULTILIB_USEDEP}] )
lzma? ( >=app-arch/xz-utils-5.0.5-r1[${MULTILIB_USEDEP}] )
mmal? ( media-libs/raspberrypi-userland )
diff --git a/media-video/ffmpeg/metadata.xml b/media-video/ffmpeg/metadata.xml
index 5a7a9e5dcefe..b2b0c975a987 100644
--- a/media-video/ffmpeg/metadata.xml
+++ b/media-video/ffmpeg/metadata.xml
@@ -36,6 +36,7 @@
<flag name="librtmp">Enables Real Time Messaging Protocol using librtmp (<pkg>media-video/rtmpdump</pkg>) in addition to FFmpeg's native implementation.</flag>
<flag name="libsoxr">Enables audio resampling through <pkg>media-libs/soxr</pkg>.</flag>
<flag name="libv4l">Uses <pkg>media-libs/libv4l</pkg> for video4linux instead of direct calls. Adds support for more devices via the userspace library.</flag>
+ <flag name="libxml2">Uses <pkg>dev-libs/libxml2</pkg> to enable dash demuxing support.</flag>
<flag name="lv2">Enables lv2 audio filter wrapper.</flag>
<flag name="mipsdspr1">Enables MIPS DSP ASE R1 optimizations.</flag>
<flag name="mipsdspr2">Enables MIPS DSP ASE R2 optimizations.</flag>