summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2024-02-11 21:58:27 +0000
committerJames Le Cuirot <chewi@gentoo.org>2024-02-13 21:11:51 +0000
commit33123fd005f771fbdf03e5711d35061e333a893d (patch)
treec381da1eb2b477c2f795c2ea4fe2f277c0ba1b42 /media-tv
parentmedia-video/mpv: Add soc USE flag to ensure ffmpeg also has this flag (diff)
downloadgentoo-33123fd005f771fbdf03e5711d35061e333a893d.tar.gz
gentoo-33123fd005f771fbdf03e5711d35061e333a893d.tar.bz2
gentoo-33123fd005f771fbdf03e5711d35061e333a893d.zip
media-tv/kodi: Add soc USE flag to ensure ffmpeg also has this flag
The additional patches we apply to media-video/ffmpeg may not always be immediately available following an upstream release. Adding the soc USE flag to this package ensures that users don't accidentally upgrade to an ffmpeg version that lacks them. Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'media-tv')
-rw-r--r--media-tv/kodi/kodi-9999.ebuild5
-rw-r--r--media-tv/kodi/metadata.xml1
2 files changed, 4 insertions, 2 deletions
diff --git a/media-tv/kodi/kodi-9999.ebuild b/media-tv/kodi/kodi-9999.ebuild
index d078eb4e9f86..761ce474eebc 100644
--- a/media-tv/kodi/kodi-9999.ebuild
+++ b/media-tv/kodi/kodi-9999.ebuild
@@ -76,13 +76,14 @@ SLOT="0"
# use flag is called libusb so that it doesn't fool people in thinking that
# it is _required_ for USB support. Otherwise they'll disable udev and
# that's going to be worse.
-IUSE="airplay alsa bluetooth bluray caps cec +css dbus doc eventclients gbm gles lcms libusb lirc mariadb mysql nfs +optical pipewire pulseaudio samba +system-ffmpeg test udf udev upnp vaapi vdpau wayland webserver X +xslt zeroconf ${CPU_FLAGS}"
+IUSE="airplay alsa bluetooth bluray caps cec +css dbus doc eventclients gbm gles lcms libusb lirc mariadb mysql nfs +optical pipewire pulseaudio samba soc +system-ffmpeg test udf udev upnp vaapi vdpau wayland webserver X +xslt zeroconf ${CPU_FLAGS}"
REQUIRED_USE="
${PYTHON_REQUIRED_USE}
^^ ( gbm wayland X )
?? ( mariadb mysql )
bluray? ( udf )
gbm? ( udev )
+ soc? ( system-ffmpeg )
udev? ( !libusb )
vdpau? ( X !gles !gbm )
zeroconf? ( dbus )
@@ -121,7 +122,7 @@ COMMON_TARGET_DEPEND="${PYTHON_DEPS}
>=media-libs/libass-0.15.0:=
media-libs/mesa[egl(+),gbm(+)?,wayland?,X?]
>=media-libs/taglib-1.9.0
- =media-video/ffmpeg-6*:=[encode,postproc,vaapi?,vdpau?,X?]
+ =media-video/ffmpeg-6*:=[encode,soc(-)?,postproc,vaapi?,vdpau?,X?]
sci-libs/kissfft
virtual/libiconv
virtual/ttf-fonts
diff --git a/media-tv/kodi/metadata.xml b/media-tv/kodi/metadata.xml
index a663e6bef6c7..d8114cac5535 100644
--- a/media-tv/kodi/metadata.xml
+++ b/media-tv/kodi/metadata.xml
@@ -23,6 +23,7 @@
<flag name="pipewire">Enable pipewire support</flag>
<flag name="power-control">Enable control of shutdown, reboot, suspend, and hibernate</flag>
<flag name="raspberry-pi">Enable support for the Raspberry Pi</flag>
+ <flag name="soc">Use additional <pkg>media-video/ffmpeg</pkg> patches for efficient playback on some SoCs (e.g. ARM, RISC-V)</flag>
<flag name="system-ffmpeg">Use system ffmpeg instead of the bundled one</flag>
<flag name="libusb">Use <pkg>virtual/libusb</pkg> for usb device hotplug support. This flag should only be enabled if you're running a non-Linux kernel or you don't want to use udev.</flag>
<flag name="udf">Enable UDF support. Required for playing blurays.</flag>