summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2019-09-29 21:12:53 +0300
committerMikle Kolyada <zlogene@gentoo.org>2019-09-29 21:12:53 +0300
commitcf9c5635271dade94c184e7b720ced62c3d77db0 (patch)
tree16957eb03a28492adf2a9a696939673cd8691663 /media-sound
parentnet-p2p/qbittorrent: Drop old (diff)
downloadgentoo-cf9c5635271dade94c184e7b720ced62c3d77db0.tar.gz
gentoo-cf9c5635271dade94c184e7b720ced62c3d77db0.tar.bz2
gentoo-cf9c5635271dade94c184e7b720ced62c3d77db0.zip
media-sound/mpd: call xdg
Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/mpd/mpd-0.21.14.ebuild7
-rw-r--r--media-sound/mpd/mpd-0.21.15.ebuild7
2 files changed, 12 insertions, 2 deletions
diff --git a/media-sound/mpd/mpd-0.21.14.ebuild b/media-sound/mpd/mpd-0.21.14.ebuild
index c886ec4ed037..16b37d262a4f 100644
--- a/media-sound/mpd/mpd-0.21.14.ebuild
+++ b/media-sound/mpd/mpd-0.21.14.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit flag-o-matic linux-info meson systemd user
+inherit flag-o-matic linux-info meson systemd user xdg-utils
DESCRIPTION="The Music Player Daemon (mpd)"
HOMEPAGE="https://www.musicpd.org https://github.com/MusicPlayerDaemon/MPD"
@@ -291,4 +291,9 @@ src_install() {
pkg_postinst() {
# also change the homedir if the user has existed before
usermod -d "/var/lib/mpd" mpd || die "usermod failed"
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
}
diff --git a/media-sound/mpd/mpd-0.21.15.ebuild b/media-sound/mpd/mpd-0.21.15.ebuild
index 984310bc5363..1d1dabe992f5 100644
--- a/media-sound/mpd/mpd-0.21.15.ebuild
+++ b/media-sound/mpd/mpd-0.21.15.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit flag-o-matic linux-info meson systemd user
+inherit flag-o-matic linux-info meson systemd user xdg-utils
DESCRIPTION="The Music Player Daemon (mpd)"
HOMEPAGE="https://www.musicpd.org https://github.com/MusicPlayerDaemon/MPD"
@@ -291,4 +291,9 @@ src_install() {
pkg_postinst() {
# also change the homedir if the user has existed before
usermod -d "/var/lib/mpd" mpd || die "usermod failed"
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
}