summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Pielmeier <billie@gentoo.org>2024-01-27 10:12:11 +0100
committerDaniel Pielmeier <billie@gentoo.org>2024-01-27 10:12:11 +0100
commit72fb5ed38d40a504c6465767b5cf8e1657a616c1 (patch)
tree220426044c0daad3fdd98f73c7a57042283fb5bc /media-sound
parentapp-portage/pfl: drop 3.3.1 (diff)
downloadgentoo-72fb5ed38d40a504c6465767b5cf8e1657a616c1.tar.gz
gentoo-72fb5ed38d40a504c6465767b5cf8e1657a616c1.tar.bz2
gentoo-72fb5ed38d40a504c6465767b5cf8e1657a616c1.zip
media-sound/mac: add 10.45
Signed-off-by: Daniel Pielmeier <billie@gentoo.org>
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/mac/Manifest1
-rw-r--r--media-sound/mac/files/mac-10.43-output.patch39
-rw-r--r--media-sound/mac/mac-10.45.ebuild29
3 files changed, 69 insertions, 0 deletions
diff --git a/media-sound/mac/Manifest b/media-sound/mac/Manifest
index 66f7930675e1..a7183a56768f 100644
--- a/media-sound/mac/Manifest
+++ b/media-sound/mac/Manifest
@@ -1,2 +1,3 @@
DIST mac-10.29.zip 1657175 BLAKE2B a5d9375af98d5422ca7e0f19e1b5372e8f00bf91bd5fead51a211efe4b304db20a8c5429a17d84db8a37b7898490c147115a363937ab9b970d3077c6c21be506 SHA512 c49cb3d11493cd7f6632ffb4c284e9333a9682d255863d46835b1b4bee2f50798b8d70a61b2a36ba9cb13836533addfcb644c2470613a38a33ddfac4acafd84d
+DIST mac-10.45.zip 1661327 BLAKE2B cb9b7f703da500638d608ecbd0c4edd3971d474369946d5b9a6a61f104d9bae549f9868b09b07b99d02f81854ad807634a69d6198ab68cd10e4c6014711af8c3 SHA512 08eb214901343ff171e661b1c3452b533399c698088feefb571003ecdc4477b958c39c75031a6bbd0957a3abee3d09fa912b1390437bd7d7ba2160d729107e21
DIST monkeys-audio_4.11-u4-b5-s7.orig.tar.gz 511190 BLAKE2B 28b5a3aadd9dae410c93cfc43c40c07fe207036f27cf60d59d8fa137a0327f90a78746c14930b7d3becb7f5fa69a454a6855aae1553dc74cd5168a9a523bb8f0 SHA512 7e73b35c86d6007ab2a94a2d8b7449bb4ac505bbba53e40373a279dc83a9cad5f62a51419a6375335576cf325c88ed7d317b0ef3039b8a497100cb74a63c25d0
diff --git a/media-sound/mac/files/mac-10.43-output.patch b/media-sound/mac/files/mac-10.43-output.patch
new file mode 100644
index 000000000000..a0ce2600cdee
--- /dev/null
+++ b/media-sound/mac/files/mac-10.43-output.patch
@@ -0,0 +1,39 @@
+diff -Naur mac-10.43_orig/Source/Console/Console.cpp mac-10.43/Source/Console/Console.cpp
+--- mac-10.43_orig/Source/Console/Console.cpp 2024-01-13 08:57:22.320394985 +0100
++++ mac-10.43/Source/Console/Console.cpp 2024-01-13 08:58:05.133394123 +0100
+@@ -68,7 +68,7 @@
+ **************************************************************************************************/
+ static void DisplayProperUsage(FILE * pFile)
+ {
+- fwprintf(pFile, L"Proper Usage: [EXE] [Input File] [Output File] [Mode]\n\n");
++ fwprintf(pFile, L"Proper Usage: [mac] [Input File] [Output File] [Mode]\n\n");
+
+ fwprintf(pFile, L"Modes: \n");
+ fwprintf(pFile, L" Compress (fast): '-c1000'\n");
+@@ -85,16 +85,16 @@
+ fwprintf(pFile, L" Convert to ID3v1 (needed by some players, etc.): '-L'\n\n");
+
+ fwprintf(pFile, L"Examples:\n");
+- fwprintf(pFile, L" Compress: mac.exe \"Metallica - One.wav\" \"Metallica - One.ape\" -c2000\n");
+- fwprintf(pFile, L" Compress: mac.exe \"Metallica - One.wav\" \"Metallica - One.ape\" -c2000 -t \"Artist=Metallica|Album=Black|Name=One\"\n");
+- fwprintf(pFile, L" Compress: mac.exe \"Metallica - One.wav\" auto -c2000\n");
+- fwprintf(pFile, L" Transcode from pipe: ffmpeg.exe -i \"Metallica - One.flac\" -f wav - | mac.exe - \"Metallica - One.ape\" -c2000\n");
+- fwprintf(pFile, L" Decompress: mac.exe \"Metallica - One.ape\" \"Metallica - One.wav\" -d\n");
+- fwprintf(pFile, L" Decompress: mac.exe \"Metallica - One.ape\" auto -d\n");
+- fwprintf(pFile, L" Verify: mac.exe \"Metallica - One.ape\" -v\n");
+- fwprintf(pFile, L" Full Verify: mac.exe \"Metallica - One.ape\" -V\n");
+- fwprintf(pFile, L" Tag: mac.exe \"Metallica - One.ape\" -t \"Artist=Metallica|Album=Black|Name=One|Comment=\\\"This is in quotes\\\"\"\n");
+- fwprintf(pFile, L" Remove tag: mac.exe \"Metallica - One.ape\" -r\n");
++ fwprintf(pFile, L" Compress: mac \"Metallica - One.wav\" \"Metallica - One.ape\" -c2000\n");
++ fwprintf(pFile, L" Compress: mac \"Metallica - One.wav\" \"Metallica - One.ape\" -c2000 -t \"Artist=Metallica|Album=Black|Name=One\"\n");
++ fwprintf(pFile, L" Compress: mac \"Metallica - One.wav\" auto -c2000\n");
++ fwprintf(pFile, L" Transcode from pipe: ffmpeg -i \"Metallica - One.flac\" -f wav - | mac - \"Metallica - One.ape\" -c2000\n");
++ fwprintf(pFile, L" Decompress: mac \"Metallica - One.ape\" \"Metallica - One.wav\" -d\n");
++ fwprintf(pFile, L" Decompress: mac \"Metallica - One.ape\" auto -d\n");
++ fwprintf(pFile, L" Verify: mac \"Metallica - One.ape\" -v\n");
++ fwprintf(pFile, L" Full Verify: mac \"Metallica - One.ape\" -V\n");
++ fwprintf(pFile, L" Tag: mac \"Metallica - One.ape\" -t \"Artist=Metallica|Album=Black|Name=One|Comment=\\\"This is in quotes\\\"\"\n");
++ fwprintf(pFile, L" Remove tag: mac \"Metallica - One.ape\" -r\n");
+ fwprintf(pFile, L" (note: int filenames must be put inside of quotations)\n");
+ }
+
diff --git a/media-sound/mac/mac-10.45.ebuild b/media-sound/mac/mac-10.45.ebuild
new file mode 100644
index 000000000000..7309b993f84b
--- /dev/null
+++ b/media-sound/mac/mac-10.45.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Monkey's Audio Codecs"
+HOMEPAGE="https://www.monkeysaudio.com"
+SRC_URI="https://monkeysaudio.com/files/MAC_${PV/.}_SDK.zip -> ${P}.zip"
+
+LICENSE="BSD"
+SLOT="0/10"
+KEYWORDS="~alpha ~amd64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+BDEPEND="app-arch/unzip"
+
+src_unpack() {
+ mkdir -p "${S}" || die
+ cd "${S}" || die
+ default
+}
+
+CMAKE_BUILD_TYPE=Release
+
+PATCHES=(
+ "${FILESDIR}/${PN}-10.18-linux.patch"
+ "${FILESDIR}/${PN}-10.43-output.patch"
+)