summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2021-04-26 21:57:38 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2021-04-26 21:57:53 -0500
commit1122d0558bf6a2d160d96efcc6366a6e95fa8252 (patch)
tree9d54ea7f8e3c7c5dc71342bd75cc125e50e8f8cd /media-sound
parentmedia-sound/ardour: Fix build with glib-2.68 (diff)
downloadgentoo-1122d0558bf6a2d160d96efcc6366a6e95fa8252.tar.gz
gentoo-1122d0558bf6a2d160d96efcc6366a6e95fa8252.tar.bz2
gentoo-1122d0558bf6a2d160d96efcc6366a6e95fa8252.zip
media-sound/mangler: more c++11 fixes
Closes: https://bugs.gentoo.org/784401 Package-Manager: Portage-3.0.18, Repoman-3.0.2 RepoMan-Options: --force Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/mangler/files/fix_ftbfs_narrowing_conversion.patch18
-rw-r--r--media-sound/mangler/mangler-1.2.5-r2.ebuild (renamed from media-sound/mangler/mangler-1.2.5-r1.ebuild)5
2 files changed, 22 insertions, 1 deletions
diff --git a/media-sound/mangler/files/fix_ftbfs_narrowing_conversion.patch b/media-sound/mangler/files/fix_ftbfs_narrowing_conversion.patch
new file mode 100644
index 000000000000..feec08089421
--- /dev/null
+++ b/media-sound/mangler/files/fix_ftbfs_narrowing_conversion.patch
@@ -0,0 +1,18 @@
+Description: Declare byte array as unsigned char rather than char to avoid narrowing
+ A step up in pedantics in C++11 has identified a byte array that was not
+ declared as unsigned.
+Author: William Panlener <wpanlener@gmail.com>
+Bug-Debian: https://bugs.debian.org/805160
+Forwarded: no
+
+--- a/src/manglerg15.h
++++ b/src/manglerg15.h
+@@ -52,7 +52,7 @@
+ std::vector<Glib::ustring> events;
+ };
+
+-const char g15_blank[] = {
++const unsigned char g15_blank[] = {
+ 0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,
+ 0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,
+ 0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,
diff --git a/media-sound/mangler/mangler-1.2.5-r1.ebuild b/media-sound/mangler/mangler-1.2.5-r2.ebuild
index bad5f2f06fcd..38b754f7ff44 100644
--- a/media-sound/mangler/mangler-1.2.5-r1.ebuild
+++ b/media-sound/mangler/mangler-1.2.5-r2.ebuild
@@ -33,7 +33,10 @@ RDEPEND="
DEPEND="${RDEPEND}"
BDEPEND="virtual/pkgconfig"
-PATCHES=( "${FILESDIR}/mangler-version-info.patch" )
+PATCHES=(
+ "${FILESDIR}/mangler-version-info.patch"
+ "${FILESDIR}/fix_ftbfs_narrowing_conversion.patch"
+)
src_configure() {
tc-export CC